LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-12-2004, 12:33 PM   #1
elluva
Member
 
Registered: Aug 2003
Location: Belguim, Ostend and Ghent
Distribution: Ubuntu
Posts: 600

Rep: Reputation: 30
Changing default locale/GNOME language


I'd like to have my GNOME in dutch, but since GNOME doesn't have a tool to configure the default language.
How do you do it?
How do you set up the system language?

I am running slackware 9.1 and took the full install...

tnx 4 all help,
elluva
 
Old 01-12-2004, 01:26 PM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
well....gosh, I've done this I should know. I even put my Gnome to show everything in one language, but use too some characters which didn't at first be there by doing some stuff with locales..

actually I don't, at least at this very moment, know/remember any way other than changing locales..LC_ALL, for example might do it? in terminal/shell, type

locale

to see your _current_ locale settings. I'm not completely sure, as I haven't dealt with these for a while, but you could try doing (in shell/terminal)

set LC_ALL LOCALENAME

where LOCALENAME is one of the locales in locales-directory (I'm not sure if it's the same on Slackware, but in Gentoo they're in /usr/share/i18n/locales/ so check that out - if you find lots of xx_XX@yy and xx:_XX -type files, then find your own like

set LC_ALL de_DE@euro

would use de_DE@euro -locale. but don't shoot me if it won't work

EDIT: I think, if you happen to screw up, you can recover with "unset" command in shell? I'd suppose so. the plain "set" command shows your current settings, or those that have been set (so LC_ALL won't necessarily be there yet)

Last edited by b0uncer; 01-12-2004 at 01:27 PM.
 
Old 01-12-2004, 01:44 PM   #3
elluva
Member
 
Registered: Aug 2003
Location: Belguim, Ostend and Ghent
Distribution: Ubuntu
Posts: 600

Original Poster
Rep: Reputation: 30
set LC_ALL nl_BE
doesn't do a thing, it doesn't even change the LC_ALL variable when I run locale it is still empty...
 
Old 01-12-2004, 02:45 PM   #4
elluva
Member
 
Registered: Aug 2003
Location: Belguim, Ostend and Ghent
Distribution: Ubuntu
Posts: 600

Original Poster
Rep: Reputation: 30
ok, I solved it, I added

export LC_ALL=nl_BE@euro
export LANG=nl

to /etc/profile
 
Old 01-13-2004, 02:14 PM   #5
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
ok...nice you could work it out I was just about starting to search through my files to see what I changed to get languages/charmaps changed, but now I don't have to (altough I still might, because it's useful)

I still think there's a locale file that tells the system what locales to use...maybe the "set" command just won't do the work (I had some doubts because I myself edited a file, and didn't use commands to set the locales).

I guess my next mission is to locate that file...
 
Old 01-13-2004, 02:20 PM   #6
elluva
Member
 
Registered: Aug 2003
Location: Belguim, Ostend and Ghent
Distribution: Ubuntu
Posts: 600

Original Poster
Rep: Reputation: 30
Maybe on gentoo, but there is no file to set up your locales in slackware.
I was making quite a quest here when suddenly I realised I could just put it in my profile...
(I am such an idiot sometimes )

Do you perhaps know the environment variable to set your keyboard layout as well?

Last edited by elluva; 01-13-2004 at 02:24 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 11 10-24-2018 05:54 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 03:34 AM
Changing the default language... njschroe SUSE / openSUSE 5 04-24-2005 01:44 PM
changing default from gnome to kde tzonga1 Red Hat 7 09-21-2004 01:53 AM
changing default gnome to kde bashrc2 Slackware 10 03-26-2004 01:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration