LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-04-2003, 04:29 AM   #1
bdika
Member
 
Registered: Aug 2003
Location: London, Canada
Distribution: Arch Linux
Posts: 60

Rep: Reputation: 15
Changing default browser in RedHat 9


I am using KDE and RedHat 9. I recently installed the MozillaFirebird web browser and would like to make it the default brower.

I have read in some posts (here and on Google) about editing the 'htmlview' script or creating an /etc/htmlview.conf file. I have tried to do both without any luck. The posts were not too clear on the details so I may have implemented them incorrectly.

I also tried to change the web browser in the 'Preferred Applications' preference tool in Gnome. Also without any luck.

When I downloaded and installed MozillaFirebird. It expanded into a folder under my download folder. I didn't see any script for it in /usr/bin/ as there is for Mozilla. This Mozilla script is referenced in the "htmlview' script.

Any help on how to change my default browser would be much appreciated.

Regards,
Bill Dika
 
Old 10-04-2003, 08:31 AM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
The easiest way to do this, is to rename the mozilla script in /usr/bin to mozilla-old or something and use this script below to make a "new" mozilla script
Code:
#!/bin/bash

/usr/local/MozillaFirebird061/MozillaFirebird -remote "openURL($@, new-tab)" ||
exec /usr/local/MozillaFirebird061/MozillaFirebird "$@";
Just change the directory locations to suit. This script opens Firebird if it's not open or opens a new tab in the existing window if it is.

If you are using Evolution as your mail client, edit the .gnome/Gnome file in your home directory to get Firebird to open links clicked.

HTH
Baldrick

Last edited by Baldrick65; 10-04-2003 at 08:32 AM.
 
Old 10-05-2003, 06:28 PM   #3
bdika
Member
 
Registered: Aug 2003
Location: London, Canada
Distribution: Arch Linux
Posts: 60

Original Poster
Rep: Reputation: 15
Many thanks Baldrick.

Your advice worked great with getting Firebird to be my default browser. However with regard to Evolution, I am unable to find a file named .gnome/Gnome on my computer.

Should I be looking for something else?

Regards,
Bill Dika
 
Old 10-06-2003, 05:10 AM   #4
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
The .gnome directory is hidden. For example: /home/<user>/.gnome/ If you are using Konqueror to view files, click on the View menu and click "Show Hidden Files". You should now be able to see the .gnome directory. The Gnome file is inside this directory.

HTH
Baldrick
 
Old 10-09-2003, 06:05 PM   #5
bdika
Member
 
Registered: Aug 2003
Location: London, Canada
Distribution: Arch Linux
Posts: 60

Original Poster
Rep: Reputation: 15
Thanks again Baldrick.

The file was right where you said it would be after showing hidden files.

This is what it says in the Gnome file:

[URL Handlers]
info-show=nautilus "%s"
man-show=nautilus "%s"
ghelp-show=nautilus "%s"

Should I replace the word nautilus with Mozilla in all cases. I am not sure which of these is for e-mail URLs.

Regards,
Bill Dika
 
Old 10-12-2003, 06:40 PM   #6
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
Yeah ... simply replace "nautilus" with "mozilla" in this section. If it doesn't exist, create it
Code:
[URL Handlers]
http-show=/usr/bin/mozilla "%s"
https-show=/usr/bin/mozilla "%s"
This should fix it.

Baldrick
 
Old 10-18-2003, 01:00 AM   #7
bdika
Member
 
Registered: Aug 2003
Location: London, Canada
Distribution: Arch Linux
Posts: 60

Original Poster
Rep: Reputation: 15
Many thanks again Baldrick.

Everything is working like a charm now.

Regards,
Bill Dika
 
Old 11-26-2003, 05:20 PM   #8
rprimmer
LQ Newbie
 
Registered: Oct 2003
Distribution: Shrike
Posts: 1

Rep: Reputation: 0
Baldrick, if i wished to make opera my default browser, should I run the same script you show above, only substituting "/usr/bin/opera" for "/usr/local/MozillaFirebird061/MozillaFirebird" in your example above?

thanks,
bob
 
Old 11-26-2003, 06:53 PM   #9
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
You can try, but I don't know if Opera will recognize the options (-remote "openURL($@, new-tab) etc.

Baldrick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing default Browser jgtg32a Mandriva 1 04-21-2005 04:14 PM
Changing default web browser BaltikaTroika Linux - Newbie 10 01-14-2005 04:40 PM
Changing default browser in Ximian Evolution 1.4 apache363 Linux - Software 5 05-12-2004 07:41 PM
Changing default browser in RH9... daemon_14 Linux - Software 1 08-16-2003 01:02 AM
Changing default Browser Crashed_Again Linux - General 3 01-29-2003 09:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration