LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-13-2004, 04:18 AM   #1
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
Change shell language


I've installed Aurox 9.4 (a Fedora Core 2 clone).
When I use the shell in gnome I have no problem, but when I switch to KDE my shell suddenly changes to greek(!!) Where do I change the shell language in KDE (only)?
 
Old 07-13-2004, 07:42 AM   #2
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
Have you tried setting the locale in the ControlCenter (kcontrol)?
 
Old 07-14-2004, 10:45 AM   #3
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993

Original Poster
Blog Entries: 1

Rep: Reputation: 46
Not sure I understand what you mean,but I'll look around...
 
Old 07-18-2004, 09:28 AM   #4
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993

Original Poster
Blog Entries: 1

Rep: Reputation: 46
STrange thing is the rets of KDE works fine and in English and I haven't got any problems with the shell when I use gnome...

Still haven't figured out how to get this straightened out
 
Old 07-24-2004, 03:16 PM   #5
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993

Original Poster
Blog Entries: 1

Rep: Reputation: 46
I'm still completely in the dark. The only config utility that I can think of /find that has anything to do with the shell language in KDE (and NOT in gnome) is what I've printed below.
Without the shell KDE is nice but not really any good to ma, but I'd like to be able to use it. Any ideas??

Code:
 [linmix@localhost config]$ cat /home/linmix/.kde/share/config/konsolerc
[$Version]
update_info=konsole.upd:kde2.2/r1,konsole.upd:kde3.0/r1
 
[Desktop Entry]
ActiveSession=0
AllowResize=false
BlinkingCursor=false
CtrlDrag=true
CutToBeginningOfLine=false
DefaultSession=shell.desktop
DynamicTabHide=false
EnableBidi=false
Fullscreen=false
Height 768=526
LineSpacing=0
SilenceSeconds=10
TabViewMode=0
TerminalSizeHint=false
WarnQuit=true
Width 1024=1025
XonXoff=false
bellmode=0
class=konsole-mainwindow#1
defaultfont=console8x16,12,-1,2,50,0,0,0,1,0
font=2
has frame=true
history=1000
historyenabled=true
keytab=default
schema=
scrollbar=2
tabbar=2
wordseps=:@-./_~
 
Old 07-24-2004, 07:57 PM   #6
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
The Control Center application I was referring to is kcontrol. It is usually accessible from the K menu as Settings|ControlCenter, or it can be invoke from a shell (possible difficult in your circumstances) as kcontrol.

On the left side of the ControlCenter application you should find a selection labeled "Country/Region & Language". With this selection active, on the right side of the ControlCenter application you should see a "Locale" tab. With this tab selected, you should see a drop down control where you can select your country and appropriate languages.
 
Old 07-25-2004, 04:06 PM   #7
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993

Original Poster
Blog Entries: 1

Rep: Reputation: 46
Ok. I found it at Preferences | more preferences | control center | Regonal & Accessibility | Country/Region & Language | Locale (tab) --> dropdown menu -- I have only Spansh and US English available, no greek anywhere to be seen.

If I change the language to Spanish, the shell menubar changes from English to Spanish, but the prompt is still in greek?!!

I checked all the hidden files in my /home folder but didn't find anything. This is really weird!
 
Old 07-26-2004, 12:24 AM   #8
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
Have you tried posting this problem on the Aurox site forums or bug tracking system?
 
Old 07-26-2004, 12:49 AM   #9
LavaDevil94
LQ Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 47
You could always try this terminal, it is way more lightweight and less of a resource hog:
http://aterm.sourceforge.net
 
Old 07-26-2004, 12:45 PM   #10
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993

Original Poster
Blog Entries: 1

Rep: Reputation: 46
Quote:
Originally posted by idaho
Have you tried posting this problem on the Aurox site forums or bug tracking system?
Yes I have, but thanks for poining it out anyway. That forum is dormant (especially compared to this one) and incredibly slow loading. You get an average of ONE message a day, maybe two if you post in multiple languages.

LavaDevil94 I'll check out aterm, but for now:

Found it!!

It's been driving me crazy until suddenly it struck me that the shell is never completetly "translated". If I change the system language to Spanish, the shell commands are still in English. So my shell wasn't in greek, I was only seeing Greek letters!! I changes the font and now everything is exactly the way it's supposed to be.

Last edited by linmix; 07-26-2004 at 12:48 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
difference between shell scripting and c language gadekishore Linux - Software 5 10-17-2005 06:33 AM
Convert shell scripts to other language vladmihaisima Programming 6 07-28-2005 02:25 AM
change language alaios SUSE / openSUSE 7 07-13-2005 08:48 AM
Change language rogk Linux - Newbie 1 04-19-2004 05:04 AM
under kde3 i change change language, where in gnome? sirpelidor Mandriva 1 12-10-2003 04:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration