LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-30-2009, 08:46 AM   #1
Uday123
Member
 
Registered: Nov 2005
Posts: 80

Rep: Reputation: 15
change HTTP default port -- Issue


Hi all,

I have changed the http default port from 80 to 8008(HTTP Alternate) in /etc/httpd/conf/http.conf file.
Code:
#Listen 80
Listen 8008
Restarted the httpd service and it is running.

But I am not able to see any welcome page while accessing from browser (http://xx.xx.xx.xx OR http://xx.xx.xx.xx:8008).

Is there anything else need to change to work for 8008 port? Please help me.

Thanks in advance.
 
Old 10-30-2009, 01:00 PM   #2
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

1. It *sounds* like you're doing everything correctly.
In general, all you need to do is update httpd.conf and restart.

2. Logged on locally, type:
Quote:
netstat -a | less
<= Make sure you've actually got an active listener on port 8008
You can also use "lsof" (a non-standard command - but easily available) to make sure THE listener is YOUR httpd daemon.

3. The *only* way you can connect is: . The standard "http://xx.xx.xx.xx", of course, will look for a listener on port 80 - and fail to find it.

4. Definitely try "http://localhost:8008", on your local machine.

If you can connect locally, but not from another client - check firewalls.

5. Of course, check your Apache and system logs.

'Hope that helps .. PSM
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PLESK [Solution] Change port to 23 (telnet) instead of default port 8443 x5452 Linux - Software 6 05-10-2009 05:58 AM
Change default port of Apache kanha Linux - Newbie 1 03-17-2009 11:40 PM
change grub boot order, all instructions say change default, but I don't see default mhg Linux - Newbie 5 11-09-2008 10:01 AM
cannot change ssh default port winkydo Fedora 5 04-22-2007 04:36 PM
turn off http port 80, keep https port 443 lothario Linux - Networking 6 02-11-2005 04:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration