LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-01-2014, 08:06 PM   #1
qajaq
Member
 
Registered: Sep 2008
Location: north-central Florida
Distribution: Lubuntu 19.04, Kubuntu 18.04
Posts: 116

Rep: Reputation: 15
Change default directory for 'open' and 'save' in KWrite?


I've done a good deal of searching on-line and haven't found an answer to this, so I'm guessing it's either so blindingly obvious (and I'm blinded) that it doesn't need explaining, or it's so arcane that nobody has asked it yet.

I use KWrite as a scratch-pad fairly often, and when I open or save a file the program initially defaults to my home Documents directory (~/Documents) until I tell it otherwise. That's not the directory I ever use, and although it's not a huge undertaking to move to the desired directory, it would be nice to have the computer do that for me. (Why we invented computers, no? To do stuff for us?)

Is there any way to either (a) set a different default directory, or (b) change the program's behaviour to always open the last-used directory the first time after opening the program?

I'm using KWrite in Kubuntu 12.04.
 
Old 03-01-2014, 09:44 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 16,752
Blog Entries: 27

Rep: Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082
Settings-->Configure Editor-->Open/Save-->Advanced-->Prefix.

Entering the desired directory in there seems to work. I tested by entering "~/Documents" (which exists in my system), saved the change, and, upon clicking "Save" on a new document, Kwrite pointed right at ~/Documents. I exited the program, restarted it, and clicked "Open," and the "open" dialog pointed to ~/Documents.
 
Old 03-01-2014, 09:59 PM   #3
qajaq
Member
 
Registered: Sep 2008
Location: north-central Florida
Distribution: Lubuntu 19.04, Kubuntu 18.04
Posts: 116

Original Poster
Rep: Reputation: 15
I may not have been clear: the ~/Documents directory is the built-in default that I want to over-write.

The place you entered "~/Documents" (Settings-->Configure Editor-->Open/Save-->Advanced-->Prefix) is a field that defines the prefix for back-up documents. I went there and added "/datalib/programming" (as I mostly use KWrite as a scratch-pad when writing scripts), closed KWrite then re-opened it, and clicked the "open file" icon. It still points initially to ~/Documents.

What I'm looking for is some way to have it open initially to my "/datalib/programming" directory.
 
Old 03-01-2014, 10:45 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 16,752
Blog Entries: 27

Rep: Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082
"Documents" was not my default in Kwrite, but I did only a quick test.

As for "/datalib/programming," did you try the full path (/[path-to]/datalib/programming)?
 
Old 03-01-2014, 10:52 PM   #5
qajaq
Member
 
Registered: Sep 2008
Location: north-central Florida
Distribution: Lubuntu 19.04, Kubuntu 18.04
Posts: 116

Original Poster
Rep: Reputation: 15
Yes, /datalib/programming is the full path.

If ~/Documents isn't the default Open/Save directory on your system, had you earlier set it to something different? Or did your flavor of Linux apply a different default directory?
 
Old 03-02-2014, 09:05 PM   #6
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 16,752
Blog Entries: 27

Rep: Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082
I tested on Mageia, and I thought the default was the home directory, but looking at again I think I was just wrong. If I remember, tomorrow I will take a longer look at it.

My apologies for wasting your time.
 
Old 03-03-2014, 02:26 PM   #7
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 16,752
Blog Entries: 27

Rep: Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082
I think I found something.

Again, this is on Mageia 4, KDE 4.11.4. The Document Path is an overall KDE setting, not a Kwrite setting:

On the KDE menu, go to Computer-->System Settings-->Account Details-->Paths. That's where you can set the default path for documents, as well as for type of files.

I also managed to get to it under Konqueror on E17 (my normal file manager on that computer), but was unable to recreate how I did it, as it was buried deep under Go-->Applications--etc.
 
Old 03-04-2014, 10:09 AM   #8
qajaq
Member
 
Registered: Sep 2008
Location: north-central Florida
Distribution: Lubuntu 19.04, Kubuntu 18.04
Posts: 116

Original Poster
Rep: Reputation: 15
Bingo! That did it -- Thank you!
 
Old 03-04-2014, 09:13 PM   #9
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 16,752
Blog Entries: 27

Rep: Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082Reputation: 5082
You're welcome. It was fun tracking it down--once I had tracked it down!
 
Old 03-04-2014, 09:15 PM   #10
qajaq
Member
 
Registered: Sep 2008
Location: north-central Florida
Distribution: Lubuntu 19.04, Kubuntu 18.04
Posts: 116

Original Poster
Rep: Reputation: 15
H1! I know what you mean. Troubleshooting is frustrating when I'm doing it, but once I find the fix, the gratification outweighs all that gnashing of teeth.
 
  


Reply

Tags
default, directory, kubuntu, kwrite


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change default vsftp anonymous accout directory /var/ftp to other directory? hocheetiong Linux - Newbie 2 01-24-2010 07:33 PM
Change default Save page directory on FF 2 suguru Linux - Software 4 06-28-2007 07:45 AM
konqueror default save directory bong.mau Linux - Software 2 03-27-2007 01:14 PM
How to change the save to directory in xsane royeo Linux - Newbie 0 09-24-2006 07:40 PM
change default save directory canyon289 Linux - Software 1 10-24-2004 01:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration