-   Linux - Software (
-   -   centrino driver install issue (

rnj 03-21-2005 09:36 PM

centrino driver install issue

I have installed debian linux 2.6.6 to my hard drive. I am trying to install the intel centrino drivers[linux version]. Untarred the ipw2200-1.0.1.gz
When i try make command, the following error occurs.
"make *** /lib/modules/2.6.6/build: No sucj file or directory. Stop
make *** [modules] Error 2 "

I tried mkdir a build directory under /lib/modules/2.6.6/, but it still gives the same error. My kernel is 2.6.6 and i have also tried modprobe ieee80211
modprobe firmware_class

Please help.


Hangdog42 03-22-2005 08:21 AM

You probably need to install the kernel source code. Just creating a directory isn't going to do the trick. I would imagine that you should be able to find the source code for your kernel through the ususal Debian methods, but you do need to be sure that the source code matches your kernel exactly. Run uname -a in a console if you're not sure what kernel version you've got.

rnj 03-22-2005 08:15 PM


thx. I am using the auditor linux from remote I tried finding the source code but it wasnt there. Can I install a source code of debian which matches my current kernel version. The kernel version is 2.6.6.


Hangdog42 03-23-2005 08:14 AM

You might be able to use the Debian kernel sources or you could download the 2.6.6 sources from However, it does seem odd that Auditor doesn't provide a package of source code for their kernel. Given it is aimed at security, I would imagine that they have done a fair bit of customization/hardening over the standard Debian kernel. By the way, in your first post, you said you are using Debian and in your second you are using Auditor. Can I ask which one you are actually using?

rnj 03-23-2005 10:07 AM

i am using auditor linux which i guess is based on debain
hi there,

i am using auditor linux which i guess is based on debain,coz when i boot the option of debian 2.6.6 is there....

thanks for the reply....I think auditor is still in its early stages...
I will try downloading the kernel.


All times are GMT -5. The time now is 09:32 AM.