-   Linux - Software (
-   -   CentOS 5.6 Sendmail - Send to 'other' SMTP server (

pshankland 08-17-2011 10:13 AM

CentOS 5.6 Sendmail - Send to 'other' SMTP server

I am having a few problems with configuring Sendmail on a fresh install of CentOS 5.6 32Bit and was after some help.

I have a couple of CentOS boxes installed and want them to send Emails to my domain account via our existing internal Lotus Domino SMTP server. I have followed a lot of online documents about how to configure this (such as but when I try am not even getting anything in my SMTP servers logs for a connection.

What I have basically done is uncomment the following:

define(`SMART_HOST', `your-smtp-server')

and added the IP address of my SMTP server (have tried FQDN as well). The SMTP server doesn't require authentication so I assume I don't need to do anything else than above. I have then completed the following:

m4 /etc/mail/ > /etc/mail/

and then restarted sendmail. When I then try "sendmail -bv peter.shankland@domain.tld" I get the following:

peter.shankland@domain.tld... deliverable: mailer relay, host, user peter.shankland@domain.tld

which looks hopeful. However, now when I run "sendmail peter.shankland@domain.tld" I don't get anything delivered. I have telnet'd (on port 25) into the SMTP server with no problems from the CentOS box so it isn't an access issue.

Any suggestions?


pshankland 08-17-2011 10:15 AM

I forgot to include the undeliverable mail info:

Date: Wed, 17 Aug 2011 16:11:54 +0100
From: Mail Delivery Subsystem <MAILER-DAEMON@ntp1.domain.tld>
To: <ts-admin@ntp1.domain.tld>
Subject: Returned mail: see transcript for details
Auto-Submitted: auto-generated (failure)

[-- Attachment #1 --]
[-- Type: text/plain, Encoding: 7bit, Size: 0.4K --]

The original message was received at Wed, 17 Aug 2011 16:11:54 +0100
from localhost.localdomain []

----- The following addresses had permanent fatal errors -----
(reason: 550 Host unknown)

----- Transcript of session follows -----
550 5.1.2 <peter.shankland@domain.tld>... Host unknown (Name server: host not found)

[-- Attachment #2 --]
[-- Type: message/delivery-status, Encoding: 7bit, Size: 0.3K --]

Reporting-MTA: dns; ntp1.domain.tld
Received-From-MTA: DNS; localhost.localdomain
Arrival-Date: Wed, 17 Aug 2011 16:11:54 +0100

Final-Recipient: RFC822; peter.shankland@domain.tld
Action: failed
Status: 5.1.2
Remote-MTA: DNS;
Diagnostic-Code: SMTP; 550 Host unknown
Last-Attempt-Date: Wed, 17 Aug 2011 16:11:54 +0100

[-- Attachment #3 --]
[-- Type: message/rfc822, Encoding: 7bit, Size: 0.5K --]

Date: Wed, 17 Aug 2011 16:11:51 +0100
From: ts-admin@ntp1.domain.tld




pshankland 08-18-2011 02:23 AM

Sorry to bump but anyone got any suggestions?


bathory 08-18-2011 03:04 AM



550 5.1.2 <peter.shankland@domain.tld>... Host unknown (Name server: host not found)
Your domain (domain.tld) does not have an MX record to point to your mailserver, or the nameserver in /etc/resolv.conf cannot find it.
Can you send email to or other external mail server? And what gives:

dig mx domain.tld
Also, you can put the IP address of your smarthost into square brackets, so sendmail doesn't try to resolve it.

define(`SMART_HOST', `[]')

pshankland 08-18-2011 03:33 AM

Hi, thanks so much for the reply :)


define(`SMART_HOST', `[]')
Worked perfectly!!


All times are GMT -5. The time now is 10:31 AM.