-   Linux - Software (
-   -   cedega steam mouse issue "fixed" (

oldsko0l 10-16-2006 03:58 PM

cedega steam mouse issue "fixed"
Hi I was having troubles with my mouse when I was playing games on steam on cedega (for example counter-strike)
the mouse didn't want to dissapear from my screen (so I had a mouse in my crosshair), In the menus the mouse didn't work either like it should. (It pointed to high)

here's the work around -->

In the profile configuration, use the option to play in a window. and hide your taskbar so it does not get in the way. Then the mouse works properly.

I hope this helps some other guys.

Maybe you have a better work around --> post it here plz ;)


Electro 10-16-2006 04:10 PM

I think X11 defaults to hardware cursor. You could try software cursor and see if that helps. If you want the mouse cursor to ungrab from a window, you can add Option "AllowDeactivateGrabs" "true" in the server flags section in xorg.conf or XF86Config that is located in /etc/X11. To upgrab after this setting, hit CTL+ALT+/. I think this is line is for Xorg version 7.

oldsko0l 10-17-2006 12:47 AM

How do I make from a hardware mouse a software mouse? :p

& in what section do I have to ad Option "AllowDeactivateGrabs" "true" in xorg.conf?


oldsko0l 10-18-2006 09:31 AM

can u answer please? thank you

Electro 10-18-2006 06:46 PM

I already state where. It seems you just skimmed my post. Read it carefully.

For the hwcursor option, place the following in the device section.
Option "HWCursor" "off"

This will use software cursor. By turning it on, it will deactivate software cursor and use hardware cursor.

Though it could be dpi setting that is confusing the game. If you are using a nVidia video card and using its module, include the following in the driver section.

Option "UseEdidDpi" "false"
Option "DPI" "96 x 96"

BTW, I tried CTL+ALT+/ in Half-Life, the first version, and it does not work. I tried in other games like Starcraft and it works. I also tried in native programs like mupen64, an Nintendo64 emulator, and it worked.

oldsko0l 10-19-2006 02:34 PM

thank you, but still I have a problem..
I don't have a server flag section, and I don't have a driver section (I do have "driver" in the device section)

I don't want to sound stupid, but could you give me an example how to make this sections (so that xorg.conf is still right)

thanks a lot ;)

All times are GMT -5. The time now is 04:02 AM.