-   Linux - Software (
-   -   cdrecord (scsi emulation) (

HwzrHlslndr 12-31-2002 05:22 PM

cdrecord (scsi emulation)
For cdrecord command I need to use scsi emulation. For this I have added the following to /etc/modules.conf:

options ide-cd "ignore=hdc ignore=hdd"
alias scd0 sr_mod
alias scd1 sr_mod
pre-install sg modprobe ide-scsi
pre-install sr_mod modprobe ide-scsi
pre-install ide-scsi modprobe ide-cd

This enables me to use the cdrecord command--although I am having other issues with it--but I find that I have to go back and comment out these lines in /etc/modules.conf and then reboot in order to play the CD I've just recorded to (or tried to).

On an older machine with a dual boot--winbloz/LINUX--I had no problem such as this. The only difference I can think of being RH 7.2 on the older machine and RH 8 on this one.

Any suggestions?

Happy new year to you, friends all.


wdingus 12-31-2002 06:22 PM

Interesting.. I've never enabled ide-scsi emulation that way, I've always done so by passing the parameter to the kernel via lilo or grub. This is from a RH8 machines /etc/grub.conf file:

title Red Hat Linux (2.4.18-19.8.0)
root (hd0,0)
kernel /vmlinuz-2.4.18-19.8.0 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.18-19.8.0.img

HwzrHlslndr 12-31-2002 06:35 PM


The contents of my /etc/grub.conf file are as follows:

password *************************************************
title Red Hat Linux (2.4.18-14)
root (hd0,0)
kernel /vmlinuz-2.4.18-14 ro root=LABEL=/
initrd /initrd-2.4.18-14.img

I notice the main difference between yours and mine is the missing "hdc=ide-scsi" after "...root=LABEL=/"

I wonder, should I be editing this file to reflect hdc=ide-scsi? And if so, what about the cdrom which is hdd? How would I distinguish between the two?

Kind regards to you and happy new year.

acid_kewpie 12-31-2002 06:48 PM

yes you need to add that to your boot loader. only required for teh bruner itself, not any otehr drives.

HwzrHlslndr 12-31-2002 07:27 PM


I do appreciate your comments. I have added "hdc=ide-scsi" to that line in my grub file and cdrecord is now cool. I realize now that the approach I was taking was affecting my CDROM on reboot. Seeing as how I do not care to play music on my CDR, the question of how to differentiate between the CDROM and CDR in the grub file is moot. I cannot tell you how much I appreciate your comments.

Have you any other expertise regarding cdrecord? If so, I am getting the following when trying to burn a song:

cdrecord: Bad audio track size 6002539 for track 01.
cdrecord: Audio tracks must be at least 705600 bytes and a multiple of 2352.
cdrecord: See -pad option.

(the pad option info doesn't mean much to me so far)

I confess, I have not done much reading on cdrecord since I loaded RH8. I did a lot of burning with RH7.2 and will figure it out as time permits. Just thought I'd ask, as I felt maybe I found a cdrecord guru in you ; )

Cheers, my friend. (and thank you again!)

Happy new year!


acid_kewpie 12-31-2002 07:37 PM

well the pad option will just fill out the data track so that it is "705600 bytes and a multiple of 2352".

personally i'm amazed you managed to read my reply, my typing can get so so lazy at times! and thanks for the affero...

HwzrHlslndr 01-02-2003 05:46 AM


I am sitting here at work and was just thinking about the above fix we implemented on New Years eve. I think maybe I had too much wine, because something just occurred to me... If I want to rip a CD using the CDROM doesn't it also have to emulate scsi? (Based on my reading I think it does.) And if the answer is yes, then I am back to one of my earlier questions, which is how to specify both CDRW and CDROM for scsi emulation? Maybe with the following?:

...root=LABEL=/ hdc=ide-scsi hdd=ide-scsi

Kind regards,

MasterC 01-02-2003 06:00 AM

To rip a CD? If you mean you need scsi emulation to rip an audio CD to your HD, I don't think so. Depending on the program (I use grip) it gives you a place to show the device to use for ripping. You can specify a scsi or standard drive.

As for copying CD's, yeah, it appears that some programs require both drives to use scsi emulation, although this is not necessary. You can copy a cd via the command line using cdrecord (Acid taught me this, thanks Acid :) ):
dd if=/dev/cdrom | cdrecord dev=0,0,0 speed=40 -v -eject -

The last - is the thing that I wasn't aware of. This means to get the info from stdin. Now I have no idea what stdin is, other than it's the output of dd.

But yeah, that's how you'd do it (hdd=ide-scsi hdc=ide-scsi).


HwzrHlslndr 01-02-2003 06:07 AM

MasterC (and Acid by proxy),

Thanks. I will give this a try after work. (I have no Linux in the office. aarrgh)


acid_kewpie 01-02-2003 06:11 AM

many cdrecord interfaces only use scsi cdrom drives as source drives, e.g. eroaster, so if you want to be able to clone cds in those applications then you will want to enable the emulation, however you don't need it for what you want.

HwzrHlslndr 01-02-2003 07:14 AM

Well, it's not like I have been doing this for years, but what I have used in my short few months has been cdparanoia. I guess I'll see what it likes when I get back to my baby (computer).

I would love to find a database of Linux apps complete with descriptions. Do you know of some definitive source like that? For example, I know what cdparanoia is because a book that I own discusses it specifically, but this is the first time I've heard of eroaster. (Maybe this kind of knowledge can only come with time...)

Cheers, my friend!

acid_kewpie 01-02-2003 07:16 AM

well there's nothing really definitive... check sourceforge / tucows / icewalkers etc...

jpsrm 01-06-2003 07:13 PM

Hi there!

I have both my CD-RW and DVD drives emulated by SCSI.
I'm running RedHat 8.0!!!

options ide-cd ignore=hdc ignore=hdd
alias scd0 sr_mod
alias scsi_hostadapter ide_scsi
probeall scsi_hostadapter ide-scsi ide_scsi

kernel /boot/vmlinuz-2.4.18-19.8.0 ro root=/dev/hdb2 hdc=ide-scsi hdd=ide-scsi

Everithing is working fine!

PS: should I have like you "alias scd1 sr_mod" too???

HwzrHlslndr 01-11-2003 06:50 AM


No. In fact all of the lines I referenced in my original post I have commented out of /etc/module.conf.

HwzrHlslndr 01-11-2003 06:54 AM

#The following SIX (6) lines (after this comment) were added by me on or around 12/30.
#They have been replaced by the "hdc=ide-scsi" entry in the
# "kernel /vmlinuz-2.4.18-19.8.0 ro root=LABEL=/ hdc=ide-scsi" line of /etc/#grub.conf
#options ide-cd "ignore=hdc ignore=hdd"
#alias scd0 sr_mod
#alias scd1 sr_mod
#pre-install sg modprobe ide-scsi
#pre-install sr_mod modprobe ide-scsi
#pre-install ide-scsi modprobe ide-cd

All times are GMT -5. The time now is 10:23 PM.