-   Linux - Software (
-   -   cd writing is broken since upgrading to 2.6 kernel (

chewbar 08-25-2004 03:16 PM

cd writing is broken since upgrading to 2.6 kernel
I recently installed the kernel. I did this so I could use a driver for my wireless lan stick, but that's another story...

Since doing this I noticed in my startup messages: ide-scsi is deprecated use ide-cd instead
(or something like that).

After a short google I found that the 2.6 kernel provides ATAPI access directly to cd burners without scsi emulation. Great I thought.. and tried the new setting.
The problem is that although cdrecord and cdrdao are perfectly happy and seem to work, the disks made are bad.

I burnt an audio CD and the sound was popping and buzzing - it certainly wasn't correct. This isn't a one off because I've tried a few times and tried upgrading cdrecord to the newest version etc.

Turning back on ide-scsi emulation solves the problem but I just wondered if anyone else has experienced problems like this.

Maybe it's my aged CD burner - a TEAC CD-W54E. ??

Any comments appreciated.

Not now, John! 08-25-2004 05:43 PM

Go to and read under News section.
K3B won't work with kernel 2.6.8.
Apparently kernel 2.6.8 also has a memory leak that causes audio CD-s to be baddly burnt.

amosf 08-25-2004 06:34 PM

You have to edit the kernel source to get the cd burner to work in

in you linux source source directory edit the file


and comment out lines 196 and 197 as such

/* if (verify_command(file, cmd))
return -EPERM;

then recompile (delete scsi_ioctl.o or make clean so that this is recompiled) and then it works fine...

This edit remooves a new security feature introduced in and make it opperate like previous kernels - which is better than running k3b as root...

chewbar 08-26-2004 01:07 PM

The issue for me was never running as root. Actually I only ever use cdrecord and cdrdao from the command line (as root) anyway. The new setuid security feature doesn't affect me - I don't use a gui like k3b.

From what I've seen the problem I'm having doesn't seem to be affecting anyone else. I can burn a CD with no errors or memory issues but the CD turns out to be a coaster!

I wonder whether I've screwed up the kernel config - it's not a totally straightforward transition from 2.4 to 2.6 series kernels.

amosf 08-26-2004 05:54 PM

I would suggest going to kernel 2.6.7 to try and minimize the possible problems and figure if it's your cd burner or the kernel... 2.6.7 doesn't have the features which confuse the issue.

Not now, John! 08-28-2004 05:31 AM

It doesn't matter if you don't use K3b (it's just frontend for cdrecord, cdrdao etc.).
Problem you have is kernel bug (in 2.6.8 and
Try instaling 2.6.9rc or 2.6.7.

chewbar 08-28-2004 05:08 PM

Just to let you guys know that I've gone back to 2.6.7 kernel.

Everything works fine without having to use ide-scsi.

Thanks for your help. Hopefully this issue is fixed in future kernel releases.

All times are GMT -5. The time now is 07:05 AM.