LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-17-2007, 09:02 AM   #1
varaahan
Member
 
Registered: Jul 2005
Location: chennai, india
Distribution: Puppy, Arch Linux,Absolute Linux
Posts: 83

Rep: Reputation: 15
CD burning problem


In absolute linux , when I tried to burn an iso image, I got the error msg
"cdrecord has no permission to open the device".
How to correct this ?
 
Old 08-17-2007, 09:16 AM   #2
otoomet
Member
 
Registered: Oct 2004
Location: Tartu, Ċrhus,Nürnberg, Europe
Distribution: Debian, Ubuntu, Puppy
Posts: 619

Rep: Reputation: 45
I am not sure about absolute linux, but perhaps you have to have suitable permissions? In debian, you have to give the user permission to use the cd drive. Check it!
 
Old 08-17-2007, 09:17 AM   #3
varaahan
Member
 
Registered: Jul 2005
Location: chennai, india
Distribution: Puppy, Arch Linux,Absolute Linux
Posts: 83

Original Poster
Rep: Reputation: 15
The fstab has users,auto options for cd drive.
 
Old 08-17-2007, 09:34 AM   #4
otoomet
Member
 
Registered: Oct 2004
Location: Tartu, Ċrhus,Nürnberg, Europe
Distribution: Debian, Ubuntu, Puppy
Posts: 619

Rep: Reputation: 45
In debian, if you look at user properties in gnome, there is something like "may use cd-rom drive" or something like that. You have to check this option, AFAIR.

Basically, you should find out which groups there exist. The easiest way were to use the grphical utilities of a modern desktop environment (something like "users and groups" in the "configure" menu in gnome). Several linux distros, including debian (no idea about absolute) limit the use of peripherials to members of certain groups. Make yourself memeber of relevant groups.

Best,
Ott
 
Old 08-17-2007, 02:39 PM   #5
mlitty
Member
 
Registered: Nov 2004
Posts: 40

Rep: Reputation: 15
I'm also a debian/Ubuntu user, so I'm not exactly sure how absolute linux manages user permissions. It's more than the way fstab mounts drives, especially since a blank disk isn't really mounted (I'm pretty sure), so fstab wouldn't affect burning.

Usually this has to do with the permissions set on the devices in /dev. For instance, if your burner is /dev/hdc (Secondary IDE, Master), then the device /dev/hdc has a user and group owner and some permissions. Mine look like this.

brw-rw---- 1 root cdrom 22, 0 2007-08-17 12:34 /dev/hdc

So in my system, root owns the burner and can read/write (the first rw). The group cdrom also has permissions to read/write (the second rw). The last three dashes in the "brw-rw----" are the "other" permissions. This is what everyone who is not root and not in the cdrom group can do. In this case, they can't do anything.

Since I don't want to run all of the time as root, I had to make sure that my user account in in the cdrom group so that I can use the optical drives. The User/Group settings interface/GUI is the easiest way to do this. My Ubuntu uses Gnome as a desktop, but KDE and XFCE also have User/Group management GUI tools.

In Gnome, it's under System>Administration>Users and Groups. I think it's also in the Gnome Control Panel, or wherever the main settings are for your system. Under users, check either the permissions or group memberships for your user, and make sure you're in the one that has permissions for your optical drives.

On most systems, your optical drives are either /dev/hdb (Primary IDE, Slave), /dev/hdc (Secondary IDE, Master), or /dev/hdd (Secondary IDE, Slave). You can see who owns them and their permissions, as seen on mine above, by going to a terminal and typing
Code:
ls -l /dev/hdb /dev/hdc /dev/hdd
root probably owns the devices, but look at the next name, the group name, and make sure you're in it.
if you want to see what groups you are currently a member of, go to a terminal and type
Code:
groups username
where username is your username.

Let us know how this works out.
 
Old 08-19-2007, 08:39 AM   #6
varaahan
Member
 
Registered: Jul 2005
Location: chennai, india
Distribution: Puppy, Arch Linux,Absolute Linux
Posts: 83

Original Poster
Rep: Reputation: 15
See the following output:

root: /home/sridhar > ls -l /dev/hdc
brw-rw---- 1 root cdrom 22, 0 2007-08-19 23:22 /dev/hdc
root: /home/sridhar > chmod 777 /dev/hdc
root: /home/sridhar > ls -l /dev/hdc
brwxrwxrwx 1 root cdrom 22, 0 2007-08-19 23:22 /dev/hdc
root: /home/sridhar > groups sridhar
users disk audio video cdrom haldaemon
root: /home/sridhar >

Still I get "cdrecord has no permission to open the device"

I am perplexed.
 
Old 08-19-2007, 11:31 PM   #7
mlitty
Member
 
Registered: Nov 2004
Posts: 40

Rep: Reputation: 15
I see you've also posted at the Absolute Linux Forums. I was going to suggest that, as this seems distro specific. At least, I've not hat this issue in a long while. I do remember that KDE has some utility to fix the permissions for Optical Burning. I think it was a utility with K3b, but I'm not sure what it was.... I'm not in my linux system right now, so I can't go look it up, but if you do a package search for k3b, there should be something there that describes setup or config or something like that.

You could also try a different cd burning program to see if it's an issue with a particular program or with the user account. It's a bit beyond me, but I think programs get permissions similar to users. It could be that the program your burning with is messed up in it's permissions. Some good programs are K3B, GnomeBaker, Brasero.

There's a decent article on the Gnome burners at http://www.freesoftwaremagazine.com/...ome?page=0%2C0

If security isn't an issue, you could try the suid trick suggested in the other forum. Though I would suggest finding a more secure solution.
 
Old 11-16-2007, 09:55 AM   #8
sadiqdm
Member
 
Registered: Nov 2003
Location: London, UK
Distribution: openSUSE, Ubuntu
Posts: 358

Rep: Reputation: 35
Found the same problem today - K3B, KDE 3.5.7, Suse 10.2. It was all working fine about a week ago. Since then there have been some security updates, including k3b.

I had a look at the permissions for my cd-writer on /dev/hdc, and found:
Code:
brw-rw----+ 1 root disk 22, 0 Nov 16 12:27 hdc
Opened YaST and went to User Management, and added myself to the "disk" group. Re-booted and all came good again. The security update must have changed the way the permissions work.
 
Old 11-16-2007, 08:44 PM   #9
varaahan
Member
 
Registered: Jul 2005
Location: chennai, india
Distribution: Puppy, Arch Linux,Absolute Linux
Posts: 83

Original Poster
Rep: Reputation: 15
bUT MY DEVICE HAS "CDROM" GROUP MENTIONED AND I ALREADY BELONG TO THAT GROUP.
STILL THE PROBLEM PERSISTS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Burning Problem Rustylinux Linux - Software 3 07-16-2007 04:58 PM
Burning cd trouble: hardware problem or software problem argt Linux - Hardware 2 04-20-2005 06:27 PM
CD burning problem delta_simon Linux - Software 1 11-10-2004 09:56 AM
audiocd burning problem, whole system hangs while burning ichbinesderelch Linux - Software 1 11-14-2003 03:30 PM
CD Burning Problem CrazySteve Slackware 20 10-26-2003 01:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration