LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-29-2005, 12:10 PM   #1
benchcomptons
LQ Newbie
 
Registered: Jul 2003
Posts: 29

Rep: Reputation: 15
CD Burning on 2.4.26


I am trying to get my computer to burn CDs. When I run cdrecord I get

bash-2.05b# cdrecord -scanbus
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J�rg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

From this I figure that I need to enable ide-scsi emulation, so I edited lilo.conf, but now:

bash-2.05b# dmesg | grep scsi
Kernel command line: auto BOOT_IMAGE=Linux ro root=302 cdrom = ide-scsi
ide_setup: ide-scsi -- BAD OPTION
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
scsi0 : SCSI host adapter emulation for IDE ATAPI devices

so I don't think that it worked. I can't figure out the BAD OPTION. Also,

bash-2.05b# cat etc/fstab
/dev/hda1 swap swap defaults 0 0
/dev/hda2 / reiserfs defaults 1 1
/dev/hdb1 /home reiserfs defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro,user 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,user 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

and,

bash-2.05b# lsmod | grep scsi
ide-scsi 9328 0

After some searching I think that I need to recompile my kernel with ide-scsi emulation into it.
But, I have never done a kernel recompile before so this makes me nervous...
Is this even the right way to go? My goal is to get cdrecord working.

By the way I am using Slackware 10
 
Old 05-29-2005, 12:23 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977
i'd think that the "bad option" is the reference to "cdrom" rather than the real ide device, i.e. hdb, hdc or hdd most likely. I'd also suggest removing the spaces either of the =, not sure if it actaully matters at all though.

ide-scsi isn't something normally left out of a 2.4 kernel, but if you do end up looking at recompiling a kernel, i'd VERY VERY strongly recommend you don't. instead build a 2.6 kernel, which doesn't need ide-scsi stuff anyway, and gives vastly improved burner performance as a result.

i'm not a slack user at all, but i'm sure slack does at least include a 2.6 kernel nowadays.
 
Old 05-29-2005, 12:30 PM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 250Reputation: 250Reputation: 250
You might have the ide-scsi module loaded but do you have it specifying what devices should be using it at bootup from your lilo.conf file in the correct format?
 
Old 05-29-2005, 02:30 PM   #4
benchcomptons
LQ Newbie
 
Registered: Jul 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Alright good, removing the spaces around "=" got rid of BAD OPTION. Now,

bash-2.05b$ dmesg | grep scsi
Kernel command line: auto BOOT_IMAGE=Linux ro root=302 cdrom=ide-scsi
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
scsi0 : SCSI host adapter emulation for IDE ATAPI devices

I still have the same problem with cd record.

Maybe getting the 2.6 kernel would be an instant fix to everything. How do I go about doing that?

Also, here is what my lilo.conf looks like:

image = /boot/vmlinuz
root = /dev/hda2
append = "cdrom=ide-scsi"
label = Linux
read-only
 
Old 05-29-2005, 03:18 PM   #5
CrEsPo
Member
 
Registered: Apr 2005
Location: Canada
Distribution: Slackware 12
Posts: 184

Rep: Reputation: 30
To update to the generic 2.6 kernel use these steps:

http://www.linuxquestions.org/questi...hreadid=327786

To compile your own try these steps:

http://www.linuxquestions.org/questi...hreadid=127095
 
Old 05-29-2005, 05:00 PM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 250Reputation: 250Reputation: 250
Quote:
append = "cdrom=ide-scsi"
This line should go before your image section and why are you using cdrom.. should be your actual device name.. like hdc or something.
 
Old 05-29-2005, 05:34 PM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977
isbn't that what i said first time, drew??
 
Old 05-30-2005, 12:57 AM   #8
benchcomptons
LQ Newbie
 
Registered: Jul 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Awesome! Upgrading to the 2.6 kernel did it.

bash-2.05b# cdrecord -scanbus
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) 'SONY ' 'CD-RW CRX100E ' '1.0m' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

Thanks
 
Old 05-30-2005, 03:42 AM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977
no, hang on, that's still using scsi emulation isn't it??? you should *NOT* be using ide-scsi on a 2.6 kernel. instead it's direct to the IDE driver via ATAPI:
Code:
kermit chris # cdrecord -scanbus -dev=ATAPI
Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
cdrecord: Warning: Running on Linux-2.6.10-kermit-r1
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
scsidev: 'ATAPI'
devname: 'ATAPI'
scsibus: -2 target: -2 lun: -2
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
Using libscg version 'schily-0.8'.
scsibus0:
        0,0,0     0) 'SAMSUNG ' 'DVD-ROM SD-616Q ' 'F401' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
don't get this far and then go wrong!
 
Old 05-30-2005, 10:40 AM   #10
benchcomptons
LQ Newbie
 
Registered: Jul 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Yeah, lots of stuff went wrong. It turns out that I did not even have the 2.6 kernel installed so I did that part wrong. But, in the process of doing it, something happened and I can burn CDs now. Since I only want to back up some stuff before switching out my hard drive, this is good enough.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cd burning anyone? matthewa Slackware 12 09-02-2005 08:02 AM
No cd burning in 10.1. Maintech Mandriva 4 01-19-2005 02:35 AM
audiocd burning problem, whole system hangs while burning ichbinesderelch Linux - Software 1 11-14-2003 03:30 PM
cd burning s/w ksd Slackware 11 10-21-2003 12:34 PM
CD-Burning slurride Slackware 16 03-14-2003 08:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration