-   Linux - Software (
-   -   CD Audio problems (

cjergl 10-30-2001 01:24 PM

CD Audio problems
I'm really new to Linux. I'm running RedHat 7.1 with the Gnome interface. The problem I have is that I cannot hear the audio from my CD drive. System sounds work, the cd drive works, the cd player is playing the track and logging the time elapsed, but I have no sound. It has the message No CDDB found.

I tried /etc/resolv.conf but I am told I don't have permission even though I am logged on as root.

Can anyone point me in the right direction?



adirotaru 10-30-2001 02:13 PM

Check please if you have the cable between your CD drive and your sound card.
For audio Cd it is very important.


cjergl 10-30-2001 08:41 PM

Thanks for the suggestion, however both my CD drives work fine in Windows. If I plug in headphones directly to the CD I can hear the audio and sndconfig has detected my soundcard (VIA Tech). Any other suggestions?

Thank you,


linuxcool 10-30-2001 09:06 PM

Maybe the volume for the cdrom drive needs to be turned up. See if there a program on one of the menus to adjust sound. In kde, it's sound mixer.

cjergl 10-30-2001 09:13 PM

Thanks for your suggestion. I've put all my volumes at max including both gnome and KDE mixers, as well as speaker volume; to no avail. I've also tried the KDE, Gnome and X CD programs.

I was digging and somewhere I read about something along the lines of... make sure /dev/audio device has audio as group. Anyone know what this means, or whether or not it's relevant to my problem?

Thank You,


linuxcool 10-30-2001 09:21 PM

I believe what they mean by that is you put the audio devices in the group ' audio ' and then you add the user to the group. What some people would do, was to change the permissions of the audio devices to ' 666 '. That would allow everyone access to the audio. Check to see if the audio devices already belong to the group ' audio '. Do an ' ls -l /dev/audio ' and see what group it belongs to.

cjergl 10-31-2001 08:41 PM

When I run 'Is -I/dev/audio', the return is

'bash: 'Is' command not found'.

Any thoughts?



michael_hoare 10-31-2001 09:42 PM

command not found - Is
It looks like you are trying to use "Is" not "ls" - an error caused by misreading a san serif font. In other words, use the command ls (as in LS but lower case). This is equivalent to "dir" in DOS.

ls lists directory contents without detail or hidden files
ls -l lists directory contents with detail but not hidden files
ls -a lists without detail, but with hidden files
ls -al lists with detail and hidden files

man ls will provide further help (manual on ls command)

I suggest you need to learn some basic LINUX/UNIX commands. The graphical interface for LINUX doesn't really avoid the need for this knowledge. In this sense (ONLY!!!) it is similar to Windows 3.1 over DOS, in that the GUI is only an overlay, and the action is taking place in the command line layer.

linuxcool 10-31-2001 10:23 PM

As michael_hoare said, they are both lower case L's. So, try this command again.

ls -l /dev/audio

cjergl 10-31-2001 10:28 PM

Thank you, that's very helpful. The CD problems offered me a practical problem to get me further into understanding Linux. I agree that I need to learn more basic commands; like I said, I'm really new, and I feel like I'm groping in the dark. I'm finding it difficult to find sources for good *basic* information on Linux and how to operate it. In anycase, pointing out the 'man' command was very helpful. Thank you... I'm going to put the CD audio problem aside for a bit and explore 'man' to get a better grip on the basics.

This site is great!

Thanks again,


All times are GMT -5. The time now is 02:02 AM.