-   Linux - Software (
-   -   Can't type in Java applet using Firefox? (

JamieBrown 04-24-2005 08:30 PM

Can't type in Java applet using Firefox?

I've installed Java on Firefox and it works fine, except in applets that require keyboard input. The key one for me is GoToMyPC - when it gets to the "login to your PC" dialog I can't type a password. However I have tried other applets - for example:

... which was on the Java site as a showcase. I can select the test that I want to view fine but when it comes to typing it just doesn't do anything.

Has anyone else seen this problem / have a solution?



adz 04-25-2005 12:57 AM

Try clicking on the titlebar. That helps sometimes. I notice I get something like that whenever the java runtime enviroment gets loaded and it seems to take focus away from the window that should have it,

JamieBrown 04-25-2005 06:33 AM

Hi! Thanks very much for your response. Unfortunately - that's not the problem. I've tried focusing the browser window, clicking on the java applet, clicking lots on the text box itself, and still nothing. It just don't work! :-( I think that since this doesn't seem like a common problem I'm going to try uninstalling the J2RE 1.5.0 and re-installing it. Maybe my Java installation is corrupt. If it works, I'll let you know! :)

Nobber 04-25-2005 06:37 AM

I had this problem with the Java applet my online bank used to use. The workaround was to keep pressing TAB (or Shift-TAB) until the keyboard focus landed on the field I wanted to type in. Either that, or type the text somewhere else, copy it into the X clipboard, and click the middle mouse button over the required entry field.

JamieBrown 04-25-2005 06:48 AM

Hello! Thanks to both of you for your suggestions. Unfortunately neither worked - I've tried reinstalling the JVM with the latest version from the Sun website but that didn't make a difference. And I think my problem must be different from yours, Nobber, because the Java applet doesn't respond to the Tab button at all - its like my keyboard just doesn't exist. But the applet hasn't frozen - I can still click on stuff with the mouse. I've played around a bit and this seems to happen in all Java applets, not just the GoToMyPC one.

Anyway - I'll have a play around again later, but in case anyone has any further ideas - I'm using a Dell Inspiron 510m laptop (just using the standard laptop keyboard - nothing fancy), and I'm running Fedora Core 3 and Firefox v1.0.3. The Java VM I've got is v1.5.0_01.

Cheers! :)


balpaudyal 05-11-2005 08:01 AM

Did anybody solve this problem? I am still having this problem. I discovered a site, where an applet had a choice "Float" and it floated the applet and detached from the Firefox. There keyboard input works just fine. My system is FC3 with all the lates updates applied. JRE1.5, Firefox-1.0.3.

enoxard 05-12-2005 09:58 PM

i have the same prob.

Linux akira 2.6.11-1.14_FC3smp #1 SMP Thu Apr 7 19:38:19 EDT 2005 i686 athlon i386 GNU/Linux

lrwxrwxrwx 1 ews ews 72 May 12 20:26 -> /usr/java/j2sdk1.4.2_06/jre/plugin/i386/ns610-gcc32/

on some of the applets i try to use, values in dropboxes seem to be encoded and appear as rectangles.


balpaudyal 05-18-2005 11:23 AM

export LANG=UTF-8 in terminal before starting firefox solved keyboard entry problem in Java Applet. My default was LANG=en_US.UTF-8. But Firefox still has some problems with "Designed for Windows" stupid sites with JavaScripts. I can't enter from keyboard, but cutting-pasting with mouse work just fine. Try entering anything on the left side of the screen on this site.

kainaw 05-18-2005 09:25 PM

Problem is with Java 1.5
First, for those who are replying about keyboard input into a webpage that happens to have an applet in it, you are completely missing the issue. The issue is keyboard input INSIDE the applet. It is a problem with Firefox (any version) and Java 1.5. If you remove the 1.5 version of Java and install 1.4, the problem goes away. Firefox developers claim that this problem doesn't exist. Java developers claim that it doesn't exist. So, I seriously doubt that it will ever get fixed.

foo_bar_foo 05-18-2005 11:36 PM

it's most likely a bug with java and Linux

Sun for years only tested java for Linux on redhat6

this is what they say for 1.5
Most testing of Java RE for Linux in the English-locale has been conducted on Red Hat 7.2, with kernel patch 2.4.9-31. Most testing in non-English locales has been conducted on Red Hat 7.1. However, Java RE has undergone limited testing on these other Linux operating systems:

* Caldera Open Linux 3.1 (kernel 2.4.2, glibc 2.2.1)
* Turbo Linux 7.0 (kernel 2.2.18, glivc 2.1.x)
* SuSE Linux 7.1 (kernel 2.4, glibc 2.2.14)
* Turbo Linux for Simplified Chinese locale

concequently for anyone using a modern system new java releases are almost always broken in some way

but they work out the bugs slowly over time

JamieBrown 05-24-2005 02:23 PM


Just to let you know, I've tried the "export LANG=UTF-8" command and it works perfectly, so thanks for that. Its slightly irritating so I hope they do fix the bug, but at least there's a work-around!



sigs 10-11-2009 01:48 PM

Java applets, I have the same problem
export lang=UTF-8 didn't do the trick. My applets kind of work, if I'm quick enough. I can paste into a password field before the dialog is fully loaded; after that all keystrokes just are lost.

In most text fields input isn't registered.

This can depend on SCIM, too. I'm using java-6-sun on Ubuntu 9.04.


Ygrex 07-26-2010 01:52 AM


Originally Posted by adz (Post 1608894)
Try clicking on the titlebar

thanks alot :) such a misterious problem...

All times are GMT -5. The time now is 10:43 AM.