LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Cant see samba shares (https://www.linuxquestions.org/questions/linux-software-2/cant-see-samba-shares-239380/)

matux 10-06-2004 09:13 AM

Cant see samba shares
 
Hi, I am setting up a samba server using mandrake 10.0. I have created usernames and passwords ok and have set up the server. The client machines can see the server name but can not see any of the shares within it. When trying to mount it never asks for username or password. I have attached the smb.conf file and would be thankful for any assistance.

Thank you
----------------------------------------------------------------
[global]
workgroup = FileServer

netbios name = FileServer

server string = Samba Server %v

log file = /var/log/samba/log.%m

max log size = 50

hosts allow = 192.168.1. 192.168.2. 127.
hosts deny =

guest account = nameX

security = user

encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd

unix password sync = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password*
%n\n *passwd:*all*authentication*tokens*updated*successfully*

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

dns proxy = no

#Share Definitions
[homes]
comment = Home Directories
browseable = no
writable = yes

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
guest ok = yes
writable = no
share modes = no

[public]
comment = Public Stuff
path = /home/server/server
write list = @wheel
read list = nobody, @users
guest ok = yes

[ISO]
comment = ISO
path = /home/server/ISO
valid users = userX
public = yes
writable = yes

scottman 10-06-2004 02:12 PM

I don't know if theres any other things in there you can change, but I noticed you don't have

browseable = yes

Try that under the share that you want to show up.


All times are GMT -5. The time now is 04:19 AM.