-   Linux - Software (
-   -   Can't play .ogg or .wav files in KDE (

DaneM 10-28-2005 06:03 PM

Can't play .ogg or .wav files in KDE
Hello, everybody. I just installed gentoo 2005.1 and I get no system notification sounds in KDE. When I run artsd in the console and go to

[wrench menu] -> sounds and multimedia -> system notifications

I get this:

couldn't load file /usr/kde/3.4/share/sounds/KDE_Dialog_Appear.ogg

and if I try to play any of the files assigned to the various tasks I get similar errors.

I have installed libvorbis and libogg via Portage.

Any ideas?



freakyg 10-28-2005 08:00 PM

you'll also need the package.........vorbistools to go with the other 2
AND the package "libao" if it is not already installed

DaneM 10-28-2005 11:32 PM

Thanks for the reply, freakyg!

I have emerged the packages you mentioned, but the problem persists. Here's what I get when I run artsd from the console and try to play the system alert sounds:

akode: Could not open frame-decoder
couldn't load file /usr/kde/3.4/share/sounds/KDE_Dialog_Appear.ogg
akode: Could not open frame-decoder
couldn't load file /usr/kde/3.4/share/sounds/Kopete_Sent.ogg

I have installed akode (even though it was masked by ~amd64, which I have), but I could not install artsplugin-akode:

[root@Orchestrator sounds]# ACCEPT_KEYWORDS='~amd64' emerge kde-base/artsplugin-akode
Calculating dependencies
!!! All ebuilds that could satisfy "kde-base/artsplugin-akode" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/artsplugin-akode-3.5.0_beta2 (masked by: package.mask)
# Diego Petten\uffff\uffff <> (6 Sep 2005)
# KDE 3.5_alpha1 (and later) split ebuilds.
# Please pay a bit more attention, it's the first time I prepare them.

- kde-base/artsplugin-akode-3.5_beta1 (masked by: package.mask)

Does that shed any light on the problem?

Thanks for your help.


DaneM 11-12-2005 05:50 PM


I told KDE to use ogg123 to play system notifications, and now it seems to be working correctly. I also had to put ogg and vorbis in my USE flags.

Anybody have a better solution?


All times are GMT -5. The time now is 10:42 PM.