-   Linux - Software (
-   -   Cant locate kernel-source to build my Nvidia driver (

nyhm 02-16-2004 01:43 AM

Cant locate kernel-source to build my Nvidia driver
Im running Fedora.

I downloaded the device driver for my Nvidia card. I tried to install it but it couldnt locate my "kernel-source" so a friend of mine told me to do a

yum install kernel-source

I did and now i have something in my /usr/src .... i thought that would have taken care of it but i tried to do the expert set up and even direct it to the new folder paths but it didnt do jack.. any help would be greatly appreciated! thanks in advance!


jax8 02-16-2004 02:27 AM

The kernel source comes with you CDs. You just have not installed them becuase they are not installed by default.

insert CD 1 into your drive and you will be presented with the Add/remove programs window (I think, do in RED HAT 9 anyway). You will find it in there somewhere.

nightwulf 02-16-2004 02:41 AM

In Slackware, the file you're looking for is "kernel-source-2.4.24-noarch-1" which is located in the "K" series of software. Depending on when you obtained your installation files, the version number may be different. You should be able to install it using pkgtool or installpkg from your original installation media.

EDIT: never mind ... you have Slackware listed in your user profile, but mention in your post that you're running Fedora. Reading comprehension > me. The rest of the post might actually be of use though ...

You say you have "something" in /usr/src ... care to elaborate? The package installs to "/usr/src/linux-2.4.xx". You may try simlinking "linux" to that directory. For example ...

If your linux source is located in /usr/src/linux-2.4.24 ...

cd /usr/src
ln -s linux-2.4.24 linux

This will make your kernel sources available at /usr/src/linux as well, which is where they're often expected to be.


nyhm 02-16-2004 04:48 PM

I did the

cd /usr/src
ln -s linux-2.4.24 linux

and then tried to install.. it seem to be doing alright but then gave me an error and told me to go to the /var/log/invidia-installer.log for more details.

I checked the log and it said that it failed a sanity check??? What exactly do i do here?

Thanks (again!) in advance.


Adding to my post......

i saw on another post that typeing this before the sh install
export CC=gcc32
would fix my problem. i tried it and it looked like it was working ( i saw the the loading bar finish all the way) then after that it gave me some error about a path /usr/src/nv/nvidia (i think that's the path it said) and a problem w/ an nvidia.o ???

just thought id keep up to date on that... please someone give me a reply. Thanks!

All times are GMT -5. The time now is 12:07 PM.