LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Can't install spotify on Opensuse 13.2 (https://www.linuxquestions.org/questions/linux-software-2/cant-install-spotify-on-opensuse-13-2-a-4175534568/)

pccor 02-19-2015 08:49 PM

Can't install spotify on Opensuse 13.2
 
I am unable to install spotify on Opensuse 13.2.20150209. When I use "install-spotify" I get the following error message:

"link target doesn't exist (neither in build root nor in installed system): /opt/spotify/spotify-client/lib/libcef.so -> /opt/spotify/spotify-client/libcef.so
Add the package providing the target to neededforbuild and Requires
error: Bad exit status from /var/tmp/rpm-tmp.VP4z0R (%install)"

I have tried installing appjs-0.0.20-1.fc20.x86_64.rpm but to no avail

Regards,

Paul Cornford

John VV 02-20-2015 01:24 AM

Quote:

appjs-0.0.20-1.fc20.x86_64.rpm
for starters that rpm is for a VERY!!! different operating system
that "fc20" means this is for a 64 bit install of FEDORA 20 and NOT OpenSUSE 13

very few things will cross over distros

I am assuming you are using zypper


"spotify-installer" is in packman
Code:

su -
zypper in spotify-installer

Quote:

zypper info spotify-installer

Information for package spotify-installer:
-----------------------------------------
Repository: Packman Repository
Name: spotify-installer
Version: 0.9.11.27.g2b1a638.81-3.1
Arch: x86_64
Vendor: http://packman.links2linux.de
Installed: No
Status: not installed
Installed Size: 20.5 KiB
Summary: Installer for Spotify desktop client
Description:
This is an automatic installer for the Spotify desktop client for
Linux, which circumvents the redistribution restrictions on the client
by:

- downloading the .deb from spotify.com
- installing required dependencies
- building an rpm
- installing the rpm

The process is intended to be as user-friendly as possible.
is this the installer you are using

or one of the many old github programs

pccor 02-20-2015 04:24 AM

According to "zypper info spotify-installer" YES.

pccor 02-20-2015 04:26 AM

Sorry, to explain: I get the same print out you get. So yes, it is the same.

John VV 02-20-2015 02:37 PM

so you installed the installer using zypper or the yast2 GUI"install and remove software"

did you read the "README.html" that the rpm installed?

file:///usr/share/doc/packages/spotify-installer/README.html
Quote:

Run "install-spotify" as a non-root user (e.g. from any terminal program).
the script will convert the Debain deb to a rpm

it may or may not work ???

it depends it you are using SUDO or not

i do not use "sudo" and "sudo" is NOT set up on my system, so it fails on my install of 13.2
however a rpm was MADE and is now in my home folder

so that can be installed


Code:

su -
### type in your root password when asked for ####

zypper in spotify-installer

### wait for it to finish THEN ###

exit

install-spotify

### might ask for root password ? or not but the install might fail ##

then install the rpm made using zypper and a local install

pccor 02-20-2015 07:17 PM

Yes to all of your questions. But somehow I have managed to produce spotify-client-0.9.11.27.g2b1a638.81-1.nosrc.rpm although I am not sure how I got it. When I tried to install that using zypper it required libudev.so.0 () (libudev0-182-8.10.x86_64.rpm) which I managed to download. That solved the problem and I now have Spotify running. Thanks for the help.

Lunar 11-27-2015 07:42 PM

Spent a day trying install.sh - This is how I got it done.
 
I tried the script. Failed.
I tried adding repo http://li.nux.ro/download/nux/dextop/el7/
I tried adding spotify repo: http://repository.spotify.com/pool/non-free/s/spotify/
and a half dozen other methods... Failures, bad files, bad signatures etc...
*(i'm running opensuse 13.2 / KDE / enlightenment)

This is what I did and it works Great! I can listen to last.fm or use Spotify-client...

* I had already installed (in YaST2) dpkg (deb package manager).
* Downloaded Spotify-client saved locally
* I also, already have my local 'download/apps/' directory added as a reop in YaST2 / zypper.
* Using YaST2, I installed the downloaded *.deb file from local repo, and chose to 'break dependency' on the ffmpeg version problem and finish install.
* Launched Spotify from kickoff (KDE) and signed in with facebook ( i already 'signed up' ).

Done. last.fm works, the Spotify client works.. I waited too, too long to do this.

Hope this helps someone else.
Landis.

Lunar 04-25-2016 01:07 AM

New Install - Not the Same... used Spotify-Install script
 
Update...
Installed a 'new system' using same opensuse 13.2, same Dell hardware, etc...
Could NOT install the *.deb file, even with package dpkg installed and everything seemingly the same...

Had to install spotify-installer from opensuse repo, run script '# sh spotify-installer' as normal user, allow to download and build the RPM.

failed, as There is a Dependency that is MISSING, libgcrypt.so.11
I used the repo: http://download.opensuse.org/reposit...openSUSE_13.2/ to install it.

Copied the RPM from ~/rpmbuild/RPMS/ to my local_-_Apps repo.
Ran Yast2 and installed Spotify.rpm with the libgcrypt dependency met.

Another Issue was that the facebook button did Not work on Spotify-client launch. I had to use my 'facebook email' (wasn't my main FB email, but is listed in FB acct and matched the email address in my spotify accout) and password as if I had a Spotify premium account.

Logged In. All is well. Have all my playlists as before, when using facebook as the login.

What a Pain in the Ass... : )

hope this helps.

Landis.


All times are GMT -5. The time now is 12:01 AM.