-   Linux - Software (
-   -   Can't install Git repo (I don't git git ) (

Nemus 02-11-2011 05:32 PM

Can't install Git repo (I don't git git )
I am trying to install a git repo i've used git as a client before and would really like to setup my own personal git repo

I've been following this but the part I don't under is the password for gitosis

I get to the part
git clone git@YOUR_SERVER:gitosis-admin.git

and it asks me for a password ?

and I don't remember setting a password for git anywhere would it be from my public key? (Because that doesn't seam to work)

Also the ubuntu thing says "Note that gitosis is an account already on your system that was created when you installed the gitosis package. " what does that mean what the crap is the gitosis password? and how am I to know this ?

Anyway I am using ubuntu 10.10 if that helps anyone

Thank you.

knudfl 02-12-2011 01:47 AM

May be Google .. gitosis ubuntu .. : Lots of info is available.

Example :
"" Install (Set Up) Git and Gitosis on Ubuntu ""

And of course do : 'sudo apt-get install gitosis'
..... or use Synaptic for the package install.

( I'd guess, you'll then be asked to create a git password.)


Nemus 02-13-2011 02:39 AM

Key Concept
I believe I missing a key concept or a step in the install or something, I've tried multiple how tos, but I always run into issues that the guide doesn't describe.
I get to this part in the guide "git clone git@<YOURSERVER>:gitosis-admin.git" and the system asks me for a password (and yes I understand that YOURSERVER is my ip address I've even tried localhost it just won't work for me)

and here above in the guide password is disabled so I don't know just don't understand it I guess.
sudo adduser
–shell /bin/sh
–gecos ‘git version control’
–home /var/git

Its easy to google for a problem when you know how to say want you need to say. I don't know what concept I am missing so I am not sure on what to google for. All of the guides have this step "git clone git@YOUR_SERVER_HOSTNAME:gitosis-admin.git
cd gitosis-admin" and I am following them to a T and it asks me for a password I try every password I can think of and it fails
maybe I'll try a different Distro see if I can get it to work, because I am having a hell of a time with it on ubuntu.

does something need to be setup in ssh or do I need to init.d the gitosis server?

Any ideas on this would be helpful thank.

or a link to a good guide that explains the issue.

Nemus 05-20-2011 02:09 PM

ssh key gen
my issue was that the guides where missing the step where you generate ssh keys.

All times are GMT -5. The time now is 11:34 AM.