LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Can't Get Sound from Pulseaudio -- PulseAudio Will Not Start (https://www.linuxquestions.org/questions/linux-software-2/cant-get-sound-from-pulseaudio-pulseaudio-will-not-start-4175593987/)

JasonC10203 11-21-2016 03:21 PM

Can't Get Sound from Pulseaudio -- PulseAudio Will Not Start
 
I have avoided Pulseaudio for as long as I possibly could. Of all the software I've tried to install/figure out on Linux, this has given me the most trouble. Now I find myself in a situation where I have to use Pulseaudio, so it is time to learn.

I have searched Google and read several posts in several different forums (including Linuxquestions) where users had the same problem/symptoms I am having but their fixes have not worked for me.

My current setup (by current, I mean what I've been using until today)
I'm running a HD install of GRML (Debian-based distro) on a Desktop. I have a cheap nVidia card installed so I can used HDMI to my TV. I figured out how to get HDMI sound working using ALSA, but I couldn't tell you how.

In terms of sound requirements, I watch videos (Netflix, Hulu, YouTube, mplayer) and play Minecraft. I have also been using Mumble to talk to those I play with. The only way to get the system to use my Headset with Mumble...or to get any sound at all through my headset is to rename my .asoundrc and then prefix the command with ALSA_CARD=Wireless. If I want to fire up mplayer with a movie and have the sound come through my TV again, I have to restore .asoundrc and I'm good to go. Hacky...but I've been content.

Now I have purchased a webcam and teleconference-style mic for this computer. I am trying to use Skype...which requires the addition of the i386 architecture to dpkg and the use of Pulse.

I have installed all the packages that I think I need for Pulseaudio to work, but when I try to run pulseaudio --start as a normal user, it just says "Failed to daemonize." There are no processes running at all having to do with pulse, so pulseaudio -k errors out too saying there were no running PIDs to kill.

I've tried deleting my ~/.config/pulse folder, running apt-get --purge remove pulseaudio, manually deleting any remaining pulse configuration files, and then reinstalling pulseaudio. I have verified that my user is in both the audio and pulse groups and have rebooted several times. I can run pulseaudio --system as root, but it prints out a bunch of lines saying this is not the way to do it. Even though it lets me run it this way, nothing can connect to the Pulse Server.

Right now I just want Skype to work. Ideally I would like to learn how Pulse and ALSA actually work so I can watch Netflix through my TV, talk to my friends through my headset, and play Minecraft through whichever I feel like at the time without having to delete, rename, or edit any configuration files.

World's longest post, I know and apologize. But I wanted to provide a complete background and goal. Can anyone help me at least get things working? I am certain I can learn the rest once I understand how to at least make it work. Thank you in advance.

notKlaatu 11-21-2016 03:41 PM

My pulse daemon starts at boot, so it gets instantiated by root. Can you try starting it as root to see if it sticks?

In terms of routing sound to skype, you will definitely want to have the poorly-named `pavucontrol` close at hand.

JasonC10203 11-28-2016 06:48 PM

I can start pulseaudio as root with "pulseaudio --system" but it spits out a bunch of warnings about how this is not the intended way to run pulseaudio. When I start pavucontrol, it says it is establishing a connection to PulseAudio, but never succeeds. So starting PulseAudio this way is a bust. I'd prefer to figure out how to start it as my normal user.

notKlaatu 11-28-2016 07:05 PM

Provide the commands you are using when you attempt to start pulse.

Try this. First, kill it just to make sure we're at ground 0, then start as a daemon:

Code:

$ pulseaudio -k
$ pulseaudio -D

Now it should be up and running. Start pavucontrol for GUI config, and check the Configuration to make sure you're routing sound to the sound card that you want to use.

Then start the application you want to hear sound from and check in its local settings to ensure it's using Pulse Audio as its output.

If you still don't have sound, check alsamixer to make sure all volume levels are up and NOT muted (pulse sends sound to ALSA devices, so if something's muted at the ALSA level then you won't hear sound).

JasonC10203 11-28-2016 11:18 PM

The commands I have tried follow (with their respective results):

Code:

pulseaudio -k
E: [pulseaudio] main.c: Failed to kill daemon: No such process

pulseaudio -D
E: [pulseaudio] main.c: Daemon startup failed

pulseaudio --start
E: [pulseaudio] main.c: Daemon startup failed

The distro I am using did not come with PulseAudio installed by default, so I never "uninstalled" it. I first attempted to install it with:

Code:

apt-get install pulseaudio
Since then I have tried several variations of the following:

Code:

apt-get --purge remove pulseaudio pulseaudio-utils
apt-get install --reinstall pulseaudio pulseaudio-utils pavucontrol libpulse0

Everything always completes without errors. But I am left in the same situation: I cannot start a pulse server to which other applications (e.g. pavucontrol, Skype, etc.) can connect.

I have also verified that my user is part of the audio and pulse groups, and that pulse is part of the audio group.

I should also share how I am attempting to start pulse as root and its results.

Code:

root@blah[~]# pulseaudio --system
W: [pulseaudio] main.c: Running in system mode, but --disallow-exit not set.
W: [pulseaudio] main.c: Running in system mode, but --disallow-module-loading not set.
N: [pulseaudio] main.c: Running in system mode, focibly disabling SHM mode.
N: [pulseaudio] main.c: Running in system mode, focibly disabling exit idle time.
W: [pulseaudio] main.c: OK, so you are running PA in system mode.  Please note that you most likely shouldn't be doing that.
W: [pulseaudio] main.c: If you do it nonetheless then it's your own fault if things don't work as expected.
W: [pulseaudio] main.c: Please read http://www.freedesktop.org/wiki.Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/ for an explanation why system mode is usually a bad idea.



All times are GMT -5. The time now is 11:41 AM.