LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   can't get postfix to work (https://www.linuxquestions.org/questions/linux-software-2/cant-get-postfix-to-work-76232/)

klintonray 07-27-2003 12:14 AM

can't get postfix to work
 
Hey all when i try to run postfix i get an error message that says

My hostname localhost is not a fully qualified
name - set myhostname or mydomain in /etc/postfix/main.cf

I have no idea what i'm doing, all i want to do is send outgoing mail.

Please help, if you need my config file, i'll be glad to post it.
Thanx

MasterC 07-27-2003 12:27 AM

Where are you getting that message, and what are you trying to do when it appears? If your hostname is not defined correctly in your main.cf you likely won't be able to receive mail, however sending should not be comprimised (as long as postfix starts..).

Did you install it or did it come pre-installed on your distro? What distro are you running?

Cool

klintonray 07-27-2003 05:41 AM

I am running red hat 9. It came pre-istalled with my distro. It gives me that message when i type "postfix" at the terminal, and when I type "postfix start" ...thanx masterC

klintonray 07-27-2003 05:41 AM

I am running red hat 9. It came pre-istalled with my distro. It gives me that message when i type "postfix" at the terminal, and when I type "postfix start" ...thanx masterC

klintonray 07-27-2003 05:41 AM

I am running red hat 9. It came pre-istalled with my distro. It gives me that message when i type "postfix" at the terminal, and when I type "postfix start" ...thanx masterC

MasterC 07-27-2003 05:46 AM

Ok, that's ok, you can set a hostname if you'd like, whatever you want to set it to is probably fine, maybe something like:
klintonrayrocks

Or something :)

But either way, let's make sure it's starting postfix (probably is), as root open up a terminal and type:
ps aux | grep postfix
And post up what you get.

Cool

klintonray 07-27-2003 06:54 AM

LoL...thanx masterC...this is what i get:
root 4975 0.0 0.0 3572 640 pts/0 S 3:51 0:00 grep postfix
Thanx again man..you all are awesome!!

klintonray 07-27-2003 06:56 AM

Also I haven't set a hostname yet....would i do that in the config file? Should I do that? Thanx again.

MasterC 07-27-2003 06:57 AM

:)

Well that's only pulling up the grep, so let's do a peek on it all if you can. Just post it all up:
ps aux

Also, I'm expecting you are running this after using the command (even though there are errors, that you might look into fixing from my above suggestion ;) ):
postfix start

Cool

klintonray 07-27-2003 08:00 AM

Hey dude, I think I don't understand what you are asking me to do plus I have a ton of other questions and you sound like just the person to talk to. Anyway, it's like 5 am and I am going home to go to bed because this is madness being at my office at 5 in the morning. Anyway, do you think there is a chance that I could talk with you over the phone on Sunday when I come back to the office. I will make and pay for the long distance call. My email address is klintonkerber@prodigy.net .... so that you don't have to post your phone number here. Anyway, that would be incredible if I could talk with someone about all I'm doing because I have a billion questions and I can't seem to find anyone in Arizona who knows anything about linux. Also I could send you an invite to do a VNC sort of thing too. Thanx again C.

MasterC 07-27-2003 08:15 AM

Whoa! :) Sure, it's 5 here too, so I guess we are on the same time zone, good deal.

As far as a knowledgable Arizonian, I believe there are a few members from Arizona, the first 2 that pop into mind (I think?) are Stephanie and Moses. Not sure how close they are to ya, and you also might have a LUG that is in your area as well, LUGS really are great things for linux people, oh:
LUG = Linux User's Group
For example, I live on an island called Whidbey, so my users' group is: Whidbey Island Users Group:
www.wlug.net
You might be able to find your LUG from google.

Anyway, yeah, I'm up for a telephone call, if you've got IM capabilities that might be an alternative if you're interested. I'll beam you an email and see how ya feel about either.

Cool

lovely_redrose 08-10-2003 11:45 PM

postfix-unable to send mail outside domain
 
Dear Members.......

I need help urgently with postfix. I have installed RedHat 8.0 with Postfix, Fetchmail and Procmail. Im constantly connected to the internet thru a ADSL modem.

My prob is this: I have to setup up my mail server to send and receive mail through an external mail server (=mail.xxxxx.com.my) (provided by my ISP). Users in my network should connect to my mail server (mars.xxxxx.com.my) to send and receive mails. I am not able to send mail to any other domain (e.g yahoo, hotmail,etc) outside my own network.

I am able to receive mail from anywhere, within and outside my network (fetchmail is working fine).

I have read through numerous mailing lists but am still unable to find a solution. This is the error msg in my log file:
Aug 11 10:15:57 mars postfix/smtp[1878]: 2EA593789C: to=<sharmila_rajagopal@yahoo.com>, relay=mail.xxxxx.com.my[202.157.185.130], delay=7, status=bounced (host mail.xxxxx.com.my[202.157.185.130] said: 550 not local host yahoo.com, not a gateway)

1. Below is the output of postconf -n

[root@mars root]# postconf -n

mydomain = xxxxx.com.my
myhostname = mars.xxxxx.com.my
relayhost = mail.xxxxx.com.my
myorigin = $mydomain
mydestination = $myhostname, localhost.$mydomain, $mydomain, mail.$mydomain, www.$mydomain, ftp.$mydomain

alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
default_destination_concurrency_limit = 10

disable_dns_lookups = no
inet_interfaces = all
mynetworks_style = class

local_destination_concurrency_limit = 5
mail_owner = postfix
mail_spool_directory = /var/spool/mail
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-1.1.11/README_FILES

sample_directory = /usr/share/doc/postfix-1.1.11/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_always_send_ehlo = yes
smtpd_banner = $myhostname ESMTP $mail_name ($mail_version)
transport_maps = hash:/etc/postfix/transport

2. etc/postfix/transport contains this: xxxxx.com.my smtp:mail.xxxxx.com.my

3. And the output of #hostname is mars.xxxxx.com.my

4. port 25 at my ISP is not closed.

p/s even if i changed
disable_dns_lookups = no to yes (as suggested in some lists), my problem is still not solved.

thank you in advance.


All times are GMT -5. The time now is 08:15 AM.