LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Can't get Eliza going (libchatbot-eliza-perl) (https://www.linuxquestions.org/questions/linux-software-2/cant-get-eliza-going-libchatbot-eliza-perl-4175592329/)

mark_alfred 10-27-2016 02:04 AM

Can't get Eliza going (libchatbot-eliza-perl)
 
Hi, I installed libchatbot-eliza-perl on my Ubuntu 16.04 machine. This program runs Eliza, the old AI program. But I can't figure out how to start it.

I went to the site and found this:

Quote:

This is all you need to do to launch a simple Eliza session:

use Chatbot::Eliza;

$mybot = new Chatbot::Eliza;
$mybot->command_interface;
I tried the command, but it didn't work. I'm not sure what to do.

mark_alfred 10-27-2016 02:23 AM

Okay, I did figure this out. There's a file named "simple", which is the basic Eliza program (there are a couple of other variations, like other languages, also). So, changing to the directory of the file and running the command worked. To illustrate:

Code:

/usr/share/doc/libchatbot-eliza-perl/examples$ perl simple
The command was in the directory /usr/share/doc/libchatbot-eliza-perl/examples, so I went to that directory and ran the command "perl simple" and it started my session with Liz. I ended the session by saying "Goodbye Liz" with Liz responding,

Code:

Liz:        I think you should talk to a REAL analyst.  Ciao!
..and then Liz closed the program.


All times are GMT -5. The time now is 02:22 PM.