-   Linux - Software (
-   -   Can't get DRI enabled with Savage/IX-MV (

Arttu 01-09-2005 02:01 PM

Can't get DRI enabled with Savage/IX-MV
The problem is that everything else works except DRI. Currently if I run glxgears with a window size of about 1200x800, I get 9 FPS. "glxinfo | grep-i direct\ rendering" returns: "direct rendering: No"

I'm running Slackware current on IBM Thinkpad T22 with Savage/IX-MV rev 19. I'm using Xorg X Window System version 6.8.1 (17 Sept. 2004). I have installed the newest snapshots of core and savage/dri stuff from /~fxkuehl/snapshots/. I also tried couple of older versions - they behave identically.

I have the following modules loaded (succesfully according to dmesg):

I am running in 1280x1024x16bit, as resolutions higher than that make the savage driver to state that I don't have enough video memory for 3D.

My xorg.conf contains the following definitions (among others):
Section "Module"
Load "dbe"
SubSection "extmod"
Option "omit xfree86-dga"
Load "glx"
Load "dri"

Load "type1"
Load "freetype"
Load "speedo"

Section "DRI"
Mode 0666

X loads the modules OK and reports the hardware correctly, but says in /var/log/Xorg.0.log:
(II) SAVAGE(0): [drm] Sarea 2200+872: 3072
(WW) SAVAGE(0): Direct rendering has been disabled.
(EE) SAVAGE(0): [drm] DRIScreenInit failed. Disabling DRI.
(EE) SAVAGE(0): DRI isn't enabled

...why DRI isn't enabled? What can I do to fix this?

Thank you VERY MUCH in advance!

Caeda 01-09-2005 04:09 PM

A Savage IX-MV getting 9 FPS...
I hate to say it but for that card this may be an alltime record speed :p
Anyway... um...

You can't load glx and dri at the same time for starters...

Caeda 01-09-2005 04:11 PM

Arttu 01-10-2005 09:48 AM

Thank you for your suggestions, but ...

1. Removing glx causes additional errors:
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!

2. The page which you gave a link to contains a XF86Config-4 in which both dri and glx are loaded.

Also, all OpenGL applications stopped working because of a missing GLX extension.

Caeda 01-10-2005 08:07 PM

Oh well. I just saw that page with someone having it working. Slackware may be at fault, have you tried any other distro's yet?

Arttu 01-11-2005 02:20 AM

On that page the author states that "DRI is (unfortunately) not supported".

Fortunately that is no longer true according to DRI wiki.

Changing distro is out of the question (and if I did change the disto and the card worked, I wouldn't really know what fixed it...I wouldn't learn anything)

Caeda 01-12-2005 11:56 AM

Oops... I musta pasted the wrong link for ya. I had three windows open with different sites and that wasn't the one I wanted to give you. Lol...

Great... now that I've cleared the history and cache and redone the internet settings and upgraded.... how do I find that right page again. :(

Arttu 01-12-2005 01:17 PM

Savage/IX-MV DRI **working**
Downloading and installing latest (DRI-enabled) snapshots solved the problem.

DRI is now enabled and I get almost 100 times the FPS I did before.

bodymind 01-25-2005 10:23 AM

hi! i have this problem... equal as you... how did you solve? where did you get the lastest snapshot?

thanks for your help

Arttu 01-25-2005 01:42 PM

Snapshots are available here ->

Instructions are available here ->

PS. I just noticed today that gradients don't work with my Savage card when using DRI - if you have similar card and get it working, please post a message here.

MistaED 02-07-2005 01:52 AM


I have a Savage IX 8MB video chip in this IBM Thinkpad T21 aswell, and I'm also having problems with 3D acceleration & DRI.

Quake 3 is like 1fps and I think it's due to no DRI. I run Slackware 10.0 now upgraded to Slackware Current just yesterday.

I've downloaded both the common & savage snapshots from the site Arttu supplied and installed witht the install scripts in order common to savage, to seeing no difference.

I'm guessing I didn't do something, because "glxinfo | grep -i direct\ rendering" gave me a no :(

(II) SAVAGE(0): [drm] Sarea 2200+284: 2484
(WW) SAVAGE(0): Direct rendering has been disabled.
(EE) SAVAGE(0): [drm] DRIScreenInit failed. Disabling DRI.
(EE) SAVAGE(0): DRI isn't enabled

That's also in my log file.

I hope you can help me, thanks!


Arttu 02-07-2005 06:00 AM

Installing Savage and Common drivers is not enough - currently you have all the drivers in place but your Xorg is not DRI enabled.

You must install new (DRI enabled) Xorg and modules. They can be found from the extras -location if I remember correctly.

Snapshots were updated just couple of days ago (fixes flat shading and segfault issues with savage drivers) - when you get the stuff working, everything should work very well.

MistaED 02-08-2005 07:35 AM

BlankScreen X
Hey thanks Arttu, I didn't realise that the patch was required because I have the latest 6.8.1. I also compiled a 2.6.10 kernel in which also helped.

I put the modules and Xorg in the spots it wanted and now DRI works which the log file says, but X ceases to show up, just sits there as a blank screen. :confused: And the log says there's no error :(

This sucks, have you got any suggestions?

Thanks again.


Arttu 02-08-2005 10:31 AM

Do "modprobe savage" always before you "startx".

Xorg will hang up just like you described if you don't have the savage module loaded before you start X. I encountered the same problem, too.

MistaED 02-09-2005 03:36 AM

Thank you once again Arttu! X boots perfectly and Quake 3 is going off at like 60fps with 512x384 res! Very happy :)


All times are GMT -5. The time now is 05:41 AM.