LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   cant find library (https://www.linuxquestions.org/questions/linux-software-2/cant-find-library-292642/)

buffed317 02-20-2005 01:39 PM

cant find library
 
i am trying to install a game so i run configure and it exits with this:

checking for sigc++-1.2... Package sigc++-1.2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `sigc++-1.2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sigc++-1.2' found

configure: error: Library requirements (sigc++-1.2) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.




so installed libsigc++-1.2.5.tar.gz to the /lib folder and still get the same message. what should i do?

buffed317 02-20-2005 01:55 PM

so i did some more searching and i found that if i run:
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig/

before the configure then it works

95se 02-20-2005 02:00 PM

most software you'll download will install, by default, into /usr/local as opposed to /usr

Sometimes you want this, sometimes you don't. If you want it to install into /usr, when "configuring", usually just adding --prefix=/usr will fix it. Example.
./configure --prefix=/usr
By default as well, pkgconfig doesn't search /usr/local/lib/pkgconfig and you have to explicitly add it to your PKG_CONFIG_PATH like you did.

buffed317 02-20-2005 07:21 PM

ok differnet problem now. i need to install SDL_ttf-2.0.7 and i installed it in /lib and now when i configure it cant find where i installed it. where should i install it?

95se 02-21-2005 01:53 PM

What do you mean you installed it in /lib... /lib is suppose to be used for libraries that are needed at startup. SDL_ttf shouldn't be installed there, /usr/lib is a good for it. You'll download the file, uncompress it, then run
./configure --prefix=/usr
After which you'll run make && su -c 'make install'
After this you may need to run ldconfig as root

buffed317 02-21-2005 10:32 PM

ok thanks. it works now. i guess i should read up on where to install things.


All times are GMT -5. The time now is 07:07 PM.