-   Linux - Software (
-   -   Can't compile gnome-ppp on my openSUSE Gnome computer (

werner1975 10-22-2007 12:30 PM

Can't compile gnome-ppp on my openSUSE Gnome computer

I downloaded the source code of gnome-ppp and when I run ./configure inside the directory, I get this error message:

checking pkg-config is at least version 0.9.0... yes
checking for DEPS... configure: error: Package requirements (gtk+-2.0 >= 2.4.0 libglade-2.0 >= 2.4.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the DEPS_CFLAGS and DEPS_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.

I'm using the latest version of openSUSE Gnome (10.3), updated from today with Gtk+-2.12.0 and libglade 2.6.2... Any idea?

weibullguy 10-23-2007 05:36 AM

Install the developer packages for Gtk and libglade using your package manager. They will be named something like gtk-dev or gtk-devel and libglade-dev or libglade-devel.

werner1975 10-23-2007 12:25 PM

Bingo :)
It's working great now. The only think I need to do is add the sticky bit so that I don't have to run it as root :)

werner1975 10-23-2007 02:07 PM

It seems Gtk applications don't work with suid. Any suggestion to circumvent this problem? :)

All times are GMT -5. The time now is 03:12 PM.