-   Linux - Software (
-   -   Can't access CUPS interface (

hikerguy 12-03-2008 05:51 PM

Can't access CUPS interface
Out of the blue, I'm unable to access the CUPS interface (localhost:631). I used to be able to, but now, everytime I try to, a Page load error comes up with "can't establish a connection to the server at localhost:631." I searched the Ubuntu forums and Google and tried a few things (including installing CUPS v1.3.9) with no change. I've tried stop and staring cups, but nothing is working. Has anyone come across this issue and found a fix for it?



SqdnGuns 12-03-2008 05:52 PM

Make sure it's running:

/etc/rc.d/rc.cups restart

hikerguy 12-03-2008 06:05 PM

SqdnGuns, guess I should have mentioned I'm running Ubuntu. I used the following two commands, which I believe
confirms it's running (Linux and CUPS are pretty new to me. I converted to Ubuntu Linux about 6 weeks ago---althgough I've worked as an end-user on Unix servers for about 7 years. Just never had to set things up from scratch like this. It's been a great learning experience).

$sudo /etc/init.d/cups status
cups: scheduler is running.


c$ ps -ef | grep cupsd
root 8982 1 0 18:58 ? 00:00:00 /usr/sbin/cupsd



michaelk 12-03-2008 06:22 PM

Check the cups access and errpr logs. Might be something there.

BTW this isn't a hardware problem and will be moved.

pixellany 12-04-2008 06:40 AM

Moved: This thread is more suitable in Software and has been moved accordingly to help your thread/question get the exposure it deserves.

hikerguy 12-04-2008 08:08 PM

Well, I'm making progress. Stumbled upon the following URL (instructions from the URL are provided below), and now I no longer
get the error message ""can't establish a connection to the server at localhost:631." However, as I tried to install the printer via
the CUPS interface, I guessed at the URI. I still can't print (getting a message of :""Unable to start filter "pstocanonij" -
No such file or directory.", but I'm getting closer.

NOTE: The user "cupsys" didn't exist, so I had to create it before executing the second "batch" of steps. The first batch of steps (shown immediately below) show the error message I received when creating the user "cupsys". I figure as long as it fixed my original problem, I'm not concerned about the password expiring. In fact, maybe it does that by default for the user cupsys, since that's used by the system.:


$sudo adduser cupsys
Adding user `cupsys' ...
Adding new group `cupsys' (1000) ...
Adding new user `cupsys' (1000) with group `cupsys' ...
The home directory `/home/cupsys' already exists.  Not copying from `/etc/skel'.
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
Your account has expired; please contact your system administrator

Basically, the steps are:


1. Add "cupsys" to the shadow group. In terminal type:
sudo adduser cupsys shadow
2. Add youself to the lpadmin group. In terminal:
sudo adduser <yourusername> lpadmin
3. Restart CUPs. This can be done by typing:
sudo /etc/init.d/cupsys restart


Thanks to all who replied to my post. Hope this helps some people out there.

(as an aside, does anyone know why the second box of code has a vertical scroll bar, but the first one doesn't?)

All times are GMT -5. The time now is 04:44 PM.