LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-08-2008, 07:14 PM   #1
HiOctane21
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: OpenBSD, Ubuntu, RedHat, Fedora Core, OpenSuse
Posts: 57

Rep: Reputation: 15
Cannot uninstall or install a specific RPM


Hello,

I'm trying to install a RPM but rpm says that its already installed but when I try to query it or erase it (rpm -evh) I get the rpm is not installed.

Code:
#rpm -ivh openoffice.org-base-2.3.1-9238.i586.rpm
Preparing...                ########################################### [100%]
        package openoffice.org-base-2.3.1-9238 is already installed

#rpm -qi openoffice.org-base-2.3.1-9238.i586.rpm
package openoffice.org-base-2.3.1-9238.i586.rpm is not installed

Does anyone have an idea about this issue?


Thanks
 
Old 04-08-2008, 07:30 PM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 32
What is the output of this command?:

# rpm -qi openoffice.org-base
 
Old 04-08-2008, 07:40 PM   #3
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Mineral, Virginia
Distribution: Debian 8
Posts: 7,891

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
You are confusing the package name with the name of the rpm package file.

You can get a list of the packages that you have installed with:

rpm -qa | sort | less

Then remove Open Office using whatever package name(s) it is actually installed as.

-------------------
Steve Stites
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM - Won't Install, Won't Uninstall qizhang Mandriva 2 11-18-2005 01:02 AM
RPM Install and Uninstall problems. pradsy90 Linux - Software 1 09-12-2004 01:44 AM
How to install an RPM to a specific Directory GUIPenguin Linux - Newbie 4 08-30-2004 07:36 PM
RPM install/uninstall jonlake Linux - Software 2 06-14-2004 09:45 PM
install, uninstall rpm aizkorri Linux - Software 2 05-06-2002 01:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration