LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-28-2005, 08:37 AM   #1
whatpot
Member
 
Registered: Feb 2005
Distribution: Kubuntu and Debian
Posts: 32

Rep: Reputation: 15
cannot run ./configure


I have past two days been getting this error everytime i try to compile a script regardless of the program i'm trying to compile.
the file /bin/sh is a link to bash
Please help

I use SuSe

error while running configure
-----------------------------------
bigbillcotton@linux:/windows/f/linux/fluxbox/fluxter-0.1.0> ./configure
bash: ./configure: /bin/sh: bad interpreter: Permission denied
bigbillcotton@linux:/windows/f/linux/fluxbox/fluxter-0.1.0>
-----------------------------------
 
Old 02-28-2005, 08:43 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 255Reputation: 255Reputation: 255
What are the permissions and owners of the file your trying to compile? Is 'bigbillcotton' the owner or part of the group of the file your trying to run ./configure against?
 
Old 02-28-2005, 09:09 AM   #3
whatpot
Member
 
Registered: Feb 2005
Distribution: Kubuntu and Debian
Posts: 32

Original Poster
Rep: Reputation: 15
Thankyou for the hint! These files i was trying to compile were in mounted windows partition (for eg: /windows/f/linux_files). I moved them to my home directory (/home/bigbillcotton/desktop/) and then ran ./configure. everything worked fine. So i guess it was a permission problem.
All i had to do was to move the files from the windows partition to my home directory.

Thankyou

P.S If possible could you in brief explain what the problem really was?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while tryiong to run ./configure Ian D Linux - General 6 08-28-2005 10:51 AM
How can I configure Lilo to run FreeBSD? Mr. Hill *BSD 7 03-14-2005 09:56 PM
how to run ./configure in redhat9.0 thanks sunclscl Linux - Hardware 2 08-08-2004 12:47 AM
Yet another configure script that won't run gauge73 Linux - Newbie 1 02-14-2004 03:25 PM
Configure kppp to automatically run. joshf Linux - Software 0 07-15-2003 04:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration