-   Linux - Software (
-   -   Cannot run Audacity : "Audacity is already running" (

tuanito 08-11-2004 05:15 AM

Cannot run Audacity : "Audacity is already running"
I installed Audacity yesterday from Slackware packages and it seemed to work (except for the recording). Anyway, today I tried again, and there is a popup msg that says :
"Audacity is already running, Running two copies of Audacity simultaneously may lead to data loss or cause your systel to crash, so is not allowed.".

I have not launched any other audacity, as

ps -aux |grep audacity yields nothing.

and I just run it by itself, without xmms or gnome-volume-control, in case there could be a problem with two apps using the soundcard.

What is the problem ?


Galik 08-11-2004 07:22 AM

Well at a guess audacity may have left an undeleted 'lock' file in /tmp. Take a look in /tmp and see if there is a folder with audacity in the name.


ls /tmp
You should see something like :


in the listing. Try deleting this file and re-run audacity.


rm -fr /tmp/audacity1.2-user
Note: rename the "audacity1.2-user" part to whatever you found in your /tmp directory.
Also: You *may* (or may not) need to be root to do that.

tuanito 08-11-2004 07:52 AM

Thanks a bunch, it was exactly the problem. Thanks a lot for the info.

I have one last problem : I cannot record with a microphone (jack plug) (maybe the soundcard finds my voice too ugly ? :-)). I set in gnome-volume-control the mike as the recording entry, and audacity in pref is set to /dev/dsp (cannot be changed). It is symlinked to /dev/dsp0.

Audacity says, when trying to record : Error while opening sound device, Please check the output device settings and the project sample rate.

The log file shows :

PaHost_OpenStream: could not open /dev/dsp for O_RDWR
PaHost_OpenStream: ERROR - result = -10000
PaHost_OpenStream: could not open /dev/dsp for O_RDONLY
PaHost_OpenStream: ERROR - result = -10000
PaHost_OpenStream: could not open /dev/dsp for O_RDONLY
PaHost_OpenStream: ERROR - result = -10000
Host error.
PaHost_OpenStream: could not open /dev/dsp for O_RDONLY
PaHost_OpenStream: ERROR - result = -10000
Host error.

All is run on an ASUS laptop and Slack 9.1



Galik 08-12-2004 02:46 AM

Right it sound like it might be a permissions problem. One thing to try is change your user acount settings and add yourself to the 'audio' group. (or it may be the 'sound' group. Many distros set up a special group for users who want to use the sound devices. If that doesn't work try doing a:


ls -l /dev/sound/dsp*
And see what it says. My output is like this:


galik> ls -l /dev/sound/dsp*
crw-------  1 galik audio 14,  3 Jan  1  1970 /dev/sound/dsp
crw-------  1 galik audio 14, 19 Jan  1  1970 /dev/sound/dsp1
crw-------  1 galik audio 14, 35 Jan  1  1970 /dev/sound/dsp2

meaning only the user 'galik' can open the sound devices for reading and writing (thats the rw bit at the start of each line) but no one else can (that's the '---' bits). But your's might be different. If you post it here we can se if there is a problem with it.

tuanito 08-12-2004 02:56 AM

This is what I get :

ls -l /dev/dsp*
lrwxrwxrwx 1 root root 4 Apr 15 16:17 /dev/dsp -> dsp0
crw-rw--w- 1 root sys 14, 3 Aug 29 2003 /dev/dsp0
crw-rw--w- 1 root sys 14, 19 Aug 29 2003 /dev/dsp1
crw-rw--w- 1 root sys 14, 35 Aug 29 2003 /dev/dsp2
crw-rw--w- 1 root sys 14, 51 Aug 29 2003 /dev/dsp3

Actually, after your post, I just tried to run Audacity under root and at least, I get now the 4 mic / vol / cd /line / phone in etc drop down menu for the input. However, I tried the mike but audacity still gets nothing.

For the mike, as I was not sure which input to try, I tried them all, putting Rec on all the successive input device in gnome-volume-control (i.e. Vol, Line, Mic, CD, Line 1 , Phone In, Video), even though I guess it should be Mic. But still it does not work.

So as you mentioned, there must be a authorization problem+ still a problem with the mike.


Galik 08-12-2004 03:25 AM

Well one thing you can try here then is to change the permissions. As root type:


root> chmod o+r /dev/dsp*
And see if this solves it. By your permissions then only user root and group sys may both read and write to the sound cards. The above command should allow others to read (as well as write) to the cards. That may solve your recording problem.

tuanito 08-13-2004 03:41 AM

It perfectly worked with your help ! Thanks a lot again.

jsmnuk 06-11-2009 06:02 PM

Not the best, but....
after ripping my newbie hair out for three hours, I decided to install an Intrepid version 1.3.5 of Audacity, after I removed the version. It installed with no problem. I don't know how compatible it is with the other sound and video programs, but at least it works. The version needs fixing, even if it is a better fit with the Ubuntu Studio Package.

GenericJam 03-17-2016 02:05 PM

2016 Update
I realize this thread is almost as old as Linux itself. However it was one of the relevant search results that led to me being able to figure out my problem. I'm running Linux Mint 15 if it's relevant.

From the original poster's problem of Audacity saying that it is already running when I know that it is not. I've restarted, rebooted and reinstalled with Audacity still saying it is already running. The last time I successfully ran Audacity it crashed and locked up the whole machine in the process. I rebooted and thought that was the end of it. When restarting I ran into the problem of it saying it was already running. I realized there must be a lock somewhere.

I looked in /tmp as instructed by a previous poster but it's not there anymore in 2016. I came across this post regarding where the config files are -

[If you're a linux noob '~' is your home directory so start there. Replace <user> with your username]

If you look in ~/.audacity-data/audacity.cfg it says where the temporary directory is stored. Mine has not been changed so I imagine the default is TempDir=/var/tmp/audacity-<user>

Go there and the lock file should be called audacity-lock-<user>. Delete that and you can start Audacity now.

All times are GMT -5. The time now is 05:42 AM.