-   Linux - Software (
-   -   Cannot read from exe files on a Cdrom (with wine or cat) (

themrrobert 08-12-2010 03:31 PM

Cannot read from exe files on a Cdrom (with wine or cat)
My fstab is basic,


/dev/cdrom /media/cdrom auto ro,user,exec 0 0
I've tried commenting out the line and mounting directly, and have also tried using ,umask=000, but when i add that to the options, it wont mount due to bad fs type or bad superblock, etc, but it mounts fine without umask.

The problem is, its not allowing users other than root to read from exe files. Here is the output of
#ls -lh /media/cdrom

total 457M
-rw-r--r--. 1  502 games  48 Jun 23  2008 autorun.inf
dr-xr-xr-x. 1 root root  2.0K Jun 23  2008 directx
-rw-r--r--. 1  502 games  54K Jun 23  2008 disc.ico
-rwx------. 1  502 games 1.2M Jun 23  2008 installer.exe
-rwx------. 1  502 games 456M Jun 23  2008 installer tome.mpq

I need to be able to run wine /media/cdrom/installer.exe, wine finds the file ok, but cant read from it so it says it can't access the file or something like that.

Fedora 13

systemserverscom 08-12-2010 04:02 PM

for old dos/windows programs to see the cd under wine it needs to see things in the ./wine structure as a dos drive letter, so open fileman in wine and and look for the pretend place for the cd directory in the dosish world wine creates.

you may need to create a symbolic link more palatable to wine.
ie as your wine user: ln -s "/media/cdrom" ~/.wine/D:

if you need to do this identicly to multiple users it might be easier to copy .wine to /etc/skel to prepopulate the users as they are created

themrrobert 08-12-2010 04:17 PM

It would normally be mounted as /media/Diablo II Install Disc 1 but I had to change it in order to be able to hot-swap cds as it is a 4 cd install.

I am fully aware that there is no execute permission (or read permission). I need to figure out HOW to mount it so that the read permission stays for all users not just root.

SO IT IS ACTUALLY MOUNTED WHERE I SAID IT WAS :), because it it mounts on its own, the installer won't be able to find the 2nd, and 3rd cds

Even when using the original label (removing fstab settings and ejecting/eject -t'ing the cd, so it regenerates a mount point in /media, it still doesn't allow reading by user.

themrrobert 08-12-2010 04:51 PM

I Read your edit, It still doesn't apply to the problem.

The problem is simple: The system WONT allow users (non-root) to read from or execute (.exe files) on a cdrom. I need to mound the cd so that all files are readable to all users, but using the umask=000 flag doesn't work, in fact, it makes everything break.

All times are GMT -5. The time now is 12:28 AM.