LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-03-2004, 08:37 PM   #1
Valhalla
Member
 
Registered: Dec 2004
Location: Atlanta
Distribution: Gentoo 2005.1, Ubuntu 5.10
Posts: 267

Rep: Reputation: 30
Cannot play sound from CDs/mp3


I have SUSE 9.1 I just installed it. I cannot play audio files using the built in XMMS or KsCD. However, I went to sound card configuration and played the test sound and it came through ok. Likewise, flash media sounds from the internet and likewise work fine. What can I do?
 
Old 12-03-2004, 09:40 PM   #2
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
What sound drivers are you using? Does xmms appear to be playing the files and just not outputting sound?
 
Old 12-03-2004, 09:56 PM   #3
Valhalla
Member
 
Registered: Dec 2004
Location: Atlanta
Distribution: Gentoo 2005.1, Ubuntu 5.10
Posts: 267

Original Poster
Rep: Reputation: 30
Well KsCD was ticking along like it was playing the CD, I tried to play it in XMMS just as an attempt, but I don't have any mp3 on my comp since I just installed. As for Sound Driver, im not really sure where to find that, but under sound configuration it says 82801EB AC'97 Audio Controller if that helps. I'm fairly certain its not hardware related though,cuz sound does come out of my speakers
 
Old 12-03-2004, 11:43 PM   #4
clean_sweep
LQ Newbie
 
Registered: Nov 2004
Location: Chicago
Posts: 12

Rep: Reputation: 0
I have the same problem with KsCD on Mandrake 10.1 Official. During the test the sound comes out of speakers, but none comes out when I play a CD though the CD looks like ticking.

However, I can play the same CD in Kaffeine/CD perfectly. What's wrong with KsCD or my configuration of it?
 
Old 12-04-2004, 12:17 AM   #5
Valhalla
Member
 
Registered: Dec 2004
Location: Atlanta
Distribution: Gentoo 2005.1, Ubuntu 5.10
Posts: 267

Original Poster
Rep: Reputation: 30
I attempted to use Kaffiene and got Error: No demux plugin
 
Old 12-04-2004, 08:42 AM   #6
clean_sweep
LQ Newbie
 
Registered: Nov 2004
Location: Chicago
Posts: 12

Rep: Reputation: 0
When you open Kaffeine, put your CD in, and then select "CD" from a menu (I am forgetting its name, but it is one right at the top bar). I am writing this from my Internet connection through XP, so I cannot see Linux. You will always that 'plugin' error, but you need to select the mode to play your CD, DVD, etc. Try it.
 
Old 01-09-2005, 10:26 AM   #7
gamma_seraph
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Rep: Reputation: 0
Running SUSE 9.1 personal.

I have the exact same problem as Valhalla. KsCd looks like it is playing a CD and it even gets the track names downloaded but there is no sound. System sounds work fine. I cannot seem to get XMMS to open a CD. I read the XMMS manual and there should be no problem. There are no cdda files under /media/cdrom

Quote:
fstab: /dev/cdrom /media/cdrom subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
The CD input plugin is configured just so: Device: /dev/cdrom Directory: /media/cdrom
Checking the drive says everything is ok. I also set it to DAE.

The CD was working fine with Ubuntu. Thanks for any help.
 
Old 01-09-2005, 10:48 AM   #8
Valhalla
Member
 
Registered: Dec 2004
Location: Atlanta
Distribution: Gentoo 2005.1, Ubuntu 5.10
Posts: 267

Original Poster
Rep: Reputation: 30
I have since discovered that KsCD doesn't work to play sound unless you have some special internal connector plug attached to your CD player. Just use kaffiene, I know it comes w/ SUSE
 
Old 01-09-2005, 10:56 AM   #9
gamma_seraph
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Rep: Reputation: 0
Thanks, I will try it out.

I do have the stereo cable going from the CD player to the sound card if that is what you mean.

I am new to Linux and am trying to learn as much as I can but I guess somethings just will not work.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sound mp3 doesn't play smoothly anotherguy Linux - Newbie 7 11-26-2005 07:27 AM
I can't hear any sound when I play a cd or mp3...but tested with system tools->Sound Niceman2005 Linux - General 6 10-31-2005 10:51 AM
Burning MP3 CDs (not audio CDs) mlamarche Linux - Newbie 6 11-29-2004 05:09 AM
cant play mp3 cds on my box kshatriyarules Linux - Newbie 5 10-01-2004 09:35 AM
System hangs-up when i try to play mp3 cds ananthbv Linux - Hardware 0 02-14-2004 09:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration