-   Linux - Software (
-   -   Cannot Login to Console - Ctrl+Alt+F1 gives me black screen (

robertpolson 02-08-2007 12:07 AM

Cannot Login to Console - Ctrl+Alt+F1 gives me black screen
Please keep in mind that I am a noob, try to be specific in all your steps..

My problem:

When entering password for user at the main login screen, there is an option to choose Login to Console if I choose that, all I get is a black screen. It seems that the commands do work, it is just that all I get is a black screen. By memory I tried to enter user name, password and sudo start x and it started, so comamnds work, but all I see is a Black Screen.

If during my X session I press Ctrl+Alt+F1 or Ctrl+Alt+F2 or whatever up to 6, all I get is a black screen. Ctrl+Alt+F7 does bring me back to the X session.

This is a problem as there are certain things which require no X running and console and I cannot do that.

Possible causes:

I have latest Nvidia 9xxx driver
I also isntalled Beryl and the uninstalled it, not sure if that console problem started after Beryl instillation.

Some people mentioned that it has something to do with Nvidia and framebuffer or Composite being enabled. Other said soemthign to do with grub, no idea what these things mean.

I do know that the console worked some time ago.

I have Kubuntu Edgy 6.10 Nvidia Go 6600 128 Mg video with 9xxx driver isntalled via envy nvidia script

I think that is all I know. Here is my xorg.conf

Please help.

stan.distortion 02-08-2007 01:05 AM

Im fairly sure that it is a combination of the kernel comands passed by grub at boot ( in "/boot/grub/menu.1st") and the nvidia driver. Passing a different graphics setting to the kernel at boot (eg, the "VGA=?" section in menu.1st) will probably get it working.
A simpler option to test if this is the the cause:
In /etc/X11 there should be another xorg.conf file, probably something like xorg.conf.old which will be a backup from before you installed the nvidia driver. Rename your xorg.conf (ie, something like xorg.conf.nvidia) then rename the backup file to xorg.conf, them cntl+alt+backspace to restart the xserver and check if it works with your origional driver.


robertpolson 02-08-2007 07:27 AM

Already tried it, does not work.

Any more ideas or suggestions?

stan.distortion 02-08-2007 08:13 AM

You are sure it is loading the original drivers and not the nvidia ones? It will say in 'section "Device"' in /etc/X11/xorg.conf. When the system boots can you drop out of the boot splash and see the boot messages? To get rid of the splash (and speed up the boot a bit) remove 'splash' from the kernel you use in /boot/grub/menu.1st ie:
kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet splash
kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet

To drop out of X use ctrl+alt+backspace (not ctrl+alt+del, that restarts). Depending on what display manager you use, you can stop it with:
/etc/init.d/kdm stop
for KDE
/etc/init.d/gdm stop
for gnome. Replacing 'stop' with 'start' or 'restart' does the obvious.
Try a few things and see either where in the boot process you loose the display or if dropping out of X completely does anything


robertpolson 02-08-2007 09:02 AM

Actually all of the backups of xorg.conf that I have, already have Nvidia in them from the envy script with 9xxx driver version.

I also did try to $ sudo dpkg-reconfigure xserver-xorg

and after reconfiguration, still I get no Console working. But I still have the Nvidia Logo for some reason

Setting kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet without splash also did not help

Setting it to: Setting kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet nosplash vga=normal

and andvga=897 ro whatever it was also did not help.

Here is my /boot/grub/menu.lst

What should I do now ?

stan.distortion 02-10-2007 05:18 AM

comment out the nvidia driver:
Driver "nvidia"
# Driver "nvidia"
and add the open source 2D driver:
# Driver "nvidia"
Driver "nv"
You can just change it but commenting will make it easier to fix if you are stuck in the terminal

With splash removed from menu.1st , do you get messages scrolling by as the system boots?


jiml8 05-15-2007 04:31 PM

There is a known bug in beryl when using the Nvidia rendering platform that will cause these symptoms.

I have experimented with it and determined that the problem goes away when you stop using the Nvidia rendering platform and start using AIGLX. I have not managed to get XGL running here so I don't know what happens when you use it.

Unfortunately (on my system at least) AIGLX is noticeably slower than Nvidia for rendering. I have taken to using Nvidia most of the time and switching to AIGLX (or else stopping beryl) when I find it necessary to go to a tty console.

Beryl is still immature. This is part of what you get when you use immature software.

All times are GMT -5. The time now is 05:40 PM.