LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Cannot execute binary file (https://www.linuxquestions.org/questions/linux-software-2/cannot-execute-binary-file-30940/)

Bigun 09-22-2002 02:01 AM

Cannot execute binary file
 
I've ran into this problem twice now with two different programs. I've downloaded three different SNES emulators:

SNEmul, ZSNES, and snes9x

SNEmul and snes9x give the same error after typing what they said to type:
[root@localhost] # SNEmul
"bash: SNEmul: Command not found"

[root@localhost] # snes9x
"bash: snes9x: Command not found"

Then I remember reading somewhere that you need an "sh" before the command...then I got "Cannot execute binary file"

The only one that has worked is ZSNES, which I had to compile. Do I need to compile these as well? If so why didn't the instructions even bother to mention such a minor detail? If not then why won't it work?

(PS - yes I know that ZSNES is a good emulator, but it doesn't seem to support my USB Gamepad Pro. So Either I need to find out how to map my joystick to "/dev/input/js0", or get another to work)



Just one more added comment:

Thank you so much! For all of you that have helped! Because without you, I would not have kept my interest in Linux. This is the third time trying Linux, and I think it may have finally stuck with me. Thank you, so much guys! For all your help!

neo77777 09-22-2002 02:08 AM

Yep, downloading the program doesn't mean installing it.

Bigun 09-22-2002 02:11 AM

I know that! But all the instructions told me was to extract the files to the home directory and "run it". Real specific huh? :D

MasterC 09-22-2002 03:08 AM

Sometimes a how to expects some knowledge and common sense, this one expects you to have a little more than that. Others will bore the average user. I guess they chose the other side, confuse the average user.

Cool

stickman 09-23-2002 08:51 PM

It could be something as simple as PATHing. When the instructions are the short "extract and run" type then you probably need to add that diretory to your PATH or specify the full path to the binary. Sometimes the permissions aren't right for the binaries. Check to see if they are indeed executable.

Bigun 09-23-2002 11:11 PM

Hmmm, something I'll have to try...

neo77777 09-23-2002 11:58 PM

What
file filename
reports

acid_kewpie 09-24-2002 04:44 AM

am i the only one to notice that he's running "snes9x" and not "./snes9x" ??

Mara 09-24-2002 06:45 AM

Quote:

Originally posted by acid_kewpie
am i the only one to notice that he's running "snes9x" and not "./snes9x" ??
I suppose that
/path_where_it's_installed/snes9x
would be better. If you're in a directory when your program is installed, you can use ./snes9x

Bigun 09-24-2002 10:12 AM

So I actually have to type in the path where the file is plus the filename such like:

/home/Bigun/Downloads/snes9x-linuxppc/snes9x

I didn't know this, I only thought you had to be IN the path. Oh well, that's what I get for learning DOS first. :)

Mara 09-24-2002 12:06 PM

Quote:

Originally posted by Bigun

/home/Bigun/Downloads/snes9x-linuxppc/snes9x

Right. But when you're in /home/Bigun/Downloads/snes9x-linuxppc/ it's just
./snes9x

Bigun 09-24-2002 11:59 PM

Where would the file be to add the directory to my PATH?

Tinkster 09-25-2002 01:06 AM

Quote:

Originally posted by Bigun
Where would the file be to add the directory to my PATH?
Gidday!

Depends on what shell you are using...
$HOME/.bashrc would be one point of interest...

Cheers,
Tink

RijilV 09-25-2002 01:09 AM

Quote:

Originally posted by Bigun
Where would the file be to add the directory to my PATH?
in general

/etc/profile

I'm sure there is some distribution specific file in most major distributions that they want you to use.

however, I must ask, is it really all that big of a deal to type in ./<path-to-program>/<program-name> ? Most shells have tab completion..

or you could even install the program to /usr/local/bin/

I'm sure you're using a popular window manager like Gnome or KDE, you could easily add it to whatever menu / desktop / panel / start-button the window manger of your choice is using....

btw, don't run that as root....and don't tell me you always login as root, just go make a user and log back on as that then post your reply...

Bigun 09-25-2002 01:28 AM

Naw, I don't log in as root all the time.

:D


All times are GMT -5. The time now is 10:44 PM.