LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-07-2017, 09:08 PM   #1
daree361
LQ Newbie
 
Registered: Aug 2016
Posts: 2

Rep: Reputation: Disabled
Cannot download any packages through terminal on LinuxMint Cinnamon 13 Maya. .deb packages only.


I just got my newer computer and I have noticed a very big problem, I can't download any packages through the terminal.
I am still learning Linux and I'm 14, so you gotta give me credit for at least trying.
I was trying to download Kdenlive at https://kdenlive.org/download/. Previously on my old computer which was running LinuxMint 17.2, it downloaded perfectly, but on my new one, it has given me some trouble.
The repository and updates go smoothly but when I try to install Kdenlive itself it gives me some of the following errors.
-Says the package may have been moved/cannot be found.
-Says I have broken packages
I went into Synaptic Package Manager and went to fix the broken packages, and get the same error.

\

sudo apt-get install kdenlive
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdenlive : Depends: kde-runtime but it is not going to be installed
Depends: libkdecore5 (>= 4:4.4.95) but it is not going to be installed
Depends: libkdeui5 (>= 4:4.8.4) but it is not going to be installed
Depends: libkio5 (>= 4:4.6.2-0ubuntu2) but it is not going to be installed
Depends: libknewstuff3-4 (>= 4:4.4.0) but it is not going to be installed
Depends: libknotifyconfig4 (>= 4:4.3.4) but it is not going to be installed
Depends: libnepomuk4 (>= 4:4.5.85) but it is not going to be installed
Depends: libqjson0 (>= 0.7.1) but it is not installable
Depends: swh-plugins but it is not installable
Depends: dvgrab but it is not installable
Depends: frei0r-plugins but it is not going to be installed
Depends: recordmydesktop but it is not installable
Depends: dvdauthor but it is not installable
Depends: xine-ui but it is not installable
E: Unable to correct problems, you have held broken packages.

\

I'm not sure what to do at this point, and I have tried downloading different video editors but end up with the same issue. I am only able to download specifically .deb packages, so I'm able to download steam, but nothing from the terminal. This is a NEW computer, barely anything is on it except for steam and other minor items. I am considering upgrading to LinuxMint 15, and LinuxMint 17 crashes and isn't able to go on this computer.
Help soon would be greatly appreciated, thanks.

Last edited by daree361; 02-07-2017 at 09:14 PM.
 
Old 02-08-2017, 01:55 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,401
Blog Entries: 10

Rep: Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212
i can only give very general advice:

- linux mint has a weird update process; basically you should always use mintupdate to update (it's the gui thingy in your systemtray) and not synaptic and/or the command line.

- you didn't update regularly or properly or have added conflicting ppas or other fishy sources

- mint 13 isn't EOL yet, but soon. here are the supported versions of linux mint.

Quote:
Originally Posted by daree361 View Post
I am still learning Linux and I'm 14, so you gotta give me credit for at least trying.
no 14-year-old would admit to something like that.
but hey, nevermind. i'm 15, have dyslexia, and am recovering from a recent stroke.
 
Old 02-08-2017, 03:07 AM   #3
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by daree361 View Post
Help soon would be greatly appreciated, thanks.
Hello and welcome to the forum

While I'm not sure any of them will help, take a look through the suggestions offered in these threads...

http://www.linuxquestions.org/questi...es-4175510237/

http://askubuntu.com/questions/84111...roken-packages

http://askubuntu.com/questions/36320...roken-packages

Let us know how it goes...

Regards...
 
Old 02-08-2017, 03:53 AM   #4
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 20.1 MATE, MX-19.3, antiX, EndeavourOS
Posts: 3,331
Blog Entries: 17

Rep: Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263
daree361,

Welcome to LQ.

What is the make/model of your PC/laptop?

I suggest that you try using Linux Mint 18.1 (MATE or Xfce) 64 bit:

https://www.linuxmint.com/release.php?id=28

First, backup all your personal data from your existing installation.

Once 18.1 is installed, use Update Manager/software updater to add all the additional software packages.

Then, as before in Terminal:
Code:
sudo apt-get install kdenlive

Last edited by beachboy2; 02-08-2017 at 03:56 AM.
 
Old 02-08-2017, 07:02 AM   #5
snowday
Senior Member
 
Registered: Feb 2009
Posts: 4,667

Rep: Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409
If you read the Kdenlive download page carefully, you'll see their PPA is intended for Ubuntu 16.04 or newer. That is the equivalent of Mint 18.x.

While there may be educational/historical reasons to use an older release, the vast majority of users such as yourself will be much happier using the current version of Linux Mint.
 
Old 02-08-2017, 07:46 AM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by ondoho View Post
i can only give very general advice:

- linux mint has a weird update process; basically you should always use mintupdate to update (it's the gui thingy in your systemtray) and not synaptic and/or the command line.

- you didn't update regularly or properly or have added conflicting ppas or other fishy sources

- mint 13 isn't EOL yet, but soon. here are the supported versions of linux mint.


no 14-year-old would admit to something like that.
but hey, nevermind. i'm 15, have dyslexia, and am recovering from a recent stroke.
I don't think a 40 yr old would say he or she is 14 not in here anyways.

dyslexia:
Code:
High in IQ, yet may not test well academically; tests well orally, but not written.
Test for Dyslexia: 37 Common Traits


For the OP,

14 yrs old, you got some time on your hands. Me - personally. I'd dump that Linux distro and try a bunch of different ones, they all can have cinnamon desktop installed on them if that is the look you like, or MATE desktop if that is the look you like.

try using the, get something under the hood that works first the way you want then make it look pretty rule of thumb.

Last edited by BW-userx; 02-08-2017 at 07:50 AM.
 
Old 02-08-2017, 08:03 AM   #7
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Posts: 4,206

Rep: Reputation: Disabled
Best advice I can give is to ditch *buntu, they change things to suit themselves, & thereby make themselves incompatible with their base distro, which is Debian.

Get yourself a real Debian based distro, it will save you many a problem.
 
Old 02-08-2017, 08:27 AM   #8
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Advice:
Use Software Manager and the version(s) supported in them.
"Latest" ! = "Better". That's a Windows reflex, IMO, sooooo, http://linux.oneandoneis2.org/LNW.htm

Use the "User Guide" in LinuxMint "mintwelcome",
and https://help.ubuntu.com/
 
Old 02-08-2017, 08:32 AM   #9
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by snowpine View Post
If you read the Kdenlive download page carefully, you'll see their PPA is intended for Ubuntu 16.04 or newer. That is the equivalent of Mint 18.x.

While there may be educational/historical reasons to use an older release, the vast majority of users such as yourself will be much happier using the current version of Linux Mint.
Dependancies that "practically" force you to "comply" with Mint18 in this "release of Kdenlive" is called "Dependancy Hell" and the net result in the end with your kicking and screaming and sucking thumb in the corner,
is upgrade to LM18 and use the repo version or additionally a PPA, but the dependency likely won't be satisfiable any other way.

Free software, Gotta Love it!
 
Old 02-08-2017, 01:33 PM   #10
daree361
LQ Newbie
 
Registered: Aug 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thanks to all who offered suggestions, I'm just gonna update my LinuxMint version and see if it fixes anything, very dumb of me not to check the supported LinuxMint verions, so that's most likely the issue.
 
Old 02-08-2017, 01:48 PM   #11
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
kdenlive is in the 17.x repos.

Code:
sudo apt-get install kdenlive
may also still be in 13 repos.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How can I search for unofficial packages in Slackware? *Packages like guake terminal* theif519 Slackware 7 06-24-2011 06:30 PM
LXer: Download "Undo / Redo" Patched Nautilus [Ubuntu .deb Packages] LXer Syndicated Linux News 0 01-11-2010 04:00 PM
When DEB packages need strange packages noteventime Linux - Software 0 11-29-2005 09:37 AM
Can apt4rpm use deb repositories or install .deb packages? raylpc Linux - General 0 08-18-2003 01:49 AM
creating packages (.tgz/.deb/.rpm) How from the source packages? l_9_l Linux - General 1 03-06-2002 06:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration