LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Cannot access Windows XP shares from Linux (https://www.linuxquestions.org/questions/linux-software-2/cannot-access-windows-xp-shares-from-linux-348455/)

FKereki 07-30-2005 10:15 PM

Cannot access Windows XP shares from Linux
 
I cannot access my kid's shares on their Windows XP. I can see the shares at smb://kidsPC but when I try to browse around, I get "PLEASE ENTER AUTHENTICATION INFORMATION FOR SERVER=kidsPC SHARE=xxxxx" and even though I enter my user name and password (I have administrative rights on their machine) I cannot go forward... what can be happening?

shanenin 07-31-2005 02:03 AM

what command are you using to mount your samba share?

you could try this
Code:

mkdir /mnt/samba
mount -t smbfs //kidsPC/sharename /mnt/samba

if this fails, what error message is it giving you

also,
this is assumbing your windows computer name is kidsPC

Elomis 07-31-2005 02:08 AM

Could be domain?
 
When people browse windows shares, one of the common things they do wrong is forget the domain, remembering only the username and password.

Try this:


create a folder called remote, in any directory, then switch to the directory above that. For example /root/remote and be in /remote

type

mount -t smbfs -o username=USERNAME, password=PASSWORD, workgroup=WORKGROUPNAME //KidsPC/Sharename remote

substituting USERNAME, PASSWORD and WORKGROUPNAME for the appropriate values.

The remote folder is then a shortcut to the share on the other machine.

shanenin 07-31-2005 02:12 AM

Re: Could be domain?
 
Quote:

Originally posted by Elomis

mount -t smbfs -o username=USERNAME, password=PASSWORD, workgroup=WORKGROUPNAME //KidsPC/Sharename remote

I think you want to close up those spaces in your options
Code:


mount -t smbfs -o username=USERNAME,password=PASSWORD,workgroup=WORKGROUPNAME //KidsPC/Sharename remote


elluva 07-31-2005 06:06 AM

First you can do 'smbclient -U <username> -L KidsPC' to see if you have any reaction from the Windows PC. This will give you the available shares on KidsPC.
Next you can take one of the shares shown and fill this url in konqueror or nautilus :
smb://KidsPC/<sharename>
Often windows pc's won't show you their shares in konqueror or nautilus, I don't know why...

good luck,
Elluva

FKereki 07-31-2005 10:04 AM

Quote:

Originally posted by elluva
First you can do 'smbclient -U <username> -L KidsPC' to see if you have any reaction from the Windows PC. This will give you the available shares on KidsPC.
Next you can take one of the shares shown and fill this url in konqueror or nautilus :
smb://KidsPC/<sharename>
Often windows pc's won't show you their shares in konqueror or nautilus, I don't know why...

Doing this works -- but I can also see the shares directly from Konqueror. However, trying to examine the shares doesn't work; I get the authentication window again.

FKereki 07-31-2005 10:05 AM

Quote:

Originally posted by shanenin
what command are you using to mount your samba share?

you could try this
Code:

mkdir /mnt/samba
mount -t smbfs //kidsPC/sharename /mnt/samba

if this fails, what error message is it giving you

also,
this is assumbing your windows computer name is kidsPC

I'm using Konqueror directly, and I also tried Smb4k. I can see the shares, but when I click on them to see the files, I get the authentication window.

FKereki 07-31-2005 06:47 PM

Re: Cannot access Windows XP shares from Linux
 
Quote:

Originally posted by FKereki
I cannot access my kid's shares on their Windows XP. I can see the shares at smb://kidsPC but when I try to browse around, I get "PLEASE ENTER AUTHENTICATION INFORMATION FOR SERVER=kidsPC SHARE=xxxxx" and even though I enter my user name and password (I have administrative rights on their machine) I cannot go forward... what can be happening?
EXTRA INFORMATION: When my kids had Windows 98, I had no problem getting at the shares. I found somewhere that you had to include ENCRYPT PASSWORDS=TRUE in smb.conf, but it didn't seem to work.

Elomis 07-31-2005 08:00 PM

What I told you to type
 
What I told you to type (with the helpful additions of the other LQ geeks ;) ) will work, if it doesn't, drop the output into here and we'll help troubleshoot. It's a little confusing that you gave extra information, does that mean what I said didn't work and you are trying to help us help you from there?

I think what I told you to enter doesn't need smb.conf as it specifies some things that smb.conf just provides defaults for. give it a burl.

FKereki 08-01-2005 06:56 PM

Re: What I told you to type
 
Quote:

Originally posted by Elomis
What I told you to type (with the helpful additions of the other LQ geeks ;) ) will work, if it doesn't, drop the output into here and we'll help troubleshoot. It's a little confusing that you gave extra information, does that mean what I said didn't work and you are trying to help us help you from there?

I think what I told you to enter doesn't need smb.conf as it specifies some things that smb.conf just provides defaults for. give it a burl.

Sorry, I wasn't clear -- my fault. I tried all suggestions, and they didn't work. With the "mount -t smbfs..." command, I can see the shares, but when I try to look into any directory, I get

/bin/ls: reading directory .: Permission denied
total 0

Elomis 08-01-2005 07:30 PM

Permissions
 
It still sounds like a permissions problem.

The windows PC will be a member of either a workgroup or a domain, these are the two types of groups that you can have a windows computer in. Usually a win98 box will be in a workgroup and the name will be "workgroup" or "common".

If you do
Quote:

mount -t smbfs -o username=USERNAME,password=PASSWORD,workgroup=WORKGROUPNAME //KidsPC/Sharename remote
and subsitute USERNAME for the username of the admin account on the windows computer ("Administrator") and PASSWORD for the password of that account, and WORKGROUPNAME for the workgroup the machine is in, it should work fine.

Alternatively, leave out password=PASSWORD and if it is working correctly, it'll prompt you for the password, if not it might raise a different, more informative error message. :scratch:

exvor 08-01-2005 08:04 PM

Ok this is because of the new authentication with windows xp.

i used to do microsoft tech support and your issue is actually common.

98 does not use the authentication of users
windows xp does


you need to have the same user on the windows xp computer that you are trying to log in with samba.

that or put it on simple file shareing


you find that on any folder go to tools then folder options and then go to view

its the last option with windows xp professional
home does not have this problem..


its ither that or some other problem.

FKereki 08-02-2005 05:50 PM

A Windows XP problem, after all...
 
Reading the Windows XP help on file sharing (RTFM!!) it says you cannot use it to share any folders such as "Program Files", "Documents and Settings", or other users documents. I created a directory of my own in that machine, shared it, and I can access it with no problems at all. GRR!!!

Now I have to guess some way to be able to get at the files I need in that machine...

Thanks to everybody for the help!

Bryan Henry 08-02-2005 08:51 PM

Go to the machine and move the files... =?

FKereki 08-03-2005 08:14 PM

Quote:

Originally posted by Bryan Henry
Go to the machine and move the files... =?
Yep, the old "sneakernet" way! :)


All times are GMT -5. The time now is 04:07 PM.