-   Linux - Software (
-   -   Cannot Access Nagios Web Interface (

Doknik 09-03-2012 09:40 AM

Cannot Access Nagios Web Interface
After successfully installing Nagios core 3.4.1 (i also installed plug-in1.4.11) on our linux rhel 5.3 server i cannot login to the nagios web interface.I am running apache 2.2.3

I am using internet explorer 8 and also firefox 3.6.3

When i try to enter the url http//localhost/nagios/ on a desktop (on the same network as the Nagios server)it does seem to like

it but if i try

http//x.x.x.x/nagios/ (where x.x.x.x is the IP address of my nagios server) it likes it but then the authentication popup appears

after entering the password and username it throws the erors below

The server x.x.x.x at Nagios access requires a username and password

Warning this server is requesting that your username and password be sent in an insecure
manner(basic authentication without a secure connection)

After a few attempts i get error 401 authentication required error from internet explorer ;this server could not verify that you are authorized to access the document requested.
Either you supplied the wrong credentials or your browser doesnt understand how to supply the credentials required.

Help Please anyone..seems like an authentication issue

Doknik 09-03-2012 09:45 AM

Sorry i fixed my own problem just 3 mins after i post this thread ...i changed the permissions on htpasswd.users file it was owned by root.I changed it to be readable by nagios user..depends on your preference you can keep it owned by root and chmod it to make it readable by ALL or chown it such that its owned by nagios ..i just "chmodded" mine to make it readable and Bingo it worked

GlennsPref 09-03-2012 07:55 PM

Thank you for that.


..i just "chmodded" mine to make it readable and Bingo it worked
Fixed my source-install.

Cheers, Glenn

All times are GMT -5. The time now is 02:14 PM.