LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-09-2003, 11:02 AM   #1
stagnant7
LQ Newbie
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: Slackware
Posts: 21

Rep: Reputation: 15
Can only watch dvd with xine as root user


hi i cant seem to play a dvd (in xine) when in logged in as my normal user.
When i run it as root is plays perfect....wats up???

btw i have installed the libdvdcss i

thanks
 
Old 12-09-2003, 11:26 AM   #2
GodMinusOne
LQ Newbie
 
Registered: Aug 2003
Distribution: Slackware
Posts: 24

Rep: Reputation: 15
Have you set permissions for your other users to use the application? To find out how to do this refer to the documentation of chmod by typing "man chmod" at a shell.
 
Old 12-09-2003, 11:36 AM   #3
stagnant7
LQ Newbie
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: Slackware
Posts: 21

Original Poster
Rep: Reputation: 15
yeh...i'd already done that....well i think what i tried was right.

I made the xine binary accessable for all users (chmod 777 xine)

here is the error message I get from xine :

-xine engine error-
input plugin failed to open mrl 'dvd:/'

and also:

The source can't be read.
Maybe you don't have enough rights for this
 
Old 12-09-2003, 11:38 AM   #4
stagnant7
LQ Newbie
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: Slackware
Posts: 21

Original Poster
Rep: Reputation: 15
yeh...i'd already done that....well i think what i tried was right.

I made the xine binary accessable for all users (chmod 777 xine)

here is the error message I get from xine :

-xine engine error-
input plugin failed to open mrl 'dvd:/'

and also:

The source can't be read.
Maybe you don't have enough rights for this, or source doesn't contain data (e.g. no disc in drive). (/dev/cdrom)

any further ideas?
 
Old 12-09-2003, 01:24 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: earth
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 927Reputation: 927Reputation: 927Reputation: 927Reputation: 927Reputation: 927Reputation: 927Reputation: 927
Indeed, the users will need read/write
permissions to the raw device... the
proper way to set that up is to create
a group dvd, add your user to that group,
and
chgrp dvd /dev/<rawdevice>
chmod ug=rwx,o=r /dev/<rawdevice>


Cheers,
Tink
 
Old 12-09-2003, 11:25 PM   #6
netboy_541
Member
 
Registered: Jul 2003
Location: Hamilton, OH
Distribution: Redhat 9, SuSE 10.1 & 10.2, Kubuntu
Posts: 173

Rep: Reputation: 30
xine tends to make my machine reboot when it's playing video of any sort, but not audio only... anyone else having this weird occurance?
 
Old 01-05-2004, 09:07 AM   #7
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Rep: Reputation: 15
G'day.

I'm having the same problem - can watch DVDs only as root user.

Tinkster,

I have followed your advice and set up a group called 'dvd'. Then I added the user in question to this group. Next I did the

Quote:
chgrp dvd /dev/<rawdevice>
chmod ug=rwx,o=r /dev/<rawdevice>
thingo, whereby I was not sure what the 'raw device' was. So I did it twice, once with /dev/cdrom (dvd combo drive) and once with /dev/dvd. Was this the right thing to do? How do I find out what my 'rawdevice' is, or do I actually type in <rawdevice>?

The problem remained unchanged. Still getting error messages as user (the same ones as mentioned in previous posts in this topic).

Please help. Thanks !
 
Old 01-05-2004, 01:02 PM   #8
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
I believe the raw device is called /dev/rdvd by default, but it's shown on one of the tabs in xine's setup dialog (video tab I think). Might have to change to "expert" view on first tab though.
 
Old 01-06-2004, 07:57 AM   #9
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Rep: Reputation: 15
Thanks for your reply.

The options in the Xine setup tabs (expert level) are:

Video tab - dev/syncfb......doesn't work with above chmod commands either (doesn't exist)
dxr3 tab -/dev/em8300-0.........haven't tried it yet
input tab - /dev/cdrom............tried and makes no diff.

there are other file paths to other files, but none in the /dev directory.

I've tried rebooting etc. I've checked that the user is part of the dvd group.

Any other ideas ....please
 
Old 01-06-2004, 11:14 AM   #10
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 37
Do this in a console:
ls -l /dev/dvd
You should find out what device it points to. It should be owned by root and the group dvd. If not:
It'll be something like /dev/hdd or /dev/scd0 (if you have SCSI drives, or SCSI emulation)
Then do something like:
chown root:dvd /dev/hdd

If you don't HAVE /dev/dvd then type "dmesg" and look for a line similar to this:
hdc: IDE DVD-ROM 16X, ATAPI CD/DVD-ROM drive
This would imply that the DVD is /dev/hdc
Then do the above
Hope this helps
Guy
 
Old 01-07-2004, 09:39 AM   #11
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Rep: Reputation: 15
Thanks Guygriffiths,

I did as you said and the following resulted:

Code:
lrwxrwxrwx    1 root     dvd             3 Jan  2 22:40 /dev/dvd -> hdc
I then typed "chown root:dvd /dev/hdc"

I went through a file explorer (Konqueror) and checked out the permissions on the file /dev/hdc and found that under the 'Ownership' section of the properties window to this file :

User: root
Group: dvd

Everyone has read write and execute permissions except 'others'.

But still, can only use Xine as root user and still getting error messeages as mentioned my others above when trying as another user.

Is my prob maybe at a more fundamental level - perhaps I haven't set the group 'dvd' up correctly?

Going through KDE System Settings / Users and Groups, then choosing the Groups tab I can clearly see that there are two groups. one is called 'oliver' (the one and only user on the system other than the root user) and the other is called 'dvd'. Now behind that (in 'Group Members') I can clearly see that 'oliver' is part of both those groups.

I just don't know where the problem may be.

Thanks for your patience folks. Please help me solve this problem.
 
Old 01-07-2004, 10:10 AM   #12
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Rep: Reputation: 15
SOLVED THE PROBLEM !!!!!

It was fundamental indeed. I assumed that Xine would set itself up in the user account, the same as it does in the root account. For some reason this was not so and therefore in the user account , in the 'Input' tab in the settings, the 'device used for dvd' was not pointing to my cdrom drive. I changed these settings in the user account (so that they are the same as in the root account) and ...elpresto, DVD fully working.

Hope you're not all as confused as I am now

Thanks for your patience and help everybody. It did enable me to find a solution in the end ....eve if it was the long way around.
 
Old 01-07-2004, 11:36 AM   #13
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
Quote:
Originally posted by oliwally
SOLVED THE PROBLEM !!!!!

Thanks for your patience and help everybody. It did enable me to find a solution in the end ....eve if it was the long way around.
but by posting your solution, maybe it will be a shorter way around in the future for someone else with the same problem. thanks.

 
Old 01-08-2004, 01:48 PM   #14
cyris
Member
 
Registered: Apr 2001
Distribution: Gentoo 1.4_rc3; Slackware 8.1; Red Hat 8.0
Posts: 49

Rep: Reputation: 15
I get the exact same error as you were getting as a user, however I get this error as root also.

Code:
-xine engine error-
Code:
input plugin failed to open mrl 'dvd:/'
I read your resolution and don't really follow. What do you mean you thought XINE would set itself up in the user account. Is there a group or something that XINE creates that users need to be a part of?
 
Old 01-08-2004, 02:30 PM   #15
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 37
He means (I think) that you have to set up Xine with it's setup menu for every user you run it with, because it creates ~/.xine config files.
You will need to setup the dvd device in the setup (go to top level "master of the known universe" or something first)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help, can't watch tv with my tv-card (in xine) laurentwahl Linux - Software 19 12-16-2005 03:48 PM
Can only watch WMV files as root user? insanity101 Mandriva 1 05-04-2005 05:35 AM
Can I use xine to watch tv? bruno buys Linux - Software 1 04-26-2004 07:09 AM
can watch movie using gmplayer in root, but not as a user!? sirpelidor Linux - Software 6 01-07-2004 04:04 AM
Can't watch my DVD's with xine tommym Linux - Software 3 10-31-2003 08:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration