-   Linux - Software (
-   -   can not play WMV video files (

Mistreated 11-23-2005 03:18 PM

cannot play WMV video files
I've got latest codecs installed (win32 codecs also), but i cant play some WMV video files. I was trying to do it with different players (MPlayer, Kaffeine, KMplayer).

Kaffeine shows the following error:
xine: couldn't find demux for >5628_warped.wmv<
xine: found input plugin : file input plugin

Mplayer displays this (at list it plays sounds):
Cannot find codec matching selected -vo and video format 0x33564D57.

Some WMV are opened without any problems, but not all of them. Why so?

Any suggestions?
Thanks in advance!

linmix 11-23-2005 03:28 PM

mught be the wmv's are protected. I had similar problems with a few wmv's some timne ago. When I tried them on a windows system it tried to make me visit a wabsite to get a temporary passkey!?!

Mistreated 11-23-2005 03:48 PM

Hmm.. I don't think so.. I was trying to run them with MS Media Player through Wine, and there were no problems.
Maybe it's possible to convert them to other format? .. but how, if the codecs doesn't work.. :(

kfoster11 12-07-2005 11:22 PM

I was using MPLAYER to play WMV but some would'nt work. I installed MPLAYER and the ESSENTIAL codecs from Mplayer site. Some WMV's just wouldn't play and I would get an error message similar to yours. I then found another set of CODECS and installed them. Now ALL WMVs work. Since I use Slack I did the rpm2tgz and create a slack install file. However it isn't really an install, the codecs get copied to /usr/lib/win32. I didn't have to recompile MPLAYER or anything. Just started it up and everything now works.

Try this site here to get the other CODECS.


linmix 12-08-2005 10:16 AM

well, as the original post says, the win32 codecs are installed... still, no harm in checking twice!
This make me think of another possible reaon though. Where did you install the codecs. Apparently different apps look in different places and maybe the output of one of them indicates where it should be.
Also,, where did you get those 'latest' codecs. MAybe they were on a site that isn't updated regularly. Try the Mplayer home site, or the link kfoster11 suggstes.

linmix 12-08-2005 10:16 AM

... accidentally clicked twice ...

kfoster11 12-08-2005 03:06 PM

Both sets of CODECs were installed in /usr/lib/win32. The first set I got came straight from Mplayers website. I had problems playing some WMV with their codecs. I then installed the CODECs from the other website into the same directory /usr/lib/win32. Now I can play all of the WMVs I have. And yes, some players look in different places. You would probably have to configure whatever player you use to look in the proper place. MPlayer looks in /usr/lib/win32 by default.

Mistreated 12-20-2005 01:00 PM

Sorry, guys, but this just doesn't work. :( I've downloaded new version of win codecs and win essential codecs from MPlayer's web site. I extracted them to the /usr/lib/win32 directory. But nothing changed, i still can't play some wmv files with any player. :( Maybe i have to make some changes to MPlayers configuration, so it would correctly work with new codecs?

Tha_Hill 12-21-2005 12:40 PM


Unpack the codecs archives and put the contents in a directory where MPlayer
will find them. The default directory is /usr/local/lib/codecs/ (it used to be
/usr/local/lib/win32 in the past, this also works) but you can change that to
something else by using the '--with-codecsdir=DIR' option when you run
This is what the readme file says if you download the source code of mplayer. The codecs must be added in that directory before you compile mplayer. If you have a package of mplayer. You might try adding them to /usr/lib/codecs. And hope the creator of the package compiled it with that directory.
I had a few problems playing wmv to. I am not sure but i thought mplayer doesnt support wmv 9

linmix 12-22-2005 02:04 AM

Starting mplayer from the command line usually provides a lot of output and there'l likely be something useful in it.

Mistreated 12-22-2005 03:43 PM

I've found the solution it's not about codecs it's about mplayer's installation. Codecs that i had in my /usr/lib/win32 were ok. All i had to do is to merge mplayer again with win32codecs USE flag. Now everything is working fine!
It looks like this in the command line (Gentoo users only):
#USE="win32codecs" emerge mplayer

All times are GMT -5. The time now is 04:19 PM.