LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-27-2017, 09:53 AM   #1
sma7
LQ Newbie
 
Registered: May 2017
Posts: 6

Rep: Reputation: Disabled
Can not install WxWidgets in Ubuntu 16.04


Hi, trying to install WXWidgets from source wxwidgets3.0-3.0.2.orig , and configure appearing complete:

tus: creating utils/helpview/src/Makefile
config.status: creating utils/helpview/Makefile
config.status: creating utils/Makefile
config.status: creating lib/wx/include/gtk2-unicode-3.0/wx/setup.h
config.status: executing wx-config commands

Configured wxWidgets 3.0.2 for `x86_64-unknown-linux-gnu'

Which GUI toolkit should wxWidgets use? GTK+ 2 with support for GTK+ printing libnotify
Should wxWidgets be compiled into single library? no
Should wxWidgets be linked as a shared library? yes
Should wxWidgets support Unicode? yes (using wchar_t)
What level of wxWidgets compatibility should be enabled?
wxWidgets 2.6 no
wxWidgets 2.8 yes
Which libraries should wxWidgets use?
STL no
jpeg builtin
png sys
regex builtin
tiff builtin
zlib sys
expat sys
libmspack no
sdl no


however at make step I get:



.0 -I/usr/include/libpng12 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/freetype2 -D_GNU_SOURCE -fvisibility=hidden ./src/regex/regfree.c
rm -f /home/sem/Downloads/wxwidgets3.0-3.0.2.orig/lib/libwxregexu-3.0.a
ar rcu /home/sem/Downloads/wxwidgets3.0-3.0.2.orig/lib/libwxregexu-3.0.a wxregex_regcomp.o wxregex_regexec.o wxregex_regerror.o wxregex_regfree.o
ar: `u' modifier ignored since `D' is the default (see `U')
ranlib /home/sem/Downloads/wxwidgets3.0-3.0.2.orig/lib/libwxregexu-3.0.a
make: *** No rule to make target 'src/jpeg/jcomapi.c', needed by 'wxjpeg_jcomapi.o'. Stop.



Cant tell what is missing...

Any ideas?
 
Old 05-27-2017, 12:43 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,430

Rep: Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623
Welcome to LQ.

Why not install the default Ubuntu 16.04 wxwidgets3.0 (3.02) packages ?
sudo apt install libwxgtk3.0-dev
... etc. etc. version 3.02 .
https://packages.ubuntu.com/search?k...searchon=names


-
 
1 members found this post helpful.
Old 05-27-2017, 08:41 PM   #3
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
wxwidgets is, and has always been tricky. If you're installing from source, you need all the dependencies. You can try,
Code:
$ apt-get build-dep wxwidgets3.0
Then try ./configure again.

And, knudfl's question.
 
Old 05-28-2017, 07:39 AM   #4
sma7
LQ Newbie
 
Registered: May 2017
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thanks, I have now installed Wxwidgets with the sudo command!

Best wishes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install MoreAmp-0.1 29(-bn) with wxWidgets-3.0.2 tar.bz2 in Ubuntu 14.04.3 LTS 64 Bit alfreditoelloco Linux - Newbie 5 10-18-2015 11:08 AM
[SOLVED] Trying to install Code::Blocks, wxWidgets on Debian Wheezy kathbeau Linux - Software 5 11-19-2014 01:05 PM
wxWidgets install- gtk+-2.0.pc not found mchcph Linux - Software 3 05-20-2011 12:45 AM
Compiling wxWidgets on Ubuntu 9.04 windows22 Linux - Newbie 6 07-31-2009 01:54 AM
How to install wxWidgets on linux (e.g. Ubuntu) openfun Ubuntu 1 07-12-2005 10:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration