-   Linux - Software (
-   -   Can no longer access my Samba shares (

Toonses82 07-19-2009 12:08 AM

Can no longer access my Samba shares
I have a Kubuntu 9.04 desktop acting as a central server for my files. I don't know why, but one day I just couldn't access it anymore.

The Kubuntu server is wired to my Dlink router. I was accessing the server from my two wireless Windows XP laptops. It was working great and wasn't anything super complicated. To set it up, I edited my smb.conf file from "security=user" to "security=share". Then, through the properties of the folder I wanted to share, I added it as a shared folder. Pretty simple.

From there I went over to my laptop and could immediately see the shared drive in My Network Neighborhood. Boom. Done. This has worked for me for years. Suddenly, now, I can't access the drive anymore. It gives me an error window saying the location cannot be found.

I don't know what changed, but I can't seem to get it working again. My knowledge of networks isn't tremendously robust but I don't believe it's a network issue. Maybe it is. I don't know. How do I begin to fix this?

Here's my smb.conf:


# Sample configuration file for the Samba suite for Debian GNU/Linux.
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which
# are not shown in this example
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic
# errors.
# A well-established practice is to name the original file
# "smb.conf.master" and create the "real" config file with
# testparm -s smb.conf.master >smb.conf
# This minimizes the size of the really used smb.conf file
# which, according to the Samba Team, impacts performance
# However, use this with caution if your smb.conf file contains nested
# "include" statements. See Debian bug #483187 for a case
# where using a master file is not a good idea.

#======================= Global Settings =======================


## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
  workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
  server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#  wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;  wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
  dns proxy = no

# What naming service and in what order should we use to resolve host names
# to IP addresses
;  name resolve order = lmhosts host wins bcast

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;  interfaces = eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;  bind interfaces only = yes

#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
  log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
  max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#  syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
  syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
  panic action = /usr/share/samba/panic-action %d

####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
#  security = share

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
  encrypt passwords = no

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using. 
  passdb backend = tdbsam

  obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
  unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<> for
# sending the correct chat script for the passwd program in Debian Sarge).
  passwd program = /usr/bin/passwd %u
  passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
  pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
  map to guest = bad user

########## Domains ###########

# Is this machine able to authenticate users. Both PDC and BDC
# must have this setting enabled. If you are the BDC you must
# change the 'domain master' setting to no
;  domain logons = yes
# The following setting only takes effect if 'domain logons' is set
# It specifies the location of the user's profile directory
# from the client point of view)
# The following required a [profiles] share to be setup on the
# samba server (see below)
;  logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#  logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;  logon drive = H:
#  logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;  logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the
# SAMR RPC pipe. 
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe. 
; add group script = /usr/sbin/addgroup --force-badname %g

########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
#  load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
;  printing = bsd
;  printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;  printing = cups
;  printcap name = cups

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;  include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#        SO_RCVBUF=8192 SO_SNDBUF=8192
#  socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
;  message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
#  domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;  idmap uid = 10000-20000
;  idmap gid = 10000-20000
;  template shell = /bin/bash

# The following was the default behaviour in sarge,
# but samba upstream reverted the default because it might induce
# performance issues in large organizations.
# See Debian bug #368251 for some of the consequences of *not*
# having this setting and smb.conf(5) for details.
;  winbind enum groups = yes
;  winbind enum users = yes

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;  usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
  usershare allow guests = yes

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares.  This will share each
# user's home directory as \\server\username
;  comment = Home Directories
;  browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;  read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;  create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;  directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.  Un-comment the following parameter
# to make sure that only "username" can connect to \\server\username
# This might need tweaking when using external authentication schemes
;  valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;  comment = Network Logon Service
;  path = /home/samba/netlogon
;  guest ok = yes
;  read only = yes
;  share modes = no

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;  comment = Users profiles
;  path = /home/samba/profiles
;  guest ok = no
;  browseable = no
;  create mask = 0600
;  directory mask = 0700

  comment = All Printers
  browseable = no
  path = /var/spool/samba
  printable = yes
  guest ok = no
  read only = yes
  create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
  comment = Printer Drivers
  path = /var/lib/samba/printers
  browseable = yes
  read only = yes
  guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;  write list = root, @lpadmin

# A sample share for sharing your CD-ROM with others.
;  comment = Samba server's CD-ROM
;  read only = yes
;  locking = no
;  path = /cdrom
;  guest ok = yes

# The next two parameters show how to auto-mount a CD-ROM when the
#        cdrom share is accesed. For this to work /etc/fstab must contain
#        an entry like this:
#      /dev/scd0  /cdrom  iso9660 defaults,noauto,ro,user  0 0
# The CD-ROM gets unmounted automatically after the connection to the
# If you don't want to use auto-mounting/unmounting make sure the CD
#        is mounted on /cdrom
;  preexec = /bin/mount /cdrom
;  postexec = /bin/umount /cdrom

jschiwal 07-19-2009 01:50 AM

Your "security = share" is commented out. I bet there was an update and smb.conf got changed on you.

I also don't see a definition for any shares defined either.

Toonses82 07-19-2009 02:23 AM

1 Attachment(s)
Well I certainly can be an idiot sometimes. I didn't notice it got commented out. I fixed that and tried it again, but my Windows machine still can't see any shared drive on the network.

I'm not sure what the deal is with the share definitions. I think I'm doing it right. I've attached a screenshot of what I did to share the directory. I want to share /home/grassman20/ and it just isn't happening. I'm not sure what changed, but this is how I did it before.

jschiwal 07-19-2009 05:20 AM

Do the shares show up in the Windows browser?
If not look at your firewall settings.
You need these ports open: 137/udp, 138/udp, 139/tcp & 445/tcp open.

Samba can be configured for working with just 445/tcp, but open the other ports if that doesn't work.

Also make sure that the smb service is running. You can use either
sudo /sbin/service smb status
sudo /sbin/chkconfig smb

I haven't used kubuntu. Look in your configuration dealing with users and security. Is there a check box on whether users can share directories?

Toonses82 07-19-2009 12:00 PM

I ran sudo nmap -sS -O to see what ports are open and here is the output:


Starting Nmap 4.76 ( ) at 2009-07-19 09:44 PDT                                     
Interesting ports on localhost (     
Not shown: 996 closed ports                     
PORT    STATE SERVICE                           
139/tcp  open  netbios-ssn                       
445/tcp  open  microsoft-ds                     
631/tcp  open  ipp                               
9091/tcp open  unknown                           
No exact OS matches for host (If you know what OS is running on it, see ). 
TCP/IP fingerprint:                             

Network Distance: 0 hops

OS detection performed. Please report any incorrect results at .
Nmap done: 1 IP address (1 host up) scanned in 11.48 seconds

I see that 137 and 138 are not listed and I can't figger how to open them. I tried sudo iptables -A INPUT -p tcp -d 0/0 -s 0/0 --dport 137 -j ACCEPT and again for 138 and neither returned any errors or anything. But when I ran the nmap again, it returned the same result. I never had to do this before, but I'm open to whatever will get it working.

I also ran the two commands to see if smb is running and it appears not to be. Here's the output:


grassman20@Media-Center:~$ sudo /sbin/service smbstatus
sudo: /sbin/service: command not found
grassman20@Media-Center:~$ sudo /sbin/chkconfig smb
smb: unknown service

I looks like this is the problem. What do I do and how do I make sure it runs every time the computer is restarted?

jschiwal 07-19-2009 01:31 PM

You may be OK with the firewall settings. The ports 137/udp, 138/udp are used if udp network broadcasts are used for browsing. Port 455 replaces them on modern Windows hosts.

You need to validate your samba package. It seems that more was changed than simply smb.conf. You may not have the binary or the startup script.

On Ubuntu you may not need to precede commands with the full path. Your `service' command may be located elsewhere such as in /usr/sbin/. Try "sudo service smb status". If that doesn't work, try "sudo service smbd status". Also try "locate 'bin/smbd'. If it can't find the smbd binary, it looks like samba is uninstalled. You should have an smbd binary, probably in /usr/sbin/smbd. You should have a startup script /etc/init.d/smb, and links to the script in /etc/init.d/rc3.d/, and /etc/init.d/rc5.d. The links that start with a "K" are to kill the service. The links that start with "S" are to start it.

note: The /etc/rc.d and /etc/init.d/ directories are the same directory. Two versions of linux used one or the either. So if you run into documentation that uses /etc/rc.d/rc3.d/ instead of /etc/init.d/rc3.d, it doesn't matter which you use.

On systems where chkconfig is used, the commented header of the startup script determines in which runlevels the script runs, and if there are any dependent services which need to be started when the service starts, or stopped when stopping the service.

Chkconfig the creates a symbolic link in /etc/rc.d/rc3.d/ to the /etc/init.d/smb script. The links will have a names like /etc/init.d/rc3.d/K01smb and /etc/init.d/rc3.d/S10smb. The S* links are for starting services and the K* links are for stopping them. The number determines the order that the scripts are run. On systems that don't use chkconfig, the "insserv" command can be used instead. It can also be done manually using the "ln -s" command, but it would be better to use the config tool that your distro uses to do this.

Note: Double check whether Kubuntu should be using chkconfig. If chkconfig does indeed work on your system, and you can restore the /etc/init.d/smb startup script, then you can run "sudo chkconfig smb 35" to install the links.
The script might be named "smbd" on your system.

Toonses82 07-19-2009 02:23 PM

Samba is installed. Here's what the initial commands returned:

grassman20@Media-Center:~$ sudo service smb status[sudo] password for grassman20:                 
$smb: unrecognized service                       
grassman20@Media-Center:~$ sudo service smbd status                                               
$smbd: unrecognized service                     
grassman20@Media-Center:~$ locate bin/smbd       

I don't have /etc/init.d/smb but I do have /etc/init.d/samba. I'm not sure if this is the same thing.

I don't have directories /etc/init.d/rc3.d/ or /etc/init.d/rc5.d. I also don't have /etc/rc.d. The /etc/ directory does have folders called rc0.d, rc1.d, rc2.d, rc3.d, rc4.d, rc5.d, rc6.d, and rcS.d.

Do I have what I need or do things need to be created? It seems to me that the file structure should be in place as this was working before and I haven't changed anything except for the possible Samba upgrade. I don't think a package upgrade would delete existing directories, would it?

Thanks for your help.

wisdom 07-19-2009 03:30 PM

I just looked through your smb.conf file and didnt see the shared drive listed anywhere in there that you mentioned

maybe you want to open up a terminal and add it manually at the bottom? try the following asuming your smb.conf file is located in /etc/samba/

# vi /etc/samba/smb.conf
Scroll down to the botton of the file and add this

comment = grassman20 files
path = /home/grassman20/
guest ok = Yes
Read only = No
browseable = yes

Then when you have done that save and exit vi by pressing Esc key then ":" then "wq" without the quotes, then just restart the services by doing


/sbin/services smb restart
and then try to access it also scroll up in the file and remove the # from before the "security = share"

Hope this helps

Toonses82 07-19-2009 04:06 PM

1 Attachment(s)
Ok, so I manually added the share in the smb.conf file like you mentioned. That went fine. When I tried to restart the service with /sbin/services smb restart, it gave me a no such file or directory. It seems the services doesn't exist. It was here that I vocally said "The hell with it" and just restarted the computer.

So I did that but I still couldn't access the computer via my Windows laptop. I've included a snapshot of the error I get when trying to access the server. It seems odd since I can ping it just fine.

wisdom 07-19-2009 06:11 PM

There is a number of factor to take into consideration , You might need to adjust your firewall on windows so that it will trust your network etc, and also linux iptables to see if you got ports open 135, 137-139 and 445, might want to try adding the following lines but with your own network IP and subnet in place


-I INPUT 1 -p tcp --source --dport 137:139 -j ACCEPT
-I INPUT 1 -p udp --source --dport 137:139 -j ACCEPT
Also you might want to add the folder name at the end of the ip address in explorer to do directly into it instead of just the ip address

jschiwal 07-19-2009 08:03 PM

The samba script is the script which starts and stops the samba service. My system uses the name "smb" for the script, yours uses "samba". Try "locate smbd" and "locate samba". If there is a /usr/sbin/smbd or /usr/bin/smb, then try starting samba for a test "sudo /etc/init.d/samba start". If that is successful, configure samba to start in the run levels that kubuntu normally uses. Debian based systems AFAIK use different run levels than many. If your system uses chkconfig, then you can look at some of the service configurations:

sudo /sbin/chkconfig --list network smb smbfs nmb winbind
network                  0:off  1:off  2:on  3:on  4:off  5:on  6:off
smb                      0:off  1:off  2:off  3:off  4:off  5:off  6:off
smbfs                    0:off  1:off  2:off  3:on  4:off  5:on  6:off
nmb                      0:off  1:off  2:off  3:off  4:off  5:off  6:off
winbind                  0:off  1:off  2:off  3:on  4:off  5:on  6:off

The network system on my desktop is enabled in the single user run level (2 on my system) because of dbus. The samba service should probably be enabled for every run level the network service (if you have one) uses except for the single user run level.
Try using chkconfig to enable the samba service you would run:
sudo chkconfig samba <runlevelnumbers>

For my runlevels I would run:
sudo chkconfig samba 35

I think that ubuntu would use

sudo chkconfig samba 23
You could check by running "sudo chkconfig --list | less" to list all of the services.

auditd                    0:off  1:off  2:off  3:on  4:off  5:on  6:off
avahi-daemon              0:off  1:off  2:off  3:on  4:off  5:on  6:off

If any of the following services are running, you probably want the same runlevel:
avahi-dnsconfd, java.binfmt_misc, mysql, nfsserver, nscd, portmap, postfix, smb, smbfs, sshd, vsftpd, winbind, xend
ex: sudo chkconfig avahi-dnsconfd

Check the "network" service. samba should run in the run levels of the network service except for run level 1. That is for the dbus daemon.
sudo chkconfig --list network

Lastly, if your system uses upstart, you may want to read up on it. Upstart is a replacement of /sbin/init. Which is the program run when starting or switching run levels.

Toonses82 07-19-2009 08:19 PM

Guys, I have no idea what happened or why we couldn't fix it. But I got it working again.

I completely uninstalled Samba and all related packages and deleted any residual files and restarted the machine. When it was back up, I ran the following:

sudo apt-get autoremove
sudo apt-get clean
sudo apt-get update
sudo apt-get install samba

Once that was done, I edited my fresh clean smb.conf file to say "security=share" and uncommented it. From there I went to the properties of my grassman20 folder and set up simple sharing just like I showed in my original screenshot. I then went over to my Windows laptop and typed \\Media-Center\Server\ in the address bar and everything shows up.

I swear I did all this already, but whatever. Who the hell knows what the deal was before. I'm just glad it's working again. Thanks for all your help with this.

All times are GMT -5. The time now is 10:28 PM.