Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 12-21-2004, 11:59 AM   #1
LQ Newbie
Registered: Feb 2004
Location: Winnipeg, Canada
Distribution: Debian
Posts: 15

Rep: Reputation: 0
Unhappy Can't select KDE session


I'm running Debian Sarge. Just installed the nvidia graphics drivers, and played some Doom 3 last night. (which was simply awesome) This morning however, I had the nasty surprise of getting a Gnome session. I logged out, selected KDE session, logged back in, but it was no use: I can't get KDE, only Gnome. How do I fix this? I recently installed the 2.6.8-1-686 kernel, as Doom 3 recommends it.

I had this exact same problem with Fedora Core 2: If you had Gnome installed, you couldn't run KDE.


And for me, it IS a problem. I've installed linux on 6 different computers, ranging from 7-year old clunkers to hot-rod gaming machines. I've used different distributions*, video cards, and motherboards. And it's always the same thing: KDE runs smoothly, Gnome consistently causes errors within minutes of logging in.

While writing this message I've gotten "The Application "nautilus" has quit unexpectedly" multiple times. The Gnome panel has also died, it flickered on and off for a while and then I got: "I've detected a panel already running and will now exit." In my experience, this isn't bad for Gnome. On Fedora, it would periodically freeze the computer and corrupt a bunch of system files, making it impossible to reboot without a rescue CD.

But I have no strong preference one way or the other; if Gnome actually worked**, I wouldn't need KDE. So an alternate fix to my problem would be to tell me what I can do to make Gnome more stable.

*Red Hat 9, Fedora Core 1 and 2, Debian Woody, Debian Sarge
**For longer than 10 minutes
Old 12-21-2004, 12:05 PM   #2
Registered: Dec 2004
Location: USA
Distribution: CentOS 4.4,Ubuntu 6.10&7.04,Win XP(the wife's)
Posts: 151

Rep: Reputation: 30
I know with fedora and few other distro's that I have used changing /etc/sysconfig/desktop settings to desktop=KDE does the trick. In that same file desktopmanager=kde will also set kdm as the default desktop manager. I do not recall if debian uses the exact same file /etc/sysconfig/desktop, but if it doesn't. I believe it is pretty close. Hope this helps. KDE 3.3X is really strong.
Old 12-21-2004, 12:53 PM   #3
LQ Newbie
Registered: Feb 2004
Location: Winnipeg, Canada
Distribution: Debian
Posts: 15

Original Poster
Rep: Reputation: 0
Alas, I don't seem to have a file like that. I found /etc/gdm/gdm.conf, which looks promising, I'm reading through it now.

> Hope this helps. KDE 3.3X is really strong.

Thanks for the info I think Sarge uses KDE 3.2, are there any significant changes in 3.3?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE session fails! Lockheed Slackware 2 03-15-2005 01:52 AM
KDE 3.3.2 lock session pete123 Linux - Software 0 12-26-2004 01:38 PM
Can't select Parellel printer with Cups Admin or KDE Print Manager EnigmaX Linux - Newbie 6 08-16-2004 09:29 PM
KDE multi session MadCow Mandriva 6 10-20-2003 03:15 PM
Cannot select ALSA sound in kde paulicat Slackware 1 09-30-2003 03:18 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:03 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration