LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-19-2004, 12:06 AM   #1
aiims1777
Member
 
Registered: Oct 2003
Location: India
Distribution: Kubuntu Dapper Drake, Edgy Eft;Red Hat Linux 9 Personal Edition
Posts: 39

Rep: Reputation: 15
Can't play midi files with kmid or kmidi


I have been trying to play some midi files using kmid. I always get the message "Can't open /dev/sequencer. It appears that some other program is using it." I have no other programs running and the ps command does not show any such processes.
I found that the /dev directory contains sequencer and sequencer2. I changed their permissions to rwx for u,g,o and it took effect.
But I still can't play my midi files.
Please help.
Thanks.
(My distro is RedHat 9)
 
Old 10-19-2004, 11:48 AM   #2
jollyjoice
Member
 
Registered: Aug 2003
Location: UK
Distribution: Gentoo 64
Posts: 383

Rep: Reputation: 30
have you got a maper installed? I know i can't play midis and don't have one but havent had time to look. If running KDE its under sound - sound system - midi - "Use a midi mapper" (bottom).
 
Old 11-10-2004, 04:22 PM   #3
rdnelson
LQ Newbie
 
Registered: Aug 2003
Location: Princeton, NJ, USA
Distribution: Fedora, Centos, Ubuntu
Posts: 19

Rep: Reputation: 0
playmidi says no /dev/sequencer

I wish to play a midi file, but playmidi does not work:

/home/rdn/music% playmidi pentatubes100.mid
Playmidi 2.4 Copyright (C) 1994-1997 Nathan I. Laredo, AWE32 by Takashi Iwai
This is free software with ABSOLUTELY NO WARRANTY.
For details please see the file COPYING.
open /dev/sequencer: No such device

This is the listing for /dev/sequencer
/home/rdn/xplore% ls -l /dev/sequencer
crw------- 1 rdn root 1 Aug 30 2001 /dev/sequencer

And the file type is:
/home/rdn/xplore% file /dev/sequencer
/dev/sequencer: character special (14/1)14,

Can someone give a usable explanation and a cure for this problem
(which I see several other people have reported.)

Thanks in advance,

Roger
 
Old 11-28-2004, 08:49 AM   #4
ktruba
LQ Newbie
 
Registered: Oct 2004
Location: Latvia
Distribution: SuSE 9.1
Posts: 5

Rep: Reputation: 0
i have the same problem: i can't play midi files. i've enabled midi mapper usage in control center, but it doesn't work anyway. i've tried to open kmid form konsole, and it was unable to open (it said that it's unable to read from libkmidlib). then i decided to uninstall kmid and install a newer version. i've downloaded kmid, but when i tried to install it, i met a dependencies problem. dependencies were to much. i also tried to install from source, but no results. what should i do?

thanks
 
Old 11-28-2004, 11:26 AM   #5
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
what sound card ?
 
Old 11-28-2004, 02:57 PM   #6
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48
timidity

I had problems with kmidi in the fedoras. So did my friend who installed it on knoppix. I ended up using timidity, which works very nicely.
 
Old 11-28-2004, 10:19 PM   #7
aiims1777
Member
 
Registered: Oct 2003
Location: India
Distribution: Kubuntu Dapper Drake, Edgy Eft;Red Hat Linux 9 Personal Edition
Posts: 39

Original Poster
Rep: Reputation: 15
Just download timidity++ and install it. It plays midi files very well. I have given up trying to use kmid and kmidi.
 
Old 12-01-2004, 10:58 PM   #8
ktruba
LQ Newbie
 
Registered: Oct 2004
Location: Latvia
Distribution: SuSE 9.1
Posts: 5

Rep: Reputation: 0
my distro is SuSE 9.1 Pro
i don't have working midi mapper. in Control Center i've set to use it, but i can't play midi anyway. when i try to open /opt/kde3/bin/kmid from the Konsole, it gives me an error. this is my Konsole output:


KMid 2.0 Copyright (C) 1997,98,99,2000,01 Antonio Larrosa Jimenez. Malaga (Spain)
KMid comes with ABSOLUTELY NO WARRANTY; for details view file COPYING
This is free software, and you are welcome to redistribute it
under certain conditions

libpng error: Read Error
libpng error: Read Error
libpng error: Read Error
kmid: error while loading shared libraries: /opt/kde3/lib/libkmidlib.so.0: undefined symbol: _ZN13KToggleAction15setCheckedStateERK8KGuiItem


i tried to reinstall kmid, but it gave me too much failed dependencies.

could anybody help me please? :/
 
Old 12-03-2004, 10:29 PM   #9
aiims1777
Member
 
Registered: Oct 2003
Location: India
Distribution: Kubuntu Dapper Drake, Edgy Eft;Red Hat Linux 9 Personal Edition
Posts: 39

Original Poster
Rep: Reputation: 15
I will repeat my advice. Install timidity++ and enjoy listening to your midi files.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound with MIDI files in kmid - Fedora Core 4 PeterRJG Linux - Newbie 1 08-06-2005 03:08 AM
Cannot play MIDI files! koolgentoo Linux - Hardware 2 07-24-2005 07:26 AM
I need to play midi files... trey85stang Linux - Software 2 02-27-2005 11:06 AM
How to play MIDI files: needed a MIDI mapper? vharishankar Linux - General 3 12-30-2004 12:12 AM
How do I play MIDI files? sirhack Linux - Hardware 1 04-06-2003 08:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration