LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-22-2017, 07:21 PM   #1
ComputerCritic
Member
 
Registered: Mar 2017
Posts: 43

Rep: Reputation: Disabled
Question Can't access Apache HTTP Server from VM while network setup method is NetworkManager service


Firefox shows "unable to connect"... But can access the server fine when the network setup method is Wicked service.
Apache HTTP Server is on the host device.
I am using OpenSUSE Leap 42.2 on a Dell Inspiron 1545. I am using Lubuntu 14.04 LTS on QEMU/KVM.
I am using a virtual network vnet1. I bridged Ethernet and Wi-Fi to virbr0.
On QEMU/KVM, the "virtual network" device model is set to VirtIO.
On the virtual network, IPv4 is NAT, and IPv6 is routed.
What could be going on?
 
Old 05-22-2017, 08:47 PM   #2
scasey
LQ Veteran
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.8.2003
Posts: 5,435

Rep: Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066
Is httpd running? You'll get "unable to connect" if it's not up even if the network connection is working.
If so, and it's really a networking problem, you'll need to provide more information, I'd think.
To begin with, what are the results of ifconfig when the network setup method is Wicked service compared to the results when the setup method is NetworkManager.
 
Old 05-23-2017, 11:01 AM   #3
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,413
Blog Entries: 10

Rep: Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226Reputation: 5226
um, i think one should look at op's other threads, many of which are network/virtualisation related.

CC, can you summarize? solved and unsolved problems so far?
 
Old 05-23-2017, 09:20 PM   #4
ComputerCritic
Member
 
Registered: Mar 2017
Posts: 43

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by scasey View Post
Is httpd running? You'll get "unable to connect" if it's not up even if the network connection is working.
If so, and it's really a networking problem, you'll need to provide more information, I'd think.
To begin with, what are the results of ifconfig when the network setup method is Wicked service compared to the results when the setup method is NetworkManager.
NetworkManager:
Code:
 ip address show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether f2:e2:97:e2:d6:2f brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.15/24 brd 192.168.0.255 scope global dynamic eth0
       valid_lft 604532sec preferred_lft 604532sec
    inet6 fe80::f0e2:97ff:fee2:d62f/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 70:1a:04:c5:64:90 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.16/24 brd 192.168.0.255 scope global dynamic wlan0
       valid_lft 604632sec preferred_lft 604632sec
    inet6 fe80::721a:4ff:fec5:6490/64 scope link 
       valid_lft forever preferred_lft forever
5: virbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 52:54:00:6d:d1:1c brd ff:ff:ff:ff:ff:ff
    inet 192.168.100.1/24 brd 192.168.100.255 scope global virbr0
       valid_lft forever preferred_lft forever
    inet6 fc00::1/64 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fe6d:d11c/64 scope link 
       valid_lft forever preferred_lft forever
6: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast master virbr0 state DOWN group default qlen 1000
    link/ether 52:54:00:6d:d1:1c brd ff:ff:ff:ff:ff:ff
7: vnet0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master virbr0 state UNKNOWN group default qlen 1000
    link/ether fe:54:00:a8:46:ee brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc54:ff:fea8:46ee/64 scope link 
       valid_lft forever preferred_lft forever
8: macvtap0@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 500
    link/ether 52:54:00:4c:98:cb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5054:ff:fe4c:98cb/64 scope link 
       valid_lft forever preferred_lft forever
9: macvtap1@wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 500
    link/ether 52:54:00:16:0c:77 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5054:ff:fe16:c77/64 scope link 
       valid_lft forever preferred_lft forever
Wicked:
Code:
 ip address show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether f2:e2:97:e2:d6:2f brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.15/24 brd 192.168.0.255 scope global dynamic eth0
       valid_lft 602927sec preferred_lft 602927sec
    inet6 fe80::f0e2:97ff:fee2:d62f/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 70:1a:04:c5:64:90 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.16/24 brd 192.168.0.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::721a:4ff:fec5:6490/64 scope link 
       valid_lft forever preferred_lft forever
5: virbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 52:54:00:6d:d1:1c brd ff:ff:ff:ff:ff:ff
    inet 192.168.100.1/24 brd 192.168.100.255 scope global virbr0
       valid_lft forever preferred_lft forever
    inet6 fc00::1/64 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fe6d:d11c/64 scope link 
       valid_lft forever preferred_lft forever
6: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast master virbr0 state DOWN group default qlen 1000
    link/ether 52:54:00:6d:d1:1c brd ff:ff:ff:ff:ff:ff
7: vnet0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master virbr0 state UNKNOWN group default qlen 1000
    link/ether fe:54:00:a8:46:ee brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc54:ff:fea8:46ee/64 scope link 
       valid_lft forever preferred_lft forever
8: macvtap0@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 500
    link/ether 52:54:00:4c:98:cb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5054:ff:fe4c:98cb/64 scope link 
       valid_lft forever preferred_lft forever
9: macvtap1@wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 500
    link/ether 52:54:00:16:0c:77 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5054:ff:fe16:c77/64 scope link 
       valid_lft forever preferred_lft forever
10: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1492 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether 02:ba:be:7c:41:1f brd ff:ff:ff:ff:ff:ff

Last edited by ComputerCritic; 05-23-2017 at 09:21 PM.
 
Old 05-27-2017, 09:37 AM   #5
ComputerCritic
Member
 
Registered: Mar 2017
Posts: 43

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by scasey View Post
Is httpd running? You'll get "unable to connect" if it's not up even if the network connection is working.
If so, and it's really a networking problem, you'll need to provide more information, I'd think.
To begin with, what are the results of ifconfig when the network setup method is Wicked service compared to the results when the setup method is NetworkManager.
I think the case may be that the VM was requesting network address from the virtual network. It kept disconnecting.
I don't know what else could be going on.
 
Old 05-28-2017, 03:24 PM   #6
ComputerCritic
Member
 
Registered: Mar 2017
Posts: 43

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by scasey View Post
Is httpd running? You'll get "unable to connect" if it's not up even if the network connection is working.
If so, and it's really a networking problem, you'll need to provide more information, I'd think.
To begin with, what are the results of ifconfig when the network setup method is Wicked service compared to the results when the setup method is NetworkManager.
Oh, I could access Apache by typing the IP address of the virtual network's gateway(the IP address assigned to the host for virbr0). But not by the IP address for wlan0 or eth0.
 
Old 05-28-2017, 05:03 PM   #7
scasey
LQ Veteran
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.8.2003
Posts: 5,435

Rep: Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066Reputation: 2066
I apologize. I know nothing about VM configuration...I missed that in the original post...and the subject.
That said, I note:
Quote:
Originally Posted by ComputerCritic View Post
Apache HTTP Server is on the host device
and
Quote:
Originally Posted by ComputerCritic View Post
Oh, I could access Apache by typing the IP address of the virtual network's gateway(the IP address assigned to the host for virbr0). But not by the IP address for wlan0 or eth0.
If Apache is on the host device (the container?? Is that right??), *should* you be able to access it from them?

I'll butt out now. I apologize again.

Last edited by scasey; 05-28-2017 at 05:16 PM.
 
Old 05-28-2017, 06:50 PM   #8
tshikose
Member
 
Registered: Apr 2010
Location: Kinshasa, Democratic Republic of Congo
Distribution: RHEL, Fedora, CentOS
Posts: 513

Rep: Reputation: 95
Please refer to this post.
I think your problem might related.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CONNECT Method Allowed in HTTP Server Or HTTP Proxy Server Vulnerability zeeshan0431 Linux - Security 1 01-13-2017 08:57 AM
Recommendation of whether to use “NetworkManager” or “Network-service “ krs4keshara Linux - Networking 1 11-01-2014 08:24 PM
[SOLVED] Apache - HTTP Server Prone To Slow Denial Of Service Attack smithy2010 Linux - Security 2 05-30-2013 04:02 AM
Disabling HTTP TRACE method in Apache bzlaskar Linux - Server 15 01-25-2010 08:44 AM
Setup linux-apache server to access documents on NT server josephswagner Linux - Software 11 04-11-2003 08:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration