LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-14-2020, 04:55 AM   #1
Balistars1
LQ Newbie
 
Registered: Sep 2018
Posts: 6

Rep: Reputation: Disabled
Angry Can't yum upgrade


Hi all,

I'm attempting some long overdue maintenance on a CentOS VM. Ultimately I want to upgrade PHP to 7.2. I tried a yum upgrade first and was hit by a huge wall of errors:

Code:
--> Finished Dependency Resolution
Error: Package: curl-7.32.0-20.fc20.x86_64 (@updates)
           Requires: libnspr4.so()(64bit)
           Removing: nspr-4.10.8-1.fc20.x86_64 (@updates)
               libnspr4.so()(64bit)
           Updated By: nspr-4.19.0-1.el6.i686 (CityFan)
               Not found
           Available: nspr-4.10.1-1.fc20.x86_64 (fedora)
               libnspr4.so()(64bit)
Error: Package: libcurl-7.32.0-20.fc20.x86_64 (@updates)
           Requires: libnss3.so(NSS_3.12.5)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so(NSS_3.12.5)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so(NSS_3.12.5)(64bit)
Error: Package: curl-7.32.0-20.fc20.x86_64 (@updates)
           Requires: libnss3.so(NSS_3.2)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so(NSS_3.2)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so(NSS_3.2)(64bit)
Error: Package: rsyslog-7.4.8-2.fc20.x86_64 (@updates)
           Requires: libestr.so.0()(64bit)
           Removing: libestr-0.1.9-1.fc20.x86_64 (@updates)
               libestr.so.0()(64bit)
           Updated By: libestr-0.1.9-2.el6.i686 (CityFan)
               Not found
           Available: libestr-0.1.5-2.fc20.x86_64 (fedora)
               libestr.so.0()(64bit)
Error: Package: rpm-libs-4.11.3-3.fc20.x86_64 (@updates)
           Requires: libnss3.so(NSS_3.2)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so(NSS_3.2)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so(NSS_3.2)(64bit)
Error: Package: mailx-12.5-11.fc20.x86_64 (installed)
           Requires: libnss3.so(NSS_3.2)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so(NSS_3.2)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so(NSS_3.2)(64bit)
Error: Package: 2:samba-client-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libldb.so.1()(64bit)
           Removing: libldb-1.1.17-2.fc20.x86_64 (installed)
               libldb.so.1()(64bit)
           Updated By: libldb-1.1.25-2.el6_7.i686 (CityFan)
               Not found
           Available: libldb-1.1.16-3.fc20.x86_64 (fedora)
               libldb.so.1()(64bit)
Error: Package: 2:samba-libs-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libldb.so.1(LDB_1.1.1)(64bit)
           Removing: libldb-1.1.17-2.fc20.x86_64 (installed)
               libldb.so.1(LDB_1.1.1)(64bit)
           Updated By: libldb-1.1.25-2.el6_7.i686 (CityFan)
               Not found
           Available: libldb-1.1.16-3.fc20.x86_64 (fedora)
               libldb.so.1(LDB_1.1.1)(64bit)
Error: Package: cyrus-sasl-lib-2.1.23-15.el6_6.2.i686 (CityFan)
           Requires: libdb-4.7.so
           Available: db4-4.7.25-22.el6.i686 (CityFan)
               libdb-4.7.so
Error: Package: 2:samba-libs-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtalloc.so.2(TALLOC_2.0.2)(64bit)
           Removing: libtalloc-2.1.1-1.fc20.x86_64 (installed)
               libtalloc.so.2(TALLOC_2.0.2)(64bit)
           Updated By: libtalloc-2.1.5-1.el6_7.i686 (CityFan)
               Not found
           Available: libtalloc-2.0.8-3.fc20.x86_64 (fedora)
               libtalloc.so.2(TALLOC_2.0.2)(64bit)
Error: Package: mailx-12.5-11.fc20.x86_64 (installed)
           Requires: libsmime3.so(NSS_3.6)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libsmime3.so(NSS_3.6)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libsmime3.so(NSS_3.6)(64bit)
Error: Package: libcurl-7.32.0-20.fc20.x86_64 (@updates)
           Requires: libnss3.so(NSS_3.9.2)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so(NSS_3.9.2)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so(NSS_3.9.2)(64bit)
Error: Package: libcurl-7.32.0-20.fc20.x86_64 (@updates)
           Requires: libnssutil3.so()(64bit)
           Removing: nss-util-3.19.1-1.0.fc20.x86_64 (@updates)
               libnssutil3.so()(64bit)
           Updated By: nss-util-3.36.0-1.el6.i686 (CityFan)
               Not found
           Available: nss-util-3.15.2-2.fc20.x86_64 (fedora)
               libnssutil3.so()(64bit)
Error: Package: 2:samba-libs-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtdb.so.1(TDB_1.2.2)(64bit)
           Removing: libtdb-1.3.1-1.fc20.x86_64 (installed)
               libtdb.so.1(TDB_1.2.2)(64bit)
           Updated By: libtdb-1.3.8-3.el6_8.2.i686 (CityFan)
               Not found
           Available: libtdb-1.2.12-2.fc20.x86_64 (fedora)
               libtdb.so.1(TDB_1.2.2)(64bit)
Error: Package: fltk-1.3.2-4.fc20.x86_64 (@updates)
           Requires: libX11.so.6()(64bit)
           Removing: libX11-1.6.1-1.fc20.x86_64 (@fedora)
               libX11.so.6()(64bit)
           Updated By: libX11-1.6.4-3.el6.i686 (CityFan)
               Not found
Error: Package: libcurl-7.32.0-20.fc20.x86_64 (@updates)
           Requires: libnss3.so(NSS_3.10)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so(NSS_3.10)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so(NSS_3.10)(64bit)
Error: Package: libcurl-7.32.0-20.fc20.x86_64 (@updates)
           Requires: libssl3.so(NSS_3.2)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libssl3.so(NSS_3.2)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libssl3.so(NSS_3.2)(64bit)
Error: Package: fltk-1.3.2-4.fc20.x86_64 (@updates)
           Requires: libXfixes.so.3()(64bit)
           Removing: libXfixes-5.0.1-2.fc20.x86_64 (@fedora)
               libXfixes.so.3()(64bit)
           Updated By: libXfixes-5.0.3-1.el6.i686 (CityFan)
               Not found
Error: Package: 2:libsmbclient-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtalloc.so.2()(64bit)
           Removing: libtalloc-2.1.1-1.fc20.x86_64 (installed)
               libtalloc.so.2()(64bit)
           Updated By: libtalloc-2.1.5-1.el6_7.i686 (CityFan)
               Not found
           Available: libtalloc-2.0.8-3.fc20.x86_64 (fedora)
               libtalloc.so.2()(64bit)
Error: Package: 2:libsmbclient-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtdb.so.1()(64bit)
           Removing: libtdb-1.3.1-1.fc20.x86_64 (installed)
               libtdb.so.1()(64bit)
           Updated By: libtdb-1.3.8-3.el6_8.2.i686 (CityFan)
               Not found
           Available: libtdb-1.2.12-2.fc20.x86_64 (fedora)
               libtdb.so.1()(64bit)
Error: Package: systemd-208-31.fc20.x86_64 (@updates)
           Requires: libaudit.so.1()(64bit)
           Removing: audit-libs-2.4.1-1.fc20.x86_64 (installed)
               libaudit.so.1()(64bit)
           Updated By: audit-libs-2.4.5-6.el6.i686 (CityFan)
               Not found
           Available: audit-libs-2.3.2-1.fc20.x86_64 (fedora)
               libaudit.so.1()(64bit)
Error: Package: libuser-0.60-3.fc20.x86_64 (installed)
           Requires: libldap-2.4.so.2()(64bit)
           Removing: openldap-2.4.39-4.fc20.x86_64 (installed)
               libldap-2.4.so.2()(64bit)
           Updated By: openldap-2.4.40-16.el6.i686 (CityFan)
               Not found
           Available: openldap-2.4.36-4.fc20.x86_64 (fedora)
               libldap-2.4.so.2()(64bit)
Error: Package: rpm-libs-4.11.3-3.fc20.x86_64 (@updates)
           Requires: libnss3.so(NSS_3.11.2)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so(NSS_3.11.2)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so(NSS_3.11.2)(64bit)
Error: Package: libcurl-7.32.0-20.fc20.x86_64 (@updates)
           Requires: libnss3.so(NSS_3.9.3)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so(NSS_3.9.3)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so(NSS_3.9.3)(64bit)
Error: Package: 2:samba-libs-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtdb.so.1(TDB_1.2.1)(64bit)
           Removing: libtdb-1.3.1-1.fc20.x86_64 (installed)
               libtdb.so.1(TDB_1.2.1)(64bit)
           Updated By: libtdb-1.3.8-3.el6_8.2.i686 (CityFan)
               Not found
           Available: libtdb-1.2.12-2.fc20.x86_64 (fedora)
               libtdb.so.1(TDB_1.2.1)(64bit)
Error: Package: rpm-4.11.3-3.fc20.x86_64 (@updates)
           Requires: libnss3.so()(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so()(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so()(64bit)
Error: Package: 1:dovecot-2.2.18-2.fc20.x86_64 (@updates)
           Requires: liblber-2.4.so.2()(64bit)
           Removing: openldap-2.4.39-4.fc20.x86_64 (installed)
               liblber-2.4.so.2()(64bit)
           Updated By: openldap-2.4.40-16.el6.i686 (CityFan)
               Not found
           Available: openldap-2.4.36-4.fc20.x86_64 (fedora)
               liblber-2.4.so.2()(64bit)
Error: Package: 2:samba-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtalloc.so.2(TALLOC_2.0.2)(64bit)
           Removing: libtalloc-2.1.1-1.fc20.x86_64 (installed)
               libtalloc.so.2(TALLOC_2.0.2)(64bit)
           Updated By: libtalloc-2.1.5-1.el6_7.i686 (CityFan)
               Not found
           Available: libtalloc-2.0.8-3.fc20.x86_64 (fedora)
               libtalloc.so.2(TALLOC_2.0.2)(64bit)
Error: Package: php-gd-5.5.26-1.fc20.x86_64 (@updates)
           Requires: libX11.so.6()(64bit)
           Removing: libX11-1.6.1-1.fc20.x86_64 (@fedora)
               libX11.so.6()(64bit)
           Updated By: libX11-1.6.4-3.el6.i686 (CityFan)
               Not found
Error: Package: xorg-x11-xinit-1.3.4-1.fc20.x86_64 (@updates)
           Requires: libX11.so.6()(64bit)
           Removing: libX11-1.6.1-1.fc20.x86_64 (@fedora)
               libX11.so.6()(64bit)
           Updated By: libX11-1.6.4-3.el6.i686 (CityFan)
               Not found
Error: Package: gd-2.1.0-8.fc20.x86_64 (@updates)
           Requires: libvpx.so.1()(64bit)
           Removing: libvpx-1.3.0-4.fc20.x86_64 (@updates)
               libvpx.so.1()(64bit)
           Updated By: libvpx-1.3.0-5.el6_5.i686 (CityFan)
               Not found
           Available: libvpx-1.2.0-2.fc20.x86_64 (fedora)
               libvpx.so.1()(64bit)
Error: Package: nss-softokn-3.19.1-1.0.fc20.x86_64 (@updates)
           Requires: libnssutil3.so(NSSUTIL_3.13)(64bit)
           Removing: nss-util-3.19.1-1.0.fc20.x86_64 (@updates)
               libnssutil3.so(NSSUTIL_3.13)(64bit)
           Updated By: nss-util-3.36.0-1.el6.i686 (CityFan)
               Not found
           Available: nss-util-3.15.2-2.fc20.x86_64 (fedora)
               libnssutil3.so(NSSUTIL_3.13)(64bit)
Error: Package: rsyslog-7.4.8-2.fc20.x86_64 (@updates)
           Requires: libjson-c.so.2()(64bit)
           Removing: json-c-0.11-6.fc20.x86_64 (@updates)
               libjson-c.so.2()(64bit)
           Updated By: json-c-0.11-13.el6.i686 (CityFan)
               Not found
           Available: json-c-0.11-3.fc20.x86_64 (fedora)
               libjson-c.so.2()(64bit)
Error: Package: rpm-libs-4.11.3-3.fc20.x86_64 (@updates)
           Requires: libnss3.so(NSS_3.4)(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libnss3.so(NSS_3.4)(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libnss3.so(NSS_3.4)(64bit)
Error: Package: 2:samba-client-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtalloc.so.2(TALLOC_2.0.2)(64bit)
           Removing: libtalloc-2.1.1-1.fc20.x86_64 (installed)
               libtalloc.so.2(TALLOC_2.0.2)(64bit)
           Updated By: libtalloc-2.1.5-1.el6_7.i686 (CityFan)
               Not found
           Available: libtalloc-2.0.8-3.fc20.x86_64 (fedora)
               libtalloc.so.2(TALLOC_2.0.2)(64bit)
Error: Package: python-libs-2.6.6-66.el6_8.i686 (CityFan)
           Requires: libexpat.so.1(EXPAT_2_0_1_RH)
           Available: expat-2.0.1-13.el6_8.i686 (CityFan)
               libexpat.so.1(EXPAT_2_0_1_RH)
           Installed: expat-2.1.0-7.fc20.x86_64 (installed)
               Not found
Error: Package: openssh-server-6.4p1-8.fc20.x86_64 (@updates)
           Requires: libldap-2.4.so.2()(64bit)
           Removing: openldap-2.4.39-4.fc20.x86_64 (installed)
               libldap-2.4.so.2()(64bit)
           Updated By: openldap-2.4.40-16.el6.i686 (CityFan)
               Not found
           Available: openldap-2.4.36-4.fc20.x86_64 (fedora)
               libldap-2.4.so.2()(64bit)
Error: Package: 2:samba-common-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtdb.so.1(TDB_1.2.1)(64bit)
           Removing: libtdb-1.3.1-1.fc20.x86_64 (installed)
               libtdb.so.1(TDB_1.2.1)(64bit)
           Updated By: libtdb-1.3.8-3.el6_8.2.i686 (CityFan)
               Not found
           Available: libtdb-1.2.12-2.fc20.x86_64 (fedora)
               libtdb.so.1(TDB_1.2.1)(64bit)
Error: Package: python-libs-2.6.6-66.el6_8.i686 (CityFan)
           Requires: libdb-4.7.so
           Available: db4-4.7.25-22.el6.i686 (CityFan)
               libdb-4.7.so
Error: Package: mod_security-2.7.5-3.fc20.x86_64 (@updates)
           Requires: liblber-2.4.so.2()(64bit)
           Removing: openldap-2.4.39-4.fc20.x86_64 (installed)
               liblber-2.4.so.2()(64bit)
           Updated By: openldap-2.4.40-16.el6.i686 (CityFan)
               Not found
           Available: openldap-2.4.36-4.fc20.x86_64 (fedora)
               liblber-2.4.so.2()(64bit)
Error: Package: sudo-1.8.12-1.fc20.x86_64 (@updates)
           Requires: /usr/bin/vi
           Removing: 2:vim-minimal-7.4.475-2.fc20.x86_64 (installed)
               Not found
           Updated By: 2:vim-minimal-7.4.629-5.el6_8.1.i686 (CityFan)
               Not found
           Available: 2:vim-minimal-7.4.027-2.fc20.x86_64 (fedora)
               Not found
Error: Package: mailx-12.5-11.fc20.x86_64 (installed)
           Requires: libssl3.so()(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libssl3.so()(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libssl3.so()(64bit)
Error: Package: 12:dhclient-4.2.7-2.fc20.x86_64 (installed)
           Requires: liblber-2.4.so.2()(64bit)
           Removing: openldap-2.4.39-4.fc20.x86_64 (installed)
               liblber-2.4.so.2()(64bit)
           Updated By: openldap-2.4.40-16.el6.i686 (CityFan)
               Not found
           Available: openldap-2.4.36-4.fc20.x86_64 (fedora)
               liblber-2.4.so.2()(64bit)
Error: Package: 2:samba-common-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtdb.so.1()(64bit)
           Removing: libtdb-1.3.1-1.fc20.x86_64 (installed)
               libtdb.so.1()(64bit)
           Updated By: libtdb-1.3.8-3.el6_8.2.i686 (CityFan)
               Not found
           Available: libtdb-1.2.12-2.fc20.x86_64 (fedora)
               libtdb.so.1()(64bit)
Error: Package: grep-2.20-6.el6.i686 (CityFan)
           Requires: libpcre.so.0
           Available: pcre-7.8-7.el6.i686 (CityFan)
               libpcre.so.0
           Installed: pcre-8.33-11.fc20.x86_64 (@updates)
               Not found
           Available: pcre-8.33-2.fc20.1.i686 (fedora)
              ~libpcre32.so.0
              ~libpcre16.so.0
              ~libpcre.so.1
Error: Package: libXt-1.1.4-7.fc20.x86_64 (@fedora)
           Requires: libX11.so.6()(64bit)
           Removing: libX11-1.6.1-1.fc20.x86_64 (@fedora)
               libX11.so.6()(64bit)
           Updated By: libX11-1.6.4-3.el6.i686 (CityFan)
               Not found
Error: Package: fltk-1.3.2-4.fc20.x86_64 (@updates)
           Requires: libGLU.so.1()(64bit)
           Removing: mesa-libGLU-9.0.0-5.fc20.x86_64 (@updates)
               libGLU.so.1()(64bit)
           Updated By: mesa-libGLU-11.0.7-4.el6.i686 (CityFan)
               Not found
           Available: mesa-libGLU-9.0.0-3.fc20.x86_64 (fedora)
               libGLU.so.1()(64bit)
Error: Package: 2:samba-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtevent.so.0(TEVENT_0.9.9)(64bit)
           Removing: libtevent-0.9.21-1.fc20.x86_64 (installed)
               libtevent.so.0(TEVENT_0.9.9)(64bit)
           Updated By: libtevent-0.9.26-2.el6_7.i686 (CityFan)
               Not found
           Available: libtevent-0.9.19-1.fc20.x86_64 (fedora)
               libtevent.so.0(TEVENT_0.9.9)(64bit)
Error: Package: openssh-6.4p1-8.fc20.x86_64 (@updates)
           Requires: libldap-2.4.so.2()(64bit)
           Removing: openldap-2.4.39-4.fc20.x86_64 (installed)
               libldap-2.4.so.2()(64bit)
           Updated By: openldap-2.4.40-16.el6.i686 (CityFan)
               Not found
           Available: openldap-2.4.36-4.fc20.x86_64 (fedora)
               libldap-2.4.so.2()(64bit)
Error: Package: php-pecl-jsonc-1.3.6-1.fc20.x86_64 (@updates)
           Requires: libjson-c.so.2()(64bit)
           Removing: json-c-0.11-6.fc20.x86_64 (@updates)
               libjson-c.so.2()(64bit)
           Updated By: json-c-0.11-13.el6.i686 (CityFan)
               Not found
           Available: json-c-0.11-3.fc20.x86_64 (fedora)
               libjson-c.so.2()(64bit)
Error: Package: 2:samba-client-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtevent.so.0(TEVENT_0.9.9)(64bit)
           Removing: libtevent-0.9.21-1.fc20.x86_64 (installed)
               libtevent.so.0(TEVENT_0.9.9)(64bit)
           Updated By: libtevent-0.9.26-2.el6_7.i686 (CityFan)
               Not found
           Available: libtevent-0.9.19-1.fc20.x86_64 (fedora)
               libtevent.so.0(TEVENT_0.9.9)(64bit)
Error: Package: libXxf86misc-1.0.3-7.fc20.x86_64 (@fedora)
           Requires: libX11.so.6()(64bit)
           Removing: libX11-1.6.1-1.fc20.x86_64 (@fedora)
               libX11.so.6()(64bit)
           Updated By: libX11-1.6.4-3.el6.i686 (CityFan)
               Not found
Error: Package: 2:samba-libs-4.1.17-1.fc20.x86_64 (@updates)
           Requires: libtevent.so.0(TEVENT_0.9.9)(64bit)
           Removing: libtevent-0.9.21-1.fc20.x86_64 (installed)
               libtevent.so.0(TEVENT_0.9.9)(64bit)
           Updated By: libtevent-0.9.26-2.el6_7.i686 (CityFan)
               Not found
           Available: libtevent-0.9.19-1.fc20.x86_64 (fedora)
               libtevent.so.0(TEVENT_0.9.9)(64bit)
Error: Package: 12:dhclient-4.2.7-2.fc20.x86_64 (installed)
           Requires: libldap-2.4.so.2()(64bit)
           Removing: openldap-2.4.39-4.fc20.x86_64 (installed)
               libldap-2.4.so.2()(64bit)
           Updated By: openldap-2.4.40-16.el6.i686 (CityFan)
               Not found
           Available: openldap-2.4.36-4.fc20.x86_64 (fedora)
               libldap-2.4.so.2()(64bit)
Error: Package: rpm-build-libs-4.11.3-3.fc20.x86_64 (@updates)
           Requires: libelf.so.1()(64bit)
           Removing: elfutils-libelf-0.161-6.fc20.x86_64 (@updates)
               libelf.so.1()(64bit)
           Updated By: elfutils-libelf-0.164-2.el6.i686 (CityFan)
               Not found
           Available: elfutils-libelf-0.157-1.fc20.x86_64 (fedora)
               libelf.so.1()(64bit)
Error: Package: nss-softokn-3.19.1-1.0.fc20.x86_64 (@updates)
           Requires: libnssutil3.so(NSSUTIL_3.15)(64bit)
           Removing: nss-util-3.19.1-1.0.fc20.x86_64 (@updates)
               libnssutil3.so(NSSUTIL_3.15)(64bit)
           Updated By: nss-util-3.36.0-1.el6.i686 (CityFan)
               Not found
           Available: nss-util-3.15.2-2.fc20.x86_64 (fedora)
               libnssutil3.so(NSSUTIL_3.15)(64bit)
Error: Package: curl-7.32.0-20.fc20.x86_64 (@updates)
           Requires: libsmime3.so()(64bit)
           Removing: nss-3.19.1-1.0.fc20.x86_64 (@updates)
               libsmime3.so()(64bit)
           Updated By: nss-3.36.0-8.el6.i686 (CityFan)
               Not found
           Available: nss-3.15.2-3.fc20.x86_64 (fedora)
               libsmime3.so()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Really not sure where to start on resolving this! If i check my repolist it is as follows:

Code:
repo id                                        repo name                                                  status
CityFan                                        City Fan Repo                                               5075
fedora/20/x86_64                               Fedora 20 - x86_64                                         38597
updates/20/x86_64                              Fedora 20 - x86_64 - Updates                               22459
repolist: 66131
Anybody got any pointers?

Thanks in advance

(I have had to remove a lot of the errors as the post is too big otherwise!)
 
Old 01-14-2020, 06:38 AM   #2
dc.901
Member
 
Registered: Aug 2018
Location: Atlanta, GA - USA
Distribution: CentOS 6-7; SuSE 8-12
Posts: 650

Rep: Reputation: 197Reputation: 197
Hmm; you mention "maintenance on a CentOS VM", but your repolist output shows "Fedora 20"!
Could you please clarify?
Perhaps output of: "cat /etc/*release"

Plus, Fedora 20 went EOF in 2015. https://fedoraproject.org/wiki/End_of_life
 
Old 01-14-2020, 06:45 AM   #3
Balistars1
LQ Newbie
 
Registered: Sep 2018
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by dc.901 View Post
Hmm; you mention "maintenance on a CentOS VM", but your repolist output shows "Fedora 20"!
Could you please clarify?
Perhaps output of: "cat /etc/*release"

Plus, Fedora 20 went EOF in 2015. https://fedoraproject.org/wiki/End_of_life
Sorry, you are absolutely correct, I've no idea why I thought it was CentOs!

Fedora release 20 (Heisenbug)
NAME=Fedora
VERSION="20 (Heisenbug)"
ID=fedora
VERSION_ID=20
PRETTY_NAME="Fedora 20 (Heisenbug)"
ANSI_COLOR="0;34"
CPE_NAME="cpe:/o:fedoraproject:fedora:20"
HOME_URL="https://fedoraproject.org/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=20
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=20
Fedora release 20 (Heisenbug)
Fedora release 20 (Heisenbug)
 
Old 01-14-2020, 12:32 PM   #4
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.7.1908
Posts: 4,248

Rep: Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483
The short answer is that you can't update because Fedora 20 is no longer supported.

You'll need to bring your OS to a current version (30? 31?)
 
1 members found this post helpful.
Old 01-14-2020, 12:37 PM   #5
Balistars1
LQ Newbie
 
Registered: Sep 2018
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by scasey View Post
The short answer is that you can't update because Fedora 20 is no longer supported.

You'll need to bring your OS to a current version (30? 31?)
Many thanks for your reply.

I'm assuming then that I will need to flatten this and rebuild it with a newer OS?
 
Old 01-14-2020, 12:40 PM   #6
sevendogsbsd
Senior Member
 
Registered: Sep 2017
Posts: 1,207

Rep: Reputation: 463Reputation: 463Reputation: 463Reputation: 463Reputation: 463
Not really pertinent but Fedora is a testbed OS and has a very short lifespan. Would not be my choice for a server at all. Perhaps CentOS might fit your needs better?
 
Old 01-14-2020, 12:58 PM   #7
Balistars1
LQ Newbie
 
Registered: Sep 2018
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by sevendogsbsd View Post
Not really pertinent but Fedora is a testbed OS and has a very short lifespan. Would not be my choice for a server at all. Perhaps CentOS might fit your needs better?
Ok thank you, the VPS provider have an option to change OS and the latest CentOs is in that list, so in think ill just start a fresh and migrate everything into the new OS.

Thanks again
 
Old 01-14-2020, 01:10 PM   #8
ehartman
Senior Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 1,105

Rep: Reputation: 632Reputation: 632Reputation: 632Reputation: 632Reputation: 632Reputation: 632
Quote:
Originally Posted by dc.901 View Post
Hmm; you mention "maintenance on a CentOS VM", but your repolist output shows "Fedora 20"!
But the CityFan repo showed some .el6 (RHEL/CentOS 6) packages too, like
nspr-4.19.0-1.el6.i686
so that leads to discrepencies in the dependancy lists.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: DNF (Dandified yum), the next generation of yum package manager (Fork of Yum) for Fedora system LXer Syndicated Linux News 0 08-07-2016 06:12 PM
Can yum override an exclusion in the /etc/yum.conf directory eodchop Fedora 3 12-05-2013 06:44 PM
yum install flash ... yum: command not found ... which yum ... /usr/bin/yum tg3793 Fedora 8 04-13-2011 12:25 PM
[SOLVED] Lost connection while yum'ing, can't yum now rjo98 Linux - Newbie 4 12-03-2010 12:23 PM
problem after yum yum yum (delicious) alaios Fedora 3 01-14-2009 03:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration