LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-02-2007, 03:06 PM   #1
mallarj
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Rep: Reputation: 0
Can't turn off screen saver/blanking on FC 7


I'm using Fedora Core 7 with Xorg version 1.3.0. My video card is an NVidia 6200 LE.

I have a TV connected to the TV-out (SVideo) port on my video card and an LCD monitor connected to the VGA-out port.

After X minutes of inactivity, the TV switches to static, and the monitor goes blank (and the status LED flashes to indicate there is no signal). Hitting any key or using the mouse restores both displays.

Despite all my efforts, I can't seem to disable this functionality. I'm quite sure this is DMPS in action, but the nvidia module evidently won't let you disable it. I've tried removing the DMPS Option from xorg.conf, I've tried setting BlankTime, StandbyTime, SuspendTime, OffTime, and NoPM. While these options do seem to take effect, something is overriding them.

I created a file in ~/.kde/Autostart/xset and set it to:

#!/bin/sh
/usr/bin/xset -display :0 dpms 0 0 0
/usr/bin/xset -display :0 q | logger

This works perfectly and my Standby, Suspend and Off values are all set to 0. However as soon as KDE starts up and I can open a konsole window, they have been reset to their defaults:

Standby: 600 Suspend: 1200 Off: 1800

I've checked again and again and I don't have a screen saver or DMPS option turned on anywhere that I can see (in ControlCenter for instance).

Anyone have any clues what is overriding my xorg.conf settings?
 
Old 12-02-2007, 05:04 PM   #2
David1357
Senior Member
 
Registered: Aug 2007
Location: South Carolina, U.S.A.
Distribution: Ubuntu, Fedora Core, Red Hat, SUSE, Gentoo, DSL, coLinux, uClinux
Posts: 1,302
Blog Entries: 1

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by mallarj View Post
This works perfectly and my Standby, Suspend and Off values are all set to 0. However as soon as KDE starts up and I can open a konsole window, they have been reset to their defaults:

Standby: 600 Suspend: 1200 Off: 1800

I've checked again and again and I don't have a screen saver or DMPS option turned on anywhere that I can see (in ControlCenter for instance).

Anyone have any clues what is overriding my xorg.conf settings?
You might try disabling ACPI. Try "noacpi" and "pci=nopci" appended to your kernel line in GRUB.
 
Old 12-03-2007, 09:39 AM   #3
mallarj
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by David1357 View Post
You might try disabling ACPI. Try "noacpi" and "pci=nopci" appended to your kernel line in GRUB.
While I'm sure that would work, I'd prefer to leave ACPI enabled for other reasons (like sleeping and waking up my computer)...
 
Old 12-03-2007, 06:35 PM   #4
David1357
Senior Member
 
Registered: Aug 2007
Location: South Carolina, U.S.A.
Distribution: Ubuntu, Fedora Core, Red Hat, SUSE, Gentoo, DSL, coLinux, uClinux
Posts: 1,302
Blog Entries: 1

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by mallarj View Post
I created a file in ~/.kde/Autostart/xset and set it to:

#!/bin/sh
/usr/bin/xset -display :0 dpms 0 0 0
/usr/bin/xset -display :0 q | logger

This works perfectly and my Standby, Suspend and Off values are all set to 0. However as soon as KDE starts up and I can open a konsole window, they have been reset to their defaults:

Standby: 600 Suspend: 1200 Off: 1800

I've checked again and again and I don't have a screen saver or DMPS option turned on anywhere that I can see (in ControlCenter for instance).

Anyone have any clues what is overriding my xorg.conf settings?
You might want to put a line in your Autostart file that logs a message to a file to make sure it is getting run during KDE startup.

Also, you might want to look through the KDE startup scripts to see if there are any scripts that turn on DPMS. The only KDE machine I have access to is my SUSE machine at home so you'll have to wait until I get a chance to poke around on it later.
 
Old 12-03-2007, 07:08 PM   #5
kromberg
Member
 
Registered: Feb 2007
Location: Colorado
Distribution: FC6, FC7 x86_64
Posts: 218

Rep: Reputation: 30
Code:
% xset s off; xset -dpms
Keith
 
Old 12-04-2007, 10:29 AM   #6
mallarj
LQ Newbie
 
Registered: Oct 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Keith,

Thanks for the info, but I don't think you read through my problem. I've tried using xset in my KDE Autostart files, and it works, but KDE is subsequently overriding my settings.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Blanking b0mb3r Slackware 6 03-16-2005 03:39 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
Can't turn off screen blanking DaBayer Red Hat 0 01-23-2004 08:41 AM
Hot to turn the screen saver off in RedHat 7.3? danielwpc Linux - General 3 07-28-2003 05:06 AM
RH 9.0 screen blanking corrupter Linux - Distributions 0 06-04-2003 10:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration