LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-04-2006, 11:21 PM   #1
DBabo
Member
 
Registered: Feb 2003
Distribution: Fedora {latest}
Posts: 513

Rep: Reputation: 39
Question can't play audio CD


i think i need a good doctor to fix my brains, but i can't play any audio CDs.
not those i burned , not the "factory" manufactored.
I can mount any data cd and read the datea - no problem.

I see the CD-ROM or AUDIO CD icon on KDE desktop.

olga@fc ~]$ id
uid=500(olga) gid=500(olga) groups=100(users),500(olga)
/etc/groups:
users:x:100lga
[olga@fc ~]$ ls -l /dev/hdc
brw-rw---- 1 olga users 22, 0 Sep 3 23:46 /dev/hdc
[olga@fc ~]$ ls -l /dev/cdrom
lrwxrwxrwx 1 root root 8 Sep 4 12:19 /dev/cdrom -> /dev/hdc

messages :
Sep 5 00:05:26 fc kernel: end_request: I/O error, dev hdc, sector 0
Sep 5 00:05:26 fc kernel: hdc: command error: status=0x51 { DriveReady SeekComplete Error }
Sep 5 00:05:26 fc kernel: hdc: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
Sep 5 00:05:26 fc kernel: ide: failed opcode was: unknown
Sep 5 00:05:26 fc kernel: end_request: I/O error, dev hdc, sector 4

tons of this things...
// I think i saw this lomg time ago , but i don't rememeber what is the workaround...

and i'm on : linux fc 2.6.17-1.2174_FC5

Any ideas are more than welcome. I'm feeling totally stupid ...

Oh, yes. :
Plug the cdrom * audio ) in , it will rotate it , will wait for
~ 30 secs to pop the KsCD and then it just hangs.. I can hit "Stop" - it will stop. But when i hit "Play" , i can hear the drive is responding, but nothing is happeneing.

Thank you.

P.S. xmms can play mp3 - no problem....

Last edited by DBabo; 09-04-2006 at 11:24 PM.
 
Old 09-04-2006, 11:23 PM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Can you play them as root?
 
Old 09-04-2006, 11:36 PM   #3
DBabo
Member
 
Registered: Feb 2003
Distribution: Fedora {latest}
Posts: 513

Original Poster
Rep: Reputation: 39
nope.
Added +r to all users - same thing .
It doen'st even knwo that it's audio cd...
 
Old 09-04-2006, 11:37 PM   #4
DBabo
Member
 
Registered: Feb 2003
Distribution: Fedora {latest}
Posts: 513

Original Poster
Rep: Reputation: 39
i have dvd burner and cdrw - none of them have a clue that this is audio cd...
I'm going ballistic, casue i know damn thing played CD with no problem...
 
Old 09-04-2006, 11:49 PM   #5
1dude1
Member
 
Registered: Jan 2006
Location: Steamboat Springs, CO
Distribution: hda1= swap hda2=gentoo hda3=music hda4=slackware10.2
Posts: 101

Rep: Reputation: 15
ok it is probobly a software problem in your install like a bit was dropped or some data loss in the Kscd so what i would say is install amarok and burn all of your music t oa data cd then coppy it to your hard drive and use amarok to play it
 
Old 09-04-2006, 11:54 PM   #6
DBabo
Member
 
Registered: Feb 2003
Distribution: Fedora {latest}
Posts: 513

Original Poster
Rep: Reputation: 39
totally not related - ogle works perfectly well - i mean it plays DVD with sound and good quality of picture... Daaaa.....
 
Old 09-04-2006, 11:56 PM   #7
DBabo
Member
 
Registered: Feb 2003
Distribution: Fedora {latest}
Posts: 513

Original Poster
Rep: Reputation: 39
1dude1 ,
yeah, tha'ts why i took a factory ( not home burned ) cdrom to test... The system doens't recognise it as Audio ... I mean KDE ( i guess )
 
Old 09-05-2006, 12:22 AM   #8
DBabo
Member
 
Registered: Feb 2003
Distribution: Fedora {latest}
Posts: 513

Original Poster
Rep: Reputation: 39
for this amarok installed.. it refuses to find my media drives and talks about dcop server...
I'm not sure i understand al lthis ...
 
Old 09-05-2006, 12:30 AM   #9
DBabo
Member
 
Registered: Feb 2003
Distribution: Fedora {latest}
Posts: 513

Original Poster
Rep: Reputation: 39
i think it might have smth to do with automount...

Update :
stopped the service - not working still.. I'm really puzzled.

Update 2:
i added the iso9660 to the fstab. No help.
i read about the cable that i should have . well. i don't have it.
so to get this to work i got the xmms-cdreader 9 i think , check the http://www.xmms.org/docs/readme.php for details. and it works now.
"good" part about this is that my wife will have a problem remembering what to hit in the xmms to get to the menu of playing a "location".
the menu that pops up when the media is inserted doesn't work either...

Da%%%, i was so much happier with FC4 - everything worked just fine... If not the SATA boot drive on this machine i would have moved back already....

Last edited by DBabo; 09-05-2006 at 09:22 PM.
 
Old 09-05-2006, 08:23 PM   #10
1dude1
Member
 
Registered: Jan 2006
Location: Steamboat Springs, CO
Distribution: hda1= swap hda2=gentoo hda3=music hda4=slackware10.2
Posts: 101

Rep: Reputation: 15
dude just reinstall it and it might work a chip in your comp detects errors and it deletes the errors whitch is a bit so 1 letter could have been dropped so try reinstalling it
 
Old 09-05-2006, 08:28 PM   #11
JBailey742
Member
 
Registered: Mar 2006
Location: Saint Louis Park, MN
Distribution: Mandriva 2007.1 Spring
Posts: 338

Rep: Reputation: 30
did it ever work? you have a digital audio cord running between the CD-ROM and mainboard? That's one of the first things I asked on. I saw the CD tracks, and the time going up, but no sound.
 
Old 09-05-2006, 09:24 PM   #12
DBabo
Member
 
Registered: Feb 2003
Distribution: Fedora {latest}
Posts: 513

Original Poster
Rep: Reputation: 39
Quote:
Originally Posted by 1dude1
dude just reinstall it and it might work a chip in your comp detects errors and it deletes the errors whitch is a bit so 1 letter could have been dropped so try reinstalling it
Yeah, maybe a good idea on a fresh machine , but i already have all setings and whistles and ( which is much more important ) data set up
And God Damn - it's just a stupid audio CD!!
 
Old 09-05-2006, 09:26 PM   #13
DBabo
Member
 
Registered: Feb 2003
Distribution: Fedora {latest}
Posts: 513

Original Poster
Rep: Reputation: 39
Quote:
Originally Posted by JBailey742
did it ever work? you have a digital audio cord running between the CD-ROM and mainboard? That's one of the first things I asked on. I saw the CD tracks, and the time going up, but no sound.
JBailey742,
See my "update 2" 2 posts higher . I guess ,i updated the post and you made a new one .
No, i dont' have a cable. And i never had it to begin with. And, yes, it played freaking CDs
Another smth i had to tell you is , that , the KsCd doesn't really played the tracks... It's more pop-up and hang. though it showed correct number of tracks...

Update:
Well, i have to add that it ( xmms ) works with the CDreader ( the default encoder, just i missed the setting on the configure tab - set to "play digital", instead of " play CD directly" which is default )

Last edited by DBabo; 09-05-2006 at 09:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can not play audio CD hottdogg Slackware 23 09-22-2006 10:41 AM
Audio::Play/Audio::Data DanTaylor Programming 0 02-07-2006 06:37 PM
Can't play audio cd melinda_sayang Slackware 12 03-20-2004 04:23 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 07:52 AM
play audio cd bfkeats Linux - General 4 02-06-2002 12:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration