LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-21-2015, 12:10 PM   #1
johf
LQ Newbie
 
Registered: Jun 2015
Posts: 16

Rep: Reputation: Disabled
Can't open steam on Linux Mint Debian Edition 2 with AMD Radeon 7970


I am running Linux Mint Debian Edition with an AMD Radeon 7970 and I tried to install steam and when it made me a desktop icon I clicked on it, and nothing happened. I entered steam in the terminal and got this " $ steam
Running Steam on linuxmint 2 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1433441724)
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast"
What should I do? I am a total Linux noob and don't know what I should do to fix this. I believe I need to install radeonsi drivers but I don't know how.
 
Old 06-21-2015, 12:21 PM   #2
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
You need to enable multiarch support and load the 32-bit OpenGL drivers for your card.

Follow this guide:
https://wiki.debian.org/Steam
 
Old 06-21-2015, 01:33 PM   #3
johf
LQ Newbie
 
Registered: Jun 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
You need to enable multiarch support and load the 32-bit OpenGL drivers for your card.

Follow this guide:
https://wiki.debian.org/Steam
I would like to stay away from the AMD Catalyst drivers if possible and use the open source drivers.
 
Old 06-21-2015, 01:39 PM   #4
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
Good idea
Code:
# apt-get install libgl1-mesa-dri:i386
(I think)

EDIT: Make sure you also have the firmware-linux-nonfree package to enable 3D acceleration for your card.
https://wiki.debian.org/AtiHowTo

Last edited by Head_on_a_Stick; 06-21-2015 at 01:42 PM.
 
Old 06-21-2015, 05:56 PM   #5
johf
LQ Newbie
 
Registered: Jun 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
Good idea
Code:
# apt-get install libgl1-mesa-dri:i386
(I think)

EDIT: Make sure you also have the firmware-linux-nonfree package to enable 3D acceleration for your card.
https://wiki.debian.org/AtiHowTo
Now it's saying
"$ steam
Running Steam on linuxmint 2 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0_client"
and just stays like that

Last edited by johf; 06-21-2015 at 05:57 PM.
 
Old 06-21-2015, 06:10 PM   #6
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
I don't know, it must be an LMDE issue.

I have just got Steam running on my pure Debian jessie AMD laptop (with the non-proprietary AMD drivers) using:
Code:
# dpkg --add-architecture i386
# aptitude update
# aptitude install steam
No other commands were needed (the libgl1-mesa-dri package is a dependency of steam).
 
Old 06-21-2015, 06:19 PM   #7
johf
LQ Newbie
 
Registered: Jun 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
I don't know, it must be an LMDE issue.

I have just got Steam running on my pure Debian jessie AMD laptop (with the non-proprietary AMD drivers) using:
Code:
# dpkg --add-architecture i386
# aptitude update
# aptitude install steam
No other commands were needed (the libgl1-mesa-dri package is a dependency of steam).
Wtf, I did what you said and installed those drivers and then restarted, got past the grub menu and instead of starting up normally I just get stuck on a black screen with the loading cursor (the spinning wheel thing) -_-
 
Old 06-22-2015, 06:46 AM   #8
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
Quote:
Originally Posted by johf View Post
Wtf, I did what you said and installed those drivers and then restarted, got past the grub menu and instead of starting up normally I just get stuck on a black screen with the loading cursor (the spinning wheel thing) -_-
Oh dear, sorry...

I wasn't giving instructions, I was just pointing out what works for Debian jessie to illustrate my theory that your difficulties are Mint-related.

I should have been much clearer.

Can you switch to a TTY?

Do you have any xorg configuration files?

Please post the exact commands that you entered.

EDIT: I see you have started a new thread for this:
http://www.linuxquestions.org/questi...04#post5381004

You installed the xserver-xorg-video-ati package -- did you in fact have the non-free ATI (fglrx) driver running beforehand?

Post the output of:
Code:
apt-cache policy fglrx

Last edited by Head_on_a_Stick; 06-22-2015 at 06:58 AM.
 
Old 06-22-2015, 09:22 PM   #9
johf
LQ Newbie
 
Registered: Jun 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
Oh dear, sorry...

I wasn't giving instructions, I was just pointing out what works for Debian jessie to illustrate my theory that your difficulties are Mint-related.

I should have been much clearer.

Can you switch to a TTY?

Do you have any xorg configuration files?

Please post the exact commands that you entered.

EDIT: I see you have started a new thread for this:
http://www.linuxquestions.org/questi...04#post5381004

You installed the xserver-xorg-video-ati package -- did you in fact have the non-free ATI (fglrx) driver running beforehand?

Post the output of:
Code:
apt-cache policy fglrx
All I did was run "# sudo apt-get install libgl1-mesa-dri:i386" and "# sudo apt-get install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati" and then rebooted and now I can't get past the black screen. Where/how do I enter the "apt-cache policy fglrx" you told me to enter? I told you I'm a huge noob haha, and btw this os is almost stock all I installed was Deluge, Steam, and ran those commands.

Last edited by johf; 06-22-2015 at 10:26 PM.
 
Old 06-22-2015, 09:52 PM   #10
Ihatewindows522
Member
 
Registered: Oct 2014
Location: Fort Wayne
Distribution: Ubuntu 16.04 LTS
Posts: 616
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
Quote:
Originally Posted by johf View Post
I would like to stay away from the AMD Catalyst drivers if possible and use the open source drivers.
I would like to stay away from anything with the AMD logo on it. Just as a quick comparison, my 1GB Radeon HD 5450 (PassMark score of 216) performs like a 64MB nVIDIA Geforce 4 440 Go (PassMark score of 5) under Linux (regardless of whether or not I'm using the Catalyst Omega). Pretty craptastic. So far the solution seems to be in the form of a nVIDIA GTX 750 ti. Especially with the newer cards, nVIDIA supposedly has great support for Linux. I intend to find out exactly how true that is.

You can get nVIDIA cards dirt cheap if you know what you need and know where to look.
 
Old 06-22-2015, 09:57 PM   #11
johf
LQ Newbie
 
Registered: Jun 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Ihatewindows522 View Post
I would like to stay away from anything with the AMD logo on it. Just as a quick comparison, my 1GB Radeon HD 5450 (PassMark score of 216) performs like a 64MB nVIDIA Geforce 4 440 Go (PassMark score of 5) under Linux (regardless of whether or not I'm using the Catalyst Omega). Pretty craptastic. So far the solution seems to be in the form of a nVIDIA GTX 750 ti. Especially with the newer cards, nVIDIA supposedly has great support for Linux. I intend to find out exactly how true that is.

You can get nVIDIA cards dirt cheap if you know what you need and know where to look.
So your solution to my black screen is to buy a new GPU? ok.
 
Old 06-23-2015, 01:04 PM   #12
johf
LQ Newbie
 
Registered: Jun 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
Oh dear, sorry...

I wasn't giving instructions, I was just pointing out what works for Debian jessie to illustrate my theory that your difficulties are Mint-related.

I should have been much clearer.

Can you switch to a TTY?

Do you have any xorg configuration files?

Please post the exact commands that you entered.

EDIT: I see you have started a new thread for this:
http://www.linuxquestions.org/questi...04#post5381004

You installed the xserver-xorg-video-ati package -- did you in fact have the non-free ATI (fglrx) driver running beforehand?

Post the output of:
Code:
apt-cache policy fglrx
I typed in apt-cache policy fglrx and it said none
 
Old 06-23-2015, 03:47 PM   #13
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
Quote:
Originally Posted by johf View Post
I typed in apt-cache policy fglrx and it said none
In which case I have no idea why your system is doing that.

I am really sorry but it seems I have wrecked your Mint install

I can only apologise -- I have never used Mint but I honestly thought that LMDE2 was basically Debian jessie with some Mint themes and GUI tools.

Clearly I was very wrong about this.

Perhaps some forum members who do use Mint (LMDE) will chime in with something useful...
 
Old 06-23-2015, 04:04 PM   #14
johf
LQ Newbie
 
Registered: Jun 2015
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
In which case I have no idea why your system is doing that.

I am really sorry but it seems I have wrecked your Mint install

I can only apologise -- I have never used Mint but I honestly thought that LMDE2 was basically Debian jessie with some Mint themes and GUI tools.

Clearly I was very wrong about this.

Perhaps some forum members who do use Mint (LMDE) will chime in with something useful...
Well I appreciate you trying but it's all good you almost got Steam working until I got this random black screen, I installed Mint the day you started assisting me so it was pretty much a fresh install so it's not a big deal. Thanks anyways!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Mint Debian Edition 2 Cinnamon edition Screencast and Screenshots jeremy Linux - Screencasts and Screenshots 3 04-14-2015 05:35 PM
LXer: Linux Mint Debian Edition 2 Cinnamon edition Screencast LXer Syndicated Linux News 0 04-11-2015 04:21 AM
All steam games crashing on boot with Linux Mint 14 on Radeon HD 7700 poipoi Linux - Games 2 02-21-2013 08:26 PM
LXer: AMD Radeon HD 7970 GHz - Is It Worth It On Linux? LXer Syndicated Linux News 0 06-23-2012 06:40 PM
LXer: AMD Radeon HD 7970 Open-Source Linux Update LXer Syndicated Linux News 0 12-25-2011 01:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration