LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-12-2006, 10:40 PM   #1
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Rep: Reputation: 30
Can't Mount Nero Multisession Data DVD


I am having trouble mounting some of my data dvd's. My friend runs Suse 10 and he can mount the same disk that I cannot. The disk that I am having trouble with is a multisesson disk created with nero on windows. I have had trouble with nero multisession disk in the past and left it alone.

My error when I try to mount the disk:

Quote:
$ mount /media/cdrecorder
mount: block device /dev/hdc is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
My fstab:
Quote:
/dev/hdc /media/cdrecorder auto pamconsole,fscontext=system_ubject_r:removable_t,exec,noauto,man$ 0 0
(my fstab must be good. It made a tired face)

Now here is the fstab on the Suse 10 that will mount the disk:

Quote:
subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8
I put the line in the Suse fstab into mine but that didn't work. I can't mount anything that is a nero windows multisession. Does anyone know why this is happining?

Last edited by natewlew; 04-12-2006 at 10:46 PM.
 
Old 04-13-2006, 12:29 AM   #2
raskin
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: approximately NixOS (http://nixos.org)
Posts: 1,900

Rep: Reputation: 69
Well, did you try expirementing as root with fs type? -t udf, -t iso9660 maybe something else? Also, did you try adding session= -o option (in root command-line)?
 
Old 04-13-2006, 12:33 AM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
My drives:
Code:
bruce@silas:~$ dmesg | grep -i atapi
Apr 10 15:05:32 silas kernel: hda: TSSTcorpCD/DVDW TS-H552U, ATAPI CD/DVD-ROM drive
Apr 10 15:05:32 silas kernel: hdc: PIONEER DVD-RW DVR-109, ATAPI CD/DVD-ROM drive
bruce@silas:~$ ls -l /dev/dvd
lrwxrwxrwx 1 root root 8 2006-01-27 01:32 /dev/dvd -> /dev/hda
My fstab:
Code:
/dev/cdrom       /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/hda         /dvd1            auto        noauto,users,ro  0   0
/dev/hdc         /dvd2            auto        noauto,users,ro  0   0
Everything mounts fine.
 
Old 04-13-2006, 04:23 PM   #4
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Thanks for the replies. I tried -t udf, -t iso9660 (-t udf crashed my computer). I tried:

Quote:
$ mount session= -o /dev/hda /media/cdrecorder
mount: special device session= does not exist
I also tried adding noauto,users,ro to my fstab and my error is a little different:

Quote:
mount /media/cdrecorder
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
I don't get the write protected error.

Thanks for the advice.
 
Old 04-13-2006, 04:40 PM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Did you try commenting out your previous line
Code:
/dev/hdc /media/cdrecorder auto pamconsole,fscontext=system_ubject_r:removable_t,exec,noauto,man$ 0 0
and using just this line without adding anything to it
Code:
/dev/hdc         /media/cdrecorder            auto        noauto,users,ro  0   0
The reason you get the write protected error
Code:
mount: block device /dev/hdc is write-protected, mounting read-only
is because it is an ATAPI CD/DVD-ROM drive. ROM is read-only memory. This drive cannot be mounted rw (read/write). I don't know what all that complicated line in your /etc/fstab means, and didn't issue "man fstab" or "man mount" to learn all those options, but something in there is trying to mount it rw.

Your real problem with that line is you're not getting the correct filesystem for the media you're trying to mount, or you're trying to mount something that shouldn't be mounted. What is the data on this disc you're trying to mount? Perhaps some of the filesystems aren't mountable?

When you post data such as your /etc/fstab output, use [_code_] before it and [_/code_] after it, without those underscores, and you will eliminate the smiley.
 
Old 04-13-2006, 10:11 PM   #6
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Quote:
Did you try commenting out your previous line
Quote:

/dev/hdc /media/cdrecorder auto pamconsole,fscontext=system_ubject_r:removable_t,exec,noauto,man$ 0 0
and using just this line without adding anything to it
Code:
Quote:
/dev/hdc /media/cdrecorder auto noauto,users,ro 0 0
Sorry I didn't explain myself very good. Yes I did.

The data on the disc is my digital camera backup pics. I created the disc originally when I used windows. Now I am using a different Windows computer to fill up the disc.

Normally I would agree that something is wrong with the disc, but I can mount it on a different computer that is running Suse 10.

When I replaced your line with mine. I didn't get the write protected error, but I still can't mount the disk.

Last edited by natewlew; 04-13-2006 at 10:12 PM.
 
Old 04-13-2006, 11:03 PM   #7
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
Windows CD's have joliet extensions, but no rock ridge extensions. Multisession disks require some sort of extensions. SuSE must be able to use joliet extensions for some reason unknown to me. Without rock ridge extensions on the multisession CD, most linux distros won't be able to read the multisession info.
 
Old 04-14-2006, 01:10 AM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
If all you need is joliet extensions, as AwesomeMachine (tell us about it) said, then issue:
Code:
mingdao@silas:~$ cat /usr/src/linux-2.6.16.2/.config | grep -i joliet
CONFIG_JOLIET=y
to see if you've got that enabled in your kernel. Replace my kernel PATH with yours.

If it returns "# CONFIG_JOLIET is not set", you need to rebuild your kernel. If it returns "CONFIG_JOLIET=m", then issue "modprobe joliet" as root and see if that will insert the module into your kernel.
 
Old 04-14-2006, 12:00 PM   #9
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Its says:

Quote:
CONFIG_JOLIET=y
Do you think it might work if I end the multisession next time I burn some pictures.

Last edited by natewlew; 04-14-2006 at 12:23 PM.
 
Old 04-14-2006, 05:36 PM   #10
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
I haven't a clue, primarily since I burn CD/VCD/DVDs in Slackware.

But the lack of joliet extensions wasn't your problem. I would suggest burning them in Linux rather than with Nero in Windows. You'll probably find that any OS can read them afterwards.

If you can't use "cdrecord" or another tool from CLI, then use K3B. It's a GUI tool similar to Nero. There is also Nero for Linux now, iirc, but I've never used it.

Also keep in mind that SuSE doesn't have an original kernel from Kernel.org, but a hacked SuSE version. Therefore, some things in that kernel and the SuSE distro are designed to work differently than the Linux standards. I think the same is true of CentOS.
 
Old 04-14-2006, 10:41 PM   #11
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Thanks for all of your help. I'll have to figure something out.

A couple Slackware Questions:

Is Slackware hard for a newbie?

Do you have to compile the programs you want from source?
 
Old 04-15-2006, 12:19 AM   #12
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Slackware is hard for a newbie, but worth every bit of effort for the superior Linux system you will get -- but not hard if you're willing to read and learn -- definitely hard if you want to just click and play.

In June 2003 I started with RedHat. That was hard to me, because it was mostly GUIs doing everything, and they hide what's happening. It seemed too much like Windows. Then I tried Debian. I did't know how to compile programs from source, and their "apt-get" system was broken at the time because 2 developers were arguing about an app, so it wasn't available except in the Woody (ultra stable, but also old) branch.

I'd noticed that most of the mods, and most of the posters I'd read with correct answers, were using Slackware. I read this:
Quote:
The Slackware Philosophy
Since its first release in April of 1993, the Slackware Linux Project has aimed at producing the most "UNIX-like" Linux distribution out there. Slackware complies with the published Linux standards, such as the Linux File System Standard. We have always considered simplicity and stability paramount, and as a result Slackware has become one of the most popular, stable, and friendly distributions available.
at the Slackware website, and decided to give it a try.

I'm glad. Yes, it was difficult in the beginning to learn what was happening. I also didn't use a desktop environment like KDE, but rather, the lightweight window manager Fluxbox. So there were no little icons to click and see what happened.

Slackware requires that you learn your system. Slackware doesn't have GUI frontends for anything. It requires that you learn how to do things on your own. This knowledge will be applicable on any Linux distro. So the saying: "When you learn Slackware, you learn Linux" still holds true, and always will.

If you want to install and learn Slackware, I'll post some links to help get you started. There are guides to follow that you can install and configure the basics of your system very easily. The best online IMO is by danieldk (LQ nick) titled Slackware Linux Basics and that version is for Slackware Linux 10.2 (the present stable version).

You don't have to compile anything from source, but you can if you would like. Slackware provides a C compiler, and kernel headers, and everything else you need. I've never had to add anything to my Slackware systems to compile.

Slackware's package system is very standard. It uses "tarballs" so you can use the package utilities, add them by hand, view their contents, and change them. You can get official "Slackpacks" directly from Slackware, or you can get packages from trusted sources. My favorite package repository is Eric Hameleer's repository (Alien_Bob in LQ). His track record for building packages that work is impeccable. In fact, he's contributed so much to Slackware that Pat has given him that space to store his contributions to the Slackware community.

Slackware packages are easy to install. In a terminal as root you issue "installpkg <package_name>" and it gets installed. And if you don't want a package, or it didn't work with your system for some reason, you issue "removepkg <package_name>" and everything installed is uninstalled. If you want to upgrade an app in your system, you issue "upgradepkg <package_name>" and it does.

NB: There are sources, such as LinuxPackages.net, that people will suggest to you. However, their packages aren't always reliable, and aren't necessarily built to the Slackware standards. I'd stick to official packages, or those from someone like Eric.

Last edited by Bruce Hill; 04-15-2006 at 12:21 AM.
 
Old 04-15-2006, 01:28 AM   #13
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
Slackware does sound cool.

At distowatch it says KDE is the default desktop. Will it start KDE after I install it?

I am interested in Slackware, but I couldn't find a dvd iso at the website.
 
Old 04-15-2006, 01:40 AM   #14
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Slackware after a default install brings you to a command prompt that says "login :"
At that point you must login as root, then enter your password. The very next thing
you should do is type "adduser natewlew" or whatever you'd like for the user account.
Then after creating it, type "exit" to get the login prompt again, then login as natewlew.
Then type "xwmconfig" and you can choose from about 8 window managers/desktop
environments. Then when returned to a prompt, type "startx" to start the X server.

You haven't read DaniŽl de Kok's guide yet, I see.

Don't get the Slackware CDs anywhere but from Slackware. There is no official DVD,
but I do make some of my own. If you have a running Linux system, you can get
the sources with a script of Eric's that will make a DVD for you. You can get it here
and it will require a little editing. If you want to do that, download the script and
then post back that you're ready to edit it.
 
Old 04-15-2006, 11:58 AM   #15
natewlew
Member
 
Registered: Jan 2006
Location: USA
Distribution: Any distro I can get my hands on!
Posts: 162

Original Poster
Rep: Reputation: 30
I am downloading the 4 iso images right now. I am ready to edit the script.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"fc5" mount does not recognize "smbfs" file system? bdplays Linux - Networking 6 06-28-2006 11:21 AM
Common problems explained: "kernel panic - not syncing", "unable to mount..." sundialsvcs Linux - Newbie 2 03-01-2006 12:17 PM
problems with smbfs mount-point in /etc/fstab - "mount -a" works, but not at boottime MarkSide Linux - Software 4 11-20-2005 03:30 PM
Segmentation Faults with "ls" and "mount" Mark007 Slackware 11 03-02-2005 09:45 AM
"Undeleting" data using grep, but get "grep: memory exhausted" error SammyK Linux - Software 2 03-13-2004 03:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration