LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-11-2004, 01:42 PM   #1
sureshot324
Member
 
Registered: Mar 2004
Posts: 49

Rep: Reputation: 15
Can't install glib 1.2.10 on Fedora Core 3


I'm trying to install glib 1.2.10 on my machine so i can install xmms. I seem to remember that xmms need glib/gtk 1.2 instead of the newest version 2.5 (is this correct). Anyway, ./configure works fine, but make fails. Here are the last few lines:

g_log_domain_glib -g -O2 -Wall -D_REENTRANT -c gstrfuncs.c
rm -f .libs/gstrfuncs.lo
gcc -DHAVE_CONFIG_H -I. -I. -I. -DG_LOG_DOMAIN=g_log_domain_glib -g -O2 -Wall -D_REENTRANT -c gstrfuncs.c -fPIC -DPIC -o .libs/gstrfuncs.lo
gstrfuncs.c: In function `g_printf_string_upper_bound':
gstrfuncs.c:870: error: syntax error before string constant
gstrfuncs.c:1037: error: syntax error before string constant
gstrfuncs.c:1080: error: syntax error before string constant
gstrfuncs.c:1111: error: syntax error before string constant
make[2]: *** [gstrfuncs.lo] Error 1
make[2]: Leaving directory `/home/louis/glib-1.2.10'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/louis/glib-1.2.10'
make: *** [all-recursive-am] Error 2
[root@localhost glib-1.2.10]#

Can anyone help?
 
Old 11-11-2004, 04:13 PM   #2
vasco1984
LQ Newbie
 
Registered: Nov 2003
Posts: 17

Rep: Reputation: 0
What version of gcc are you using?
 
Old 11-12-2004, 11:25 PM   #3
dracflamloc
LQ Newbie
 
Registered: Feb 2004
Posts: 12

Rep: Reputation: 0
I too would like to know how to do this. I get the same error.
 
Old 11-26-2004, 05:12 AM   #4
SirMrX
LQ Newbie
 
Registered: Nov 2004
Posts: 5

Rep: Reputation: 0
Fedora Core 3 comes with gcc 3.4.2

Anyway to see your version of gcc type in your favorite console: gcc --version
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
Fedora Core 3 Glib issues checarsner Linux - Software 8 06-10-2005 08:27 AM
Install FEdora Core 3 over Fedorda Core 2 loninappleton Fedora - Installation 5 04-16-2005 03:17 PM
If i install Fedora Core 2, can i just update to Core 3 from internet? FocusedWolf Fedora 12 02-07-2005 01:03 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration