LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-31-2005, 01:10 PM   #1
lPrentice
LQ Newbie
 
Registered: May 2005
Posts: 24

Rep: Reputation: 15
Can't find eth0 after Sarge upgrade to 2.6


Hi,

I've just upgraded to Sarge kernel-image-2.6-k7. Upgrade went smoothly except for networking functions -- system doesn't seem to find eth0.

If I ifconfig -a, I see:

lo Link encap:Local Loopback
inet ...
inet6 ...
UP LOOPBACK RUNNING

sit0 Link encap:IPv6-in-IPv4
NOARP ...


If I look in /etc/network/interfaces is see:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp


I'm guessing that the new kernel has implemented IPv6 and that /etc/network/interfaces is showing me the network configuration under my old kernel.

But now I'm stuck. I'm not sure that I need IPv6. I can't find where it is configured. And I'd like to get the new kernel talking nicely with my LAN.

Thanks in advance for your help.

Lloyd
 
Old 05-31-2005, 01:13 PM   #2
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
Originally from Dead Parrot, in another post :
QUOTE :

"If you want to turn off IPv6 system-wide, this can be done in /etc/modutils/aliases -- just find the following line and remove the # character from the beginning of the line:

# alias net-pf-10 off # IPv6

Hope it helps.
 
Old 05-31-2005, 03:25 PM   #3
lPrentice
LQ Newbie
 
Registered: May 2005
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks for the response.

Hmmm... I disabled IPv6 as suggested, then rebooted.

But

-- ifconfig -a still gives the same result
-- System still can't find eth0
-- And still can't find my LAN

So I'm still at sea.

Lloyd
 
Old 05-31-2005, 03:28 PM   #4
jonlake
Member
 
Registered: Apr 2004
Distribution: Slackware 11.0, Gentoo
Posts: 252

Rep: Reputation: 31
run lspci to see if your interface is listed there. And then make sure you have the correct module loaded for it.
 
Old 05-31-2005, 03:57 PM   #5
lPrentice
LQ Newbie
 
Registered: May 2005
Posts: 24

Original Poster
Rep: Reputation: 15
Hi,

Looks affirmative on both counts:

lspci | grep -i Ethernet returns:

Ethernet controller: Silicon Integrated Systems [SIS] SIS900 PCI Fast Ethernet (rev 82)

modprobe -v sis900 returns:

/lib/modules/2.6.8-2-k7/kernel/drivers/net/sis900.ko

I confirmed that SIS900.ko was in /lib/modules/2.6.8-2-k7/kernel/drivers/net

So, what next?

Again, thanks for your help.

Lloyd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 gone after sarge install Brother Michael Debian 10 07-31-2006 01:06 PM
Eth0 and Eth1 disappeared in Debian 3.1 Sarge... JoeneB Linux - Networking 1 11-01-2005 07:52 AM
Sarge Eth0 config problems rblampain Linux - Distributions 2 10-13-2005 10:41 PM
eth0 static config for Sarge net install Peff Linux - Networking 1 07-04-2005 07:30 AM
After installing Sarge it lost the eth0 spiri Debian 8 05-01-2004 08:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration